seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/11/19, 19:01:42


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: alles englisch nach d-u  (Read 2252 times)

0 Members and 1 Guest are viewing this topic.

Offline wodga

  • User
  • Posts: 185
alles englisch nach d-u
« on: 2015/12/06, 21:35:19 »
nach einem d-u sind sämtliche Anwendungen auf englisch. Wie kann ich die locales auf deutsch umstellen?
64bit, intel i5, GeForce GTX 650 Ti

Offline jure

  • User
  • Posts: 520
Re: alles englisch nach d-u
« Reply #1 on: 2015/12/06, 22:41:16 »
hast du mal
Code: [Select]
dpkg-reconfigure locales probiert ....
Gruss Juergen

Offline wodga

  • User
  • Posts: 185
Re: alles englisch nach d-u
« Reply #2 on: 2015/12/07, 15:36:12 »
hab ich probiert. Hat nichts bewirkt
64bit, intel i5, GeForce GTX 650 Ti

Offline musca

  • Global Moderator
  • User
  • *****
  • Posts: 725
  • sid, fly high!
Re: alles englisch nach d-u
« Reply #3 on: 2015/12/07, 16:12:06 »
Hallo wodga,

was gibt der Befehl "locale" aus?
„Es irrt der Mensch, solang er strebt.“  (Goethe, Faust)

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.719
  • we are the priests ... of the temples of syrinx
Re: alles englisch nach d-u
« Reply #4 on: 2015/12/07, 16:32:58 »
Code: [Select]
dpkg-reconfigure locales && dpkg-reconfigure console-setup && dpkg-reconfigure keyboard-configuration
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline wodga

  • User
  • Posts: 185
Re: alles englisch nach d-u
« Reply #5 on: 2015/12/08, 21:56:17 »
@musca locale:
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=nds_DE.UTF-8
LANGUAGE=de
LC_CTYPE="nds_DE.UTF-8"
LC_NUMERIC="nds_DE.UTF-8"
LC_TIME="nds_DE.UTF-8"
LC_COLLATE="nds_DE.UTF-8"
LC_MONETARY="nds_DE.UTF-8"
LC_MESSAGES="nds_DE.UTF-8"
LC_PAPER="nds_DE.UTF-8"
LC_NAME="nds_DE.UTF-8"
LC_ADDRESS="nds_DE.UTF-8"
LC_TELEPHONE="nds_DE.UTF-8"
LC_MEASUREMENT="nds_DE.UTF-8"
LC_IDENTIFICATION="nds_DE.UTF-8"
LC_ALL=
64bit, intel i5, GeForce GTX 650 Ti

Offline wodga

  • User
  • Posts: 185
Re: alles englisch nach d-u
« Reply #6 on: 2015/12/08, 22:10:16 »
@piper: Keine Änderung
64bit, intel i5, GeForce GTX 650 Ti

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.927
    • Land of the Buckeye
Re: alles englisch nach d-u
« Reply #7 on: 2015/12/08, 23:17:31 »
No guarantee ...


Keine Garantie ..



An init 3:


Code: [Select]
# apt-get purge locales

Code: [Select]
# apt-get update && apt-get install locales

Code: [Select]
# dpkg-reconfigure locales

Use the spacebar to select/unselect languages.


Benutzen Sie die Leertaste, um vorzuwählen
« Last Edit: 2015/12/08, 23:46:39 by dibl »
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline sunrat

  • User
  • Posts: 309
Re: alles englisch nach d-u
« Reply #8 on: 2015/12/09, 00:07:12 »
Possibly related? https://bugs.kde.org/show_bug.cgi?id=340982

Sorry, no German.
Entschuldigung, keine Deutsch.

Offline der_bud

  • User
  • Posts: 893
  • member
Re: alles englisch nach d-u
« Reply #9 on: 2015/12/09, 15:32:37 »
...
LANG=nds_DE.UTF-8
LANGUAGE=de
...
I realized recently that in some dropdown lists if you want to select german by typing 'de', the cursor jumps to nde_DE. But be aware that nds is Niedersachsen, do you really want Platt ;) ? Probably that's not fully translated yet. Reconfigure again and assure that you really select de_DE.UTF-8, then try again.
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline wodga

  • User
  • Posts: 185
Re: alles englisch nach d-u
« Reply #10 on: 2015/12/09, 15:36:44 »
no, no I selected:             
  • de_DE.UTF-8 UTF-8                                                                                                                                 
64bit, intel i5, GeForce GTX 650 Ti

Offline der_bud

  • User
  • Posts: 893
  • member
Re: alles englisch nach d-u
« Reply #11 on: 2015/12/10, 09:18:49 »
Then something went wrong or did not get applied, please compare your output from the post above:
@musca locale:
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=nds_DE.UTF-8
LANGUAGE=de
LC_CTYPE="nds_DE.UTF-8"
LC_NUMERIC="nds_DE.UTF-8"
LC_TIME="nds_DE.UTF-8"
LC_COLLATE="nds_DE.UTF-8"
LC_MONETARY="nds_DE.UTF-8"
LC_MESSAGES="nds_DE.UTF-8"
LC_PAPER="nds_DE.UTF-8"
LC_NAME="nds_DE.UTF-8"
LC_ADDRESS="nds_DE.UTF-8"
LC_TELEPHONE="nds_DE.UTF-8"
LC_MEASUREMENT="nds_DE.UTF-8"
LC_IDENTIFICATION="nds_DE.UTF-8"
LC_ALL=

versus mine

Code: [Select]
LANG=de_DE.UTF-8
LANGUAGE=de
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=
Note the difference, nds_DE and de_DE.
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline wodga

  • User
  • Posts: 185
Re: alles englisch nach d-u
« Reply #12 on: 2015/12/11, 14:00:06 »
with a little help, in the irc I got now locale:
LANG=de_DE.UTF-8
LANGUAGE=de
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=

what solved the problem was locale-gen "de_DE.UTF-8"
« Last Edit: 2015/12/11, 14:05:10 by wodga »
64bit, intel i5, GeForce GTX 650 Ti