seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/02/25, 17:33:36


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [SOLVED] New Pkg xserver-xorg-input-libinput Breaks Tap-to-Click on Touchpads  (Read 4907 times)

0 Members and 1 Guest are viewing this topic.

Offline KrunchTime

  • User
  • Posts: 183
I'm unable to enable tap-to-click for my Logitech Wireless Touchpad on my desktop using synclient commands and tap-to-click no longer works on my laptop (Focalpoint touchpad).  Hopefully this is just a transition issue (libinput replacing evdev and synclient).  Having to constantly click a touchpad is a pain in the rump.
« Last Edit: 2016/04/29, 02:50:19 by KrunchTime »

Offline mithat

  • User
  • Posts: 14
Here's a link to my fix. I ended up removing xserver-xorg-input-libinput becuase even after the fix, touchpad behavior was still a bit wonky.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.394
The solution is quite easy.
You have to check, if /etc/X11 has a xorg.conf.d. directory. If not, you need to create that:
Code: [Select]
mkdir -p xorg.conf.d

After that you copy

Code: [Select]
/usr/share/X11/xorg.conf.d/60-libinput.confinto the new directory.


There you locate the section with the Identifier
Code: [Select]
libinput touchpad catchall

You add the option
Code: [Select]
Option "Tapping" "on"to that.
Other Options can befound in the manpage of libinput


greetz
devil
« Last Edit: 2016/06/02, 00:27:22 by devil »

Offline KrunchTime

  • User
  • Posts: 183
Thank you very much, devil.  I made the assumption that libinput was just a library and hence, no manpage.

Offline mithat

  • User
  • Posts: 14
FWIW, @devil's post got me curious about the different xorg configuration directories (/usr/share/X11/xorg.conf.d and /etc/X11/xorg.conf.d in this case).

According to the docs:
Quote
Xorg uses a configuration file called xorg.conf and files ending in the suffix .conf from the directory xorg.conf.d for its initial setup. The xorg.conf configuration file is searched for in the following places when the server is started as a normal user:

/etc/X11/<cmdline>
/usr/etc/X11/<cmdline>
/etc/X11/$XORGCONFIG
/usr/etc/X11/$XORGCONFIG
/etc/X11/xorg.conf
/etc/xorg.conf
/usr/etc/X11/xorg.conf.<hostname>
/usr/etc/X11/xorg.conf
/usr/lib/X11/xorg.conf.<hostname>
/usr/lib/X11/xorg.conf

and

Quote
Finally, configuration files will also be searched for in directories reserved for system use. These are to separate configuration files from the vendor or 3rd party packages from those of local administration. These files are found in the following directories:

/usr/share/X11/xorg.conf.d
/usr/share/X11/xorg.conf.d

So, /usr/share/X11/xorg.conf.d isn't the right place to make local user modifications, which in retrospect makes sense given the FHS.
 

Offline KrunchTime

  • User
  • Posts: 183
@mithat:  Interesting; I always wondered why there were similar files and folders in various locations.  Thank you for sharing the results of your research.

@devil:  Thank you, my German brother.  Your solution worked perfectly.  Odd thing is, info pages say the value for the Tapping option is boolean, but using "on" works fine.

Now it will be interesting to see if palm detection using libinput works for the Focalpoint touchpad on my laptop...fingers crossed.
« Last Edit: 2016/04/29, 02:53:11 by KrunchTime »

Offline linearJim

  • User
  • Posts: 32
hi
i had the same problem and devil`s solution worked great,thanks devil

here
says  that palm detection is enabled by default with trackpoints.


does you DE`s mouse settings work?
i am in xfce4 and does not pick the values when trying to decrease acceleration, also, if i remember correctly, it had some settings that now are gone, ex "Disable when typing" etc..

i fixed it by manually editing the file that devil said but i was wondering if anyone has problems with its DE settings

Offline KrunchTime

  • User
  • Posts: 183
Palm detection for the Focalpoint trackpad on my laptop either is not enabled by default or it does not work.  I'm going to try and set it using the configuration file.


I do not use a true DE.  I use the Openbox window manager and the Tint2 panel as my DE; BunsenLabs Linux.

Edit:  Confirmed...setting the option via the configuration file enables palm detection:
Code: [Select]
Option "DisableWhileTyping" "1"
Now I need to figure out how to set a three-finger tap to equal a right-click.  I've also noticed that double-clicking a folder to open it usually doesn't work for some reason, although I haven't tested whether it's just an anomaly under SpaceFM, which is my file manager to use this week.  I switch between 3 different file managers on a weekly basis.
« Last Edit: 2016/04/29, 14:37:31 by KrunchTime »

Offline mithat

  • User
  • Posts: 14
Middle button emulation isn't working for me. Is anyone else having this problem?
Code: [Select]
$ cat /etc/X11/xorg.conf.d/90-touchpad.conf
Section "InputClass"
        Identifier "MyTouchpad"
        MatchIsTouchpad "on"
        Driver "libinput"
        Option "Tapping" "on"
        Option "MiddleEmulation" "1"
        Option "DisableWhileTyping" "1"
EndSection

Offline linearJim

  • User
  • Posts: 32
i did like this and it worked

Code: [Select]
Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Option "Tapping" "on"
        Option "AccelSpeed" "-0.7"
        Driver "libinput"
EndSection

you can also check it with

Code: [Select]
xinput list-props <device-id>
and i believe you need to restart xorg

Offline mithat

  • User
  • Posts: 14
An update on my middle-click emulation issue: The trackpad in question is an Alps, and Googling for solutions suggests Alps pads currently present emulated middle click issues for libinput. In my case, the problem may be compounded by the fact that my trackpad has a physical third button (there are three buttons between the pad and the keyboard--I prefer using the two buttons below the pad). I think it's probably best if I defer this issue upstream.

Offline KrunchTime

  • User
  • Posts: 183
After a few days of use, I've noticed that tap-to-click sensitivity isn't as sensitive as I would like.  Sometimes a tap doesn't register.  I also do not see any option in the info pages to adjust tap sensitivity like there is with synclient.

Offline dal

  • User
  • Posts: 36
Quick side note:

I Just did a d-u for the first time in weeks and I had the same problem with disabled tapping afterwards. By following devil's instructions it still only worked in the login screen, but not in KDE.

If anyone has the same problem: you might want to have a look at the KDE system settings. At least in my case it was disabled there as well for some reason.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.394
Krunchtime,
I am ok on my thinkpad, on a cheap Acer notebook it could be more sensitive too. Had no time to look into that though.


dal,
nope, this did not occur here on three kde machines.


greetz
devil

Offline dal

  • User
  • Posts: 36
dal,
nope, this did not occur here on three kde machines.

Interesting, because I certainly didn't switch it off myself.

But I guess my KDE installation is a bit messed up anyway. Switching from one window to another often fails, for instance – the window will just freeze until I switch to a different window and back. But that's a problem for another thread. Or maybe it's just time for a clean new installation.

However, thanks for your solution to the touchpad problem  :)