seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/08/07, 12:17:24


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Cleanup of outdated policykit packages  (Read 1609 times)

0 Members and 1 Guest are viewing this topic.

Offline musca

  • Global Moderator
  • User
  • *****
  • Posts: 725
  • sid, fly high!
Cleanup of outdated policykit packages
« on: 2016/05/29, 19:02:12 »
Hello,

last year we had an incident with broken policykit and I just found out, debian still uses lower version numbers than our temporary fix package. (Higher versions from experimental didn't make it into unstable during the whole time.) 
Let's downgrade to the newest version from debian unstable.

root@sidbox:~# dpkg -l | grep 0.112-5.3.1~really-0.105-8  # lists packages of outdated version number
ii  gir1.2-polkit-1.0                                   0.112-5.3.1~really-0.105-8           amd64        GObject introspection data for PolicyKit
ii  libpolkit-agent-1-0:amd64                           0.112-5.3.1~really-0.105-8           amd64        PolicyKit Authentication Agent API
ii  libpolkit-backend-1-0:amd64                         0.112-5.3.1~really-0.105-8           amd64        PolicyKit backend API
ii  libpolkit-gobject-1-0:amd64                         0.112-5.3.1~really-0.105-8           amd64        PolicyKit Authorization API
ii  policykit-1                                         0.112-5.3.1~really-0.105-8           amd64        framework for managing administrative policies and privileges

root@sidbox:~# dpkg -l | awk '/0.112-5.3.1~really-0.105-8/ {print $2"=0.105-15"}'  # print test output with current version appended
gir1.2-polkit-1.0=0.105-15
libpolkit-agent-1-0:amd64=0.105-15
libpolkit-backend-1-0:amd64=0.105-15
libpolkit-gobject-1-0:amd64=0.105-15
policykit-1=0.105-15

root@sidbox:~# apt-get install $(dpkg -l | awk '/0.112-5.3.1~really-0.105-8/ {print $2"=0.105-15"}')   # downgrade packages
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be DOWNGRADED:
  gir1.2-polkit-1.0 libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0 policykit-1
0 upgraded, 0 newly installed, 5 downgraded, 0 to remove and 0 not upgraded.
Need to get 189 kB of archives.
After this operation, 5,120 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://mirror.unitedcolo.de/debian unstable/main amd64 libpolkit-gobject-1-0 amd64 0.105-15 [42.6 kB]
Get:2 http://mirror.unitedcolo.de/debian unstable/main amd64 libpolkit-agent-1-0 amd64 0.105-15 [23.5 kB]
Get:3 http://mirror.unitedcolo.de/debian unstable/main amd64 gir1.2-polkit-1.0 amd64 0.105-15 [15.9 kB]
Get:4 http://mirror.unitedcolo.de/debian unstable/main amd64 libpolkit-backend-1-0 amd64 0.105-15 [45.0 kB]
Get:5 http://mirror.unitedcolo.de/debian unstable/main amd64 policykit-1 amd64 0.105-15 [62.0 kB]
Fetched 189 kB in 0s (233 kB/s)     
dpkg: warning: downgrading libpolkit-gobject-1-0:amd64 from 0.112-5.3.1~really-0.105-8 to 0.105-15
(Reading database ... 539750 files and directories currently installed.)
Preparing to unpack .../libpolkit-gobject-1-0_0.105-15_amd64.deb ...
Unpacking libpolkit-gobject-1-0:amd64 (0.105-15) over (0.112-5.3.1~really-0.105-8) ...
dpkg: warning: downgrading libpolkit-agent-1-0:amd64 from 0.112-5.3.1~really-0.105-8 to 0.105-15
Preparing to unpack .../libpolkit-agent-1-0_0.105-15_amd64.deb ...
Unpacking libpolkit-agent-1-0:amd64 (0.105-15) over (0.112-5.3.1~really-0.105-8) ...
dpkg: warning: downgrading gir1.2-polkit-1.0 from 0.112-5.3.1~really-0.105-8 to 0.105-15
Preparing to unpack .../gir1.2-polkit-1.0_0.105-15_amd64.deb ...
Unpacking gir1.2-polkit-1.0 (0.105-15) over (0.112-5.3.1~really-0.105-8) ...
dpkg: warning: downgrading libpolkit-backend-1-0:amd64 from 0.112-5.3.1~really-0.105-8 to 0.105-15
Preparing to unpack .../libpolkit-backend-1-0_0.105-15_amd64.deb ...
Unpacking libpolkit-backend-1-0:amd64 (0.105-15) over (0.112-5.3.1~really-0.105-8) ...
dpkg: warning: downgrading policykit-1 from 0.112-5.3.1~really-0.105-8 to 0.105-15
Preparing to unpack .../policykit-1_0.105-15_amd64.deb ...
Created symlink /run/systemd/system/polkitd.service → /dev/null.
Unpacking policykit-1 (0.105-15) over (0.112-5.3.1~really-0.105-8) ...
Processing triggers for libc-bin (2.22-9) ...
Processing triggers for dbus (1.10.8-1) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for siduction-dynamic-dms (2016.01.31) ...
Setting up libpolkit-gobject-1-0:amd64 (0.105-15) ...
Setting up libpolkit-agent-1-0:amd64 (0.105-15) ...
Setting up gir1.2-polkit-1.0 (0.105-15) ...
Setting up libpolkit-backend-1-0:amd64 (0.105-15) ...
Setting up policykit-1 (0.105-15) ...
Removed /run/systemd/system/polkitd.service.
Processing triggers for libc-bin (2.22-9) ...


Well, we are back to business and will get updates from unstable in the future.

Cheers
musca
« Last Edit: 2016/06/17, 11:02:03 by musca »
„Es irrt der Mensch, solang er strebt.“  (Goethe, Faust)