seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/09/22, 23:18:36


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: PC-Speaker Sound deaktivieren  (Read 669 times)

0 Members and 1 Guest are viewing this topic.

Offline whistler_mb

  • User
  • Posts: 151
PC-Speaker Sound deaktivieren
« on: 2018/07/09, 17:54:24 »
Moin Siducer,

seit einiger Zeit nervt mich wieder der PC-Speaker Ton auf meinem Laptop. Bisher hatte ich es immer so gelöst, dass ich pcspkr Modul auf blacklist gesetzt hatte. Das ist auch immer noch so. Trotzdem höre ich diesen lauten Ton wieder. Er kommt zum Beispiel bei einer Systemmeldung in einer RDP Verbindung. Ebenso, kommt der Ton bei Meldungen von Applikationen, die mit wine laufen.

Der Ton wird allerdings nicht mehr vom Speaker ausgeben, sondern über die Soundkarte. Daher ist es mir auch nicht gleich aufgefallen, weil ich den Ton meist aus habe.

Es gibt dafür ein eigens Modul snd_pcsp, dass die Ausgabe des Speaker Tons über die Soundkarte realisieren soll, doch leider bleibt der Ton bestehen, auch wenn das Modul entladen wurde.

Ich konnte bei PA-Einstellungen auch keine Geräte entdecken, die eine Auswirkung haben.

Im Netz finde ich nur Informationen zum eigentlichen pcspkr Modul und das mit der dessen Deaktivierung der Ton aus ist, aber das hilft bei mir nicht mehr. Vielleicht kann einer von euch mir helfen.

###translated by deepl###
Hi Siducer,

the PC speaker sound on my laptop has been bugging me again for some time. So far I had always solved it in such a way that I had set pcspkr module to blacklist. It still is. Nevertheless, I hear that loud sound again. For example, it appears in a system message in an RDP connection. Likewise, the sound comes from applications running with wine.

However, the sound is no longer output from the speaker, but from the sound card. That's why I didn't notice it right away, because I usually have the sound off.

There is a special module snd_pcsp for this purpose, which should realize the output of the speaker sound via the sound card, but unfortunately the sound remains, even if the module has been unloaded.

I couldn't find any devices with PA settings that had an effect.

On the internet I only find information about the actual pcspkr module and that deactivates the sound, but that doesn't help me anymore. Maybe one of you can help me.


Code: [Select]
# cat /etc/modprobe.d/pcspkr-blacklist.conf
blacklist pcspkr
blacklist snd_pcsp

Code: [Select]
# lsmod | grep snd
snd_hda_codec_hdmi     57344  1
snd_hda_codec_via      24576  1
snd_hda_codec_generic    86016  1 snd_hda_codec_via
snd_hda_intel          45056  4
snd_hda_codec         151552  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_via
snd_hda_core           94208  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_via
snd_hwdep              16384  1 snd_hda_codec
snd_pcm               118784  4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core
snd_timer              36864  1 snd_pcm
snd                    94208  16 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_timer,snd_hda_codec_via,snd_pcm
soundcore              16384  1 snd

Code: [Select]
# inxi -A
Audio:     Card-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio driver: snd_hda_intel
           Card-2: Intel 8 Series/C220 Series High Definition Audio driver: snd_hda_intel
           Sound Server: ALSA v: k4.17.5-towo.1-siduction-amd64
« Last Edit: 2018/07/09, 17:59:58 by whistler_mb »