seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/09/18, 01:07:33


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [systemd] Timed out waiting for device dev-disk-by  (Read 8768 times)

0 Members and 1 Guest are viewing this topic.

Offline brummer

  • User
  • Posts: 270
    • http://guitarix.sourceforge.net/
Re: [systemd] Timed out waiting for device dev-disk-by
« Reply #15 on: 2018/07/20, 05:25:22 »
Ich denke, wir haben das gleiche Problem. Daher würde es mich brennend interessieren, ob Du es zwischenzeitlich "sauber" lösen konntest.

Hi

Nö, meine Kiste läuft immer noch genau so wie oben beschrieben. Das funktioniert ohne Probleme, so das ich nicht mehr nach einer anderen Lösung gesucht habe.

Offline df8oe

  • User
  • Posts: 103
  • Linux von Innen
    • DF8OE
Re: [systemd] Timed out waiting for device dev-disk-by
« Reply #16 on: 2018/07/20, 05:58:06 »
Wenn ich doch da nur logtechnisch weiter käme! Er sagt zwar, dass die Mounts "timed out" sind, aber sie sind trotzdem schon gemounted, wenn ich in die Rescuekonsole geworfen werde. Fast so, als wenn versucht wird, doppelt zu mounten und das zweite Mal schlägt natürlich fehl.


LG
DF8OE

Offline brummer

  • User
  • Posts: 270
    • http://guitarix.sourceforge.net/
Re: [systemd] Timed out waiting for device dev-disk-by
« Reply #17 on: 2018/07/21, 05:37:54 »
Ich bin damals zu dem Schluss gekommen das ein benötigtes Modul noch nicht geladen ist (systemd arbeitet ja einiges parallel ab), deshalb habe ich den mount auf einen späteren Zeitpunkt verlegt.
Ansonsten, würde ja ein einfaches nofail in der fstab reichen, ich muss aber (später halt) nochmal mounten damit die platten zur Verfügung stehen.

Offline brummer

  • User
  • Posts: 270
    • http://guitarix.sourceforge.net/
Re: [systemd] Timed out waiting for device dev-disk-by
« Reply #18 on: 2018/07/21, 08:51:35 »
Ich habe jetzt nochmal geguckt, es ist so das die mount services vom systemd-fstab-generator beim Systemstart generiert werden (siehe /run/systemd/generator).  Es ist quasi nicht möglich hier die Reihenfolge der Ausführung zu verändern.
systemd-fstab-generator kann aber abgeschaltet werden, mit dem boot Parameter fstab=no wird die Erzeugung der mount services verhindert, und man kann seinen eigenen Service schreiben und nutzen.
Ein mount der Partitionen zu einem späteren Zeitpunkt funktioniert hier einwandfrei.

Offline df8oe

  • User
  • Posts: 103
  • Linux von Innen
    • DF8OE
Re: [systemd] Timed out waiting for device dev-disk-by
« Reply #19 on: 2018/07/21, 09:31:02 »
Ich habe eben auch nochmal getestet. Erstaunlicherweise ist das System, wenn ich an ALLE mounts in der fstab ein nofail eintrage, hochgefahren - wenn auch nicht fehlerfrei. Ich landete auf der Konsole, obwohl der X-Server und kdm gestartet werden sollen. Die Untersuchung der systemd-Protokolle ergab einen Fehler beim Starten von apparmor - es wurde gemeckert, dass die Datei freedesktop.org in /etc/apparmor.d/abstractions nicht gelesen werden konnte. Stimmt - die gab es da auch nicht - aber eine freedesktop.org.dpkg-dist... Diese habe ich wieder aktiviert. Danach bootet bei mir das System wieder in die grafische Oberfläche, es sind alle Dateisysteme gemounted (obwohl "nofail" in der fstab steht), es läuft einfach alles. Der Fehler mit apparmor steht übrigens NICHT in den Logs, wenn das "nofail" weg ist! Dann startet apparmor - aber ich lande wegen des timeouts immer in der Rescue-Konsole.


Jetzt - mit der umkopierten freedesktop.org UND dem nofail - läuft alles. Als nächstes werde ich mal apparmor deaktivieren - mal schauen, was dann passiert. Da ist irgendeine Reihenfolge beim Booten durcheinandergekommen - das denke ich auch.


LG
DF8OE

Offline brummer

  • User
  • Posts: 270
    • http://guitarix.sourceforge.net/
Re: [systemd] [solved]Timed out waiting for device dev-disk-by
« Reply #20 on: 2018/07/22, 06:09:51 »
Okay, ich habe jetzt für mich eine saubere Lösung.

Ich habe in meiner fstab eine direktive für systemd eingetragen um den mount auf einen späteren zeitpunkt zu verlegen. Einen eigen service brauche ich jetzt nicht mehr. Meine fstab sieht jetzt so aus:

Code: [Select]
UUID=4ea712e1-25a7-4749-bbe9-0e6bb80b81d0       /                    ext4         defaults,noatime,errors=remount-ro           0    1   
UUID=6d240a14-9a87-4b93-9b4b-6458a7f0ebaa       /home                ext4         defaults,nofail,noatime,x-systemd-after=systemd-udevd-kernel.socket,errors=remount-ro           0    2 
UUID=e59da633-c3ad-4b2c-8ba2-f134c4f3d110       /home/opt            ext4         defaults,nofail,noatime,x-systemd-after=systemd-udevd-kernel.socket,errors=remount-ro           0    2   
UUID=c57a4047-41bf-484b-a3e9-e81ed50534f6       none                 swap         nofail,x-systemd-after=systemd-udevd-kernel.socket,ssw                                           0    0   

wobei nofail jetzt wahrscheinlich wieder raus-kann, da der mount einwandfrei funktioniert. Der entscheidende eintrag ist:
Code: [Select]
x-systemd-after=systemd-udevd-kernel.socket
zu diesem Zeitpunkt sind alle benötigten module geladen.


Offline df8oe

  • User
  • Posts: 103
  • Linux von Innen
    • DF8OE
Re: [systemd] Timed out waiting for device dev-disk-by
« Reply #21 on: 2018/07/22, 11:35:34 »
Super - genial - danke für deine Mühe. Da habe ich Dich doch noch mal motivieren können  ;) . Alleine wäre ich nicht soweit gekommen.


LG
DF8OE