seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/08/22, 09:43:56


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Installation on Acer Travelmate B117 (success - after some UEFI boot troubles)  (Read 5947 times)

0 Members and 1 Guest are viewing this topic.

Offline qord

  • User
  • Posts: 22
I recently bought an Acer Travelmate B117 as a replacement for an ageing Samsung N220 netbook.

The notebook came preloaded with Win7 Pro and had recovery parititons for Win7 & Win10. Curiously, the notebook had separate system and data partitions - maybe because the notebook is aimed at educational institutions which would make re-imaging the notebook easier when user data is separate...

I recovered it to Win10 which set the BIOS to UEFI mode & secure boot.

To install siduction I turned off secure boot (note: you must set a "supervisor password" to access these settings...) and resized the data partition to make space for a system partition and a swap partition.

For installation I used a freshly build KDE-AMD64 image (thanks musca!) written to an USB stick.

Booting from the stick worked without issues, apart from the touchpad not working (I later found out that this can be fixed in the BIOS settings: Switching the touchpad from "advanced" to "basic" did the trick).

The installation went more or less smooth, but after a reboot, the notebook stubbornly booted into windows. An UEFI boot-entry for siduction was not visible in the boot menu.

After some trial and error, these steps led to a bootable system (I hope I rembered all steps correctly):

1. Boot from USB stick again into the live system
2. Chroot into the new installation & install grub

N.B.:
* Siduction was at /dev/sda7 & EFI at /dev/sda1
* Change partition names to your setup!!!
* If you have a separate /boot partition, mount this too!

Code: [Select]
mount /dev/sda7 /mnt
mount /dev/sda1 /mnt/boot/efi
mount -o bind /dev /mnt/dev
mount -o bind /sys /mnt/sys
mount -t proc /proc /mnt/proc
chroot /mnt /bin/bash
grub-install /dev/sda
The EFI-Bootloader should now be installed (check with "efibootmgr" command), but due to some creative UEFI configuration by Acer, it can still not be selected for booting...

3. Boot from USB stick again, then select "Detect EFI bootloaders" in the initial GRUB menu.
4. In the next menu select the "siduction/grubx64.efi" to boot in the installed system. If this works, the bootloader is installed correctly, now on to the Acer bios...
5. Reboot and enter bios (F2, most likely)
6. Turn on secure boot ("Boot" -> "Secure Boot" -> "Enabled")
7. Goto "Security" -> "Select an UEFI file as trusted for executing" -> then select the "siduction/grubx64.efi" file
8. Save and reboot. The siduction grub entry should now be available in the boot menu, but when grub comes up, booting the kernel will fail because of the enabled secure boot option
9. Go into the bios again and disable secure boot, save and reboot. You should now have a working grub that can boot the system. Yay!

Interstingly the B117 comes with a preinstalled Linux (linpus or something) I expect that this is installed in legacy, not UEFI mode, because the procedure to get Linux to boot on this UEFI system is a bit ridiculous.
Honestly, Acer - was this necessary?
« Last Edit: 2016/07/01, 14:35:57 by qord »

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.902
    • Land of the Buckeye
@qord, thanks for posting this.  We are all facing installation on a UEFI system, eventually, and this could help.   :D
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

tommy_2

  • Guest
@gord, yes thanks, this makes things more understandable in dealing with UEFI "IMHO".   :)