seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/04/04, 17:31:30


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [done] Let's get ready to rumble - perl transition started  (Read 1780 times)

0 Members and 1 Guest are viewing this topic.

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.800
    • g-com.eu
Nach einer endlos langen langweiligen Zeit ohne tiefgreifende Änderungen ist es endlich wieder soweit, das neue perl 5.24 ist im Anrollen - bitte Augen auf beim upgraden.

After a long time of boring silence sid is back with a new and shiny transition - the perl 5.24 is just started. Have fun

https://release.debian.org/transitions/html/perl5.24.html
« Last Edit: 2016/09/28, 15:01:19 by musca »
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline mylo

  • User
  • Posts: 921
Re: Lets get ready to rumble - perl transition started
« Reply #1 on: 2016/09/24, 04:01:42 »
Danke für den Hinweis!
Code: [Select]
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 dictionaries-common : Hängt ab von: libtext-iconv-perl soll aber nicht installiert werden
Ist ongoing.
Regards mylo
____________________________________________ ____
"Die gefährlichste aller Weltanschauungen ist die Weltanschauung der Leute,
welche die Welt nicht angeschaut haben."               Alexander von Humboldt

Offline terroreek

  • User
  • Posts: 170
Re: Lets get ready to rumble - perl transition started
« Reply #2 on: 2016/09/24, 21:54:13 »
Would this explain the error I am getting today from apt?

Code: [Select]
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Error!
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libenchant1c2a : Depends: aspell-en but it is not going to be installed or
                           myspell-dictionary or
                           aspell-dictionary or
                           ispell-dictionary or
                           hunspell-dictionary
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.


I have no held packages

Offline agaida

  • User
  • Posts: 1.760
    • http://g-com.eu
Re: Lets get ready to rumble - perl transition started
« Reply #3 on: 2016/09/24, 21:56:57 »
yes
There's this special biologist word we use for "stable". It's "dead". ~ Jack Cohen

Offline KrunchTime

  • User
  • Posts: 183
Re: Lets get ready to rumble - perl transition started
« Reply #4 on: 2016/09/25, 00:34:07 »
@terroreek:  Thank you for bringing that up.  I'm getting the same error on both machines here.

@agaida:  Thank you for confirming that the perl transition is the issue.

@melmarker:  Thank you for the heads up.

Offline agaida

  • User
  • Posts: 1.760
    • http://g-com.eu
Re: Lets get ready to rumble - perl transition started
« Reply #5 on: 2016/09/25, 04:59:13 »
@KrunchTime - melmarker is the alter ego of agaida - (user account and maintainance account)
There's this special biologist word we use for "stable". It's "dead". ~ Jack Cohen

Offline HarzG

  • User
  • Posts: 110
Re: Lets get ready to rumble - perl transition started
« Reply #6 on: 2016/09/25, 22:20:07 »
Heute habe ich 2x aktualisiert. Bei der 1. Aktion wurden noch Pakete zurückgehalten und eine Teil-Aktualisierung gemacht.
Code: [Select]
Start-Date: 2016-09-25  17:56:25
Commandline: apt upgrade
Upgrade: libxcb-xfixes0:amd64 (1.11.1-1.1, 1.12-1), libxcb-present0:amd64 (1.11.1-1.1, 1.12-1), libzbar0:amd64 (0.10+doc-10+b1, 0.10+doc-10+b2), libxcb-composite0:amd64 (1.11.1-1.1, 1.12-1), libxcb-shm0:amd64 (1.11.1-1.1, 1.12-1), libxcb-randr0:amd64 (1.11.1-1.1, 1.12-1), libxcb-render0:amd64 (1.11.1-1.1, 1.12-1), libxcb1:amd64 (1.11.1-1.1, 1.12-1), libxcb-xinerama0:amd64 (1.11.1-1.1, 1.12-1), libxcb-xv0:amd64 (1.11.1-1.1, 1.12-1), libxcb-shape0:amd64 (1.11.1-1.1, 1.12-1), libxcb-damage0:amd64 (1.11.1-1.1, 1.12-1), libxcb-glx0:amd64 (1.11.1-1.1, 1.12-1), libxcb-dri2-0:amd64 (1.11.1-1.1, 1.12-1), libxcb-xtest0:amd64 (1.11.1-1.1, 1.12-1), ext4magic:amd64 (0.3.2-5, 0.3.2-6), libxcb-dri3-0:amd64 (1.11.1-1.1, 1.12-1), libxcb-xkb1:amd64 (1.11.1-1.1, 1.12-1), libxcb-sync1:amd64 (1.11.1-1.1, 1.12-1)
End-Date: 2016-09-25  17:56:38

Bei der 2. Aktion wurde alles aktualisiert.
Code: [Select]
Start-Date: 2016-09-25  22:02:21
Commandline: apt upgrade
Install: perl-modules-5.24:amd64 (5.24.1~rc3-2, automatic), libperl5.24:amd64 (5.24.1~rc3-2, automatic)
Upgrade: perl-base:amd64 (5.22.2-5, 5.24.1~rc3-2), hplip-data:amd64 (3.16.8+repack0-2, 3.16.9+repack0-1), libnet-ssleay-perl:amd64 (1.77-1, 1.77-1+b1), liblist-moreutils-perl:amd64 (0.416-1, 0.416-1+b1), printer-driver-hpcups:amd64 (3.16.8+repack0-2, 3.16.9+repack0-1), weechat-plugins:amd64 (1.5-1, 1.5-1+b1), libacme-damn-perl:amd64 (0.06-1+b1, 0.06-1+b2), liblocale-gettext-perl:amd64 (1.07-3, 1.07-3+b1), libclass-methodmaker-perl:amd64 (2.24-1+b1, 2.24-1+b2), libcurses-perl:amd64 (1.36-1, 1.36-1+b1), libterm-readkey-perl:amd64 (2.33-1+b1, 2.33-1+b2), libpango-perl:amd64 (1.227-1, 1.227-1+b1), libapt-pkg-perl:amd64 (0.1.29+b5, 0.1.29+b6), libcairo-perl:amd64 (1.106-1+b1, 1.106-1+b2), libparams-classify-perl:amd64 (0.013-6, 0.013-6+b1), weechat-core:amd64 (1.5-1, 1.5-1+b1), libsnmp30:amd64 (5.7.3+dfsg-1.5, 5.7.3+dfsg-1.5+b1), libforks-perl:amd64 (0.36-2+b1, 0.36-2+b2), hplip:amd64 (3.16.8+repack0-2, 3.16.9+repack0-1), libhpmud0:amd64 (3.16.8+repack0-2, 3.16.9+repack0-1), weechat-curses:amd64 (1.5-1, 1.5-1+b1), libglib-perl:amd64 (3:1.321-1, 3:1.321-1+b1), libio-pty-perl:amd64 (1:1.08-1.1+b1, 1:1.08-1.1+b2), firefox-l10n-de:amd64 (49.0-1, 49.0-3), libnet-idn-encode-perl:amd64 (2.300-1+b1, 2.300-1+b2), firefox-l10n-nl:amd64 (49.0-1, 49.0-3), libsane-hpaio:amd64 (3.16.8+repack0-2, 3.16.9+repack0-1), libfile-fnmatch-perl:amd64 (0.02-2+b2, 0.02-2+b3), firefox:amd64 (49.0-1, 49.0-3), perl:amd64 (5.22.2-5, 5.24.1~rc3-2), libtext-iconv-perl:amd64 (1.7-5+b3, 1.7-5+b4), libhtml-parser-perl:amd64 (3.72-2, 3.72-2+b1), libgtk2-perl:amd64 (2:1.2498-3, 2:1.2498-3+b1), libtext-charwidth-perl:amd64 (0.04-7+b4, 0.04-7+b5)
End-Date: 2016-09-25  22:03:19
Danach habe ich keine "spannenden" Meldungen gesehen.

Offline musca

  • Global Moderator
  • User
  • *****
  • Posts: 725
  • sid, fly high!
Re: Lets get ready to rumble - perl transition started
« Reply #7 on: 2016/09/26, 22:50:31 »
Hello,
transition: perl5.24 (99%) -- that was a quick transition.

I dist-upgraded without issues.

greetings
musca
„Es irrt der Mensch, solang er strebt.“  (Goethe, Faust)

Offline seasons

  • User
  • Posts: 242
Re: Lets get ready to rumble - perl transition started
« Reply #8 on: 2016/09/26, 23:01:44 »
that was a quick transition.

I dist-upgraded without issues.

Yeah, it's like one of those razor blades with (n+1) blades and 2 comfort strips: smoooth!

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.730
  • we are the priests ... of the temples of syrinx
Re: Lets get ready to rumble - perl transition started
« Reply #9 on: 2016/09/27, 00:23:53 »

:) :)

Quote
[Sunday, September 25, 2016] [6:10:31 PM EDT] <piper> Calculating upgrade... Done
[Sunday, September 25, 2016] [6:10:31 PM EDT] <piper> 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear