seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/12/16, 09:14:36


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [solved] Teamviewer 11 requires libpng12.so.0  (Read 2092 times)

0 Members and 1 Guest are viewing this topic.

Offline absolut

  • User
  • Posts: 421
[solved] Teamviewer 11 requires libpng12.so.0
« on: 2016/08/25, 20:49:22 »
Hi all,

whoever it may concern... just wanted to share my experience with latest version of teamviewer

I encountered an issue with missing GUI buttons in TeamViewer 11 (standalone edition/zipped).
Inspecting the wine error log in its folder, i'Ve encountered the error message:
Code: [Select]
err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng12.so.0
since the library libpng12 is not in the debian repos anymore, i was wondering how to fix it.
my workaround for now is to use the libpng12.so.0 that resides within the SynologyAssistant software folder (from my NAS) that i luckily have on my workstation here...

most interestingly, teamviewer 10 does not have that library issue

if there is a more usable solution (not a workaround), feedback very welcome!
best

absolut
« Last Edit: 2016/08/25, 20:57:29 by absolut »

Offline absolut

  • User
  • Posts: 421
Re: Teamviewer 11 requires libpng12.so.0
« Reply #1 on: 2016/08/25, 20:57:08 »
okay, let me also answer to my own issue...


i did not have testing or stable enabled in apt sources at all!

the solution is to enable debian stable repo and install the library from there:
Code: [Select]
apt install libpng12-0:i386


p.s. to myself: stop writing stuff on forum when tired.

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.308
Re: [solved] Teamviewer 11 requires libpng12.so.0
« Reply #2 on: 2016/08/25, 21:09:10 »
I would avoid teamviewer at all, since it is wine-bundled 32bit crap.
The better solution would be using anydeskt, it's a native 64bit app and is available for windows, mac, bsd and linux.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline absolut

  • User
  • Posts: 421
Re: [solved] Teamviewer 11 requires libpng12.so.0
« Reply #3 on: 2016/08/25, 21:23:12 »
thanks a lot for that suggestion, will try it out!

best
absolut

Offline domicius

  • User
  • Posts: 35
    • My personal ramblings
Re: [solved] Teamviewer 11 requires libpng12.so.0
« Reply #4 on: 2016/08/27, 18:42:47 »
Hi towo, I don't mean to dispute that anydesk is better solution than Teamviewer, however, having just found out about it, I immediately tried it out, wishing to replace Teamviewer with it.

But upon first run I encountered quite a few "glitches". First of all, parts of it's UI (some words/sentences) on my siduction box are not readable (font color too similar to the white background). Now, I've encountered this at least once on my system, but I can't remember when it was the last time any app behaved like that and I thought it was fixed on my system.

Second pet peeve is that I either can't find a way to save client's address or the feature is missing. Teamviewer has this helpful feature where I can "add" a client to my account (can I even have an account with AnyDesk?), categorize all the clients and access them from the list of "my clients". Is something similar available with AnyDesk?

Third offence from this short experience with AnyDesk is that I found it confusing how to close the program, on Windows client I was connected to. First of all, there were two icons in the systray and upon closing one, I can't seem to quit the program altogether. (I wasn't trying to close the program on the client I was connected to through AnyDesk, I RDP-ed to the Windows client I was testing AnyDesk with and closed AnyDesk session before I tried to close AnyDesk)

I will certainly give it a try again, but maybe you or someone else has already hit these bumps and solved them or knows more than me about them, hence this post.
Dom