seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/12/15, 06:43:15


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [solved] Warnig: No dist-upgrade  (Read 10803 times)

0 Members and 1 Guest are viewing this topic.

Offline HarzG

  • User
  • Posts: 109
Re: Warnig: No dist-upgrade
« Reply #15 on: 2016/11/25, 13:18:06 »
Quote from: devil
What irritates me in your output is build-essential debhelper dh-autoreconf dh-strip-nondeterminism. Have not seen these blocked elsewhere.
Ist bei mir auch so. For me also blocked/removed.
Code: [Select]
apt dist-upgrade -d
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  build-essential debhelper dh-autoreconf dh-strip-nondeterminism g++ g++-5 g++-6 libc6-dev libstdc++-5-dev libstdc++-6-dev
  libtool nvidia-legacy-304xx-driver virtualbox-guest-source virtualbox-guest-x11 xserver-xorg-video-intel
  xserver-xorg-video-nvidia-legacy-304xx
The following NEW packages will be installed:
  libxfont2
The following packages have been kept back:
  libc6
The following packages will be upgraded:
  libc-dev-bin libprotobuf10 virtualbox-guest-dkms virtualbox-guest-utils xserver-xorg-core xserver-xorg-input-evdev
  xserver-xorg-input-libinput xserver-xorg-input-mouse xserver-xorg-input-synaptics xserver-xorg-input-wacom
  xserver-xorg-video-amdgpu xserver-xorg-video-ati xserver-xorg-video-fbdev xserver-xorg-video-mga xserver-xorg-video-nouveau
  xserver-xorg-video-radeon xserver-xorg-video-vesa xserver-xorg-video-vmware
18 upgraded, 1 newly installed, 16 to remove and 1 not upgraded.
Need to get 7466 kB of archives.
After this operation, 131 MB disk space will be freed.
Do you want to continue? [Y/n]

Offline seasons

  • User
  • Posts: 241
Re: Warnig: No dist-upgrade
« Reply #16 on: 2016/11/25, 15:02:47 »
What irritates me in your output is build-essential debhelper dh-autoreconf dh-strip-nondeterminism. Have not seen these blocked elsewhere.

They also get removed on my system. I believe it's because of the libc multiarch issue:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=845512

Offline CCarpenter

  • User
  • Posts: 195
    • http://www.greenvalleyranchschwand.de
Re: Warnig: No dist-upgrade
« Reply #17 on: 2016/11/26, 01:11:33 »
Big thanks for the warning, devil & team!

Offline zash1958

  • User
  • Posts: 83
Re: Warnig: No dist-upgrade
« Reply #18 on: 2016/11/26, 15:15:10 »
es werden weniger Pakete die entfernt werden sollen ;-)

Code: [Select]
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete werden ENTFERNT:
  iptables virtualbox-guest-x11


Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.308
Re: Warnig: No dist-upgrade
« Reply #19 on: 2016/11/26, 15:19:57 »
Code: [Select]
apt install iptables libxtables12 libxtables11-
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline zash1958

  • User
  • Posts: 83
Re: Warnig: No dist-upgrade
« Reply #20 on: 2016/11/26, 17:05:17 »
Done :-)

Aber mit dem aktuellen Kernel 4.8.10 läuft der Nvidia Treiber "NVIDIA-Linux-x86_64-375.20" nicht. Kein GUI
Mit dem Kernel 4.8.9 tut alles wie gewünscht.

Kernel 4.8.10:
Code: [Select]
[   128.566] (II) LoadModule: "glx"
[   128.566] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   128.569] (II) Module glx: vendor="NVIDIA Corporation"
[   128.569]    compiled for 4.0.2, module version = 1.0.0
[   128.569]    Module class: X.Org Server Extension
[   128.569] (II) NVIDIA GLX Module  367.57  Mon Oct  3 20:28:17 PDT 2016
[   128.569] (II) LoadModule: "nvidia"
[   128.569] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[   128.569] (II) Module nvidia: vendor="NVIDIA Corporation"
[   128.569]    compiled for 4.0.2, module version = 1.0.0
[   128.569]    Module class: X.Org Video Driver
[   128.569] ================ WARNING WARNING WARNING WARNING ================
[   128.569] This server has a video driver ABI version of 23.0 that is not
supported by this NVIDIA driver.  Please check
http://www.nvidia.com/ for driver updates or downgrade to an X
server with a supported driver ABI.
[   128.569] =================================================================
[   128.569] (EE) NVIDIA: Use the -ignoreABI option to override this check.
[   128.569] (II) UnloadModule: "nvidia"
[   128.569] (II) Unloading nvidia
[   128.570] (EE) Failed to load module "nvidia" (module requirement mismatch, 0)
[   128.570] (EE) No drivers available.
[   128.570] (EE)
Fatal server error:
[   128.570] (EE) no screens found(EE)
[   128.570] (EE)



Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.308
Re: Warnig: No dist-upgrade
« Reply #21 on: 2016/11/26, 17:08:41 »
1. 375.20 gibt in Debian nicht!
2. "läuft nicht" sagt genau Nichts!

3. 375.20 läuft sogar mit 4.9-rcX, also werde genauer, oder lass es.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline zash1958

  • User
  • Posts: 83
Re: Warnig: No dist-upgrade
« Reply #22 on: 2016/11/26, 17:16:54 »
warum immer so grimmig?

Kernel 4.8.10 zusammen mit dem beschriebenen NVidia Treiber startet halt keinen Xserver und wirft die beigefügte Fehlermeldung
Kernel 4.8.9 funktioniert dagegen tadellos ????

Ich habe doch sogar das Logfile des vergeblichen Starts des Xservers beigefügt?

Wir hatten diese Diskussionen doch schonmal in ähnlicher Form. Damals war der Grund, dass bei einem Dist-Upgrade der Standard gcc von der Version 5 auf die Version 6 umgestellt wurde. Auch damals stand immer latent der Vorwurf des "Unmöglich/Unfähig" im Raum :-(

Muss doch BITTE wirklich nicht sein.....

NVIDIA-Linux-x86_64-375.20 habe ich gerade vor einer halben Stunde von der Nvidia Webseite heruntergeladen. Wieso soll es DEN dort nicht geben????

http://www.nvidia.de/download/driverResults.aspx/111627/de


Offline axt

  • User
  • Posts: 339
    • axebase.net
Re: Warnig: No dist-upgrade
« Reply #23 on: 2016/11/26, 17:31:19 »
"auf nvidia.com" ≠ "in Debian"

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.308
Re: Warnig: No dist-upgrade
« Reply #24 on: 2016/11/26, 17:41:59 »
Schonmal in die Fehlermeldung geschaut?


Quote
[   128.569] (II) NVIDIA GLX Module  367.57  Mon Oct  3 20:28:17 PDT 2016


Das ist nicht 375.20!

Und das hat auch Nix mit dem Kernel zu tun, sondern einfach nur, dass 367.57 mit Xserver 1.19 nicht kann!
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline zash1958

  • User
  • Posts: 83
Re: Warnig: No dist-upgrade
« Reply #25 on: 2016/11/26, 18:18:13 »
Habe den Kernel 4.8.10, die Kernel-Header dafür, den NVIDIA-Treiber 375.20 nochmals geladen.
Dann den symbolischen Link "/usr/lib/i386-linux-gnu/libEGL.so" gelöscht (der wird vom Nvidia Installer immer angemault)


Dann den Nvidia Installer nochmals laufen lassen.......
 

Jetzt tut es!

Kernel 4.8.10 startet und der Xserver tut auch !



Offline cas

  • User
  • Posts: 401
Re: Warnig: No dist-upgrade
« Reply #26 on: 2016/11/27, 00:22:05 »
Jetzt tut es!

schön, aber du hast den thread gekapert

Offline cas

  • User
  • Posts: 401
Re: Warnig: No dist-upgrade
« Reply #27 on: 2016/11/27, 00:29:13 »
Code: [Select]
apt install iptables libxtables12 libxtables11-

danke, aber es ist seltsam, dass man hier selbst tätig werden muss. sollte das nicht automatisch geschehen? ist das ein fehler von debian?

aber auch nach obigem befehl heißt es bei mir
Code: [Select]
Die folgenden Pakete werden ENTFERNT:
  virtualbox-guest-x11 xserver-xorg-input-vmmouse xserver-xorg-video-intel

gruß, c

Offline vilde

  • User
  • Posts: 657
Re: Warnig: No dist-upgrade
« Reply #28 on: 2016/11/27, 00:41:35 »
May I ask, is it ok to d-u now or? I still will get "iptables xserver-xorg-input-vmmouse" removed. So shall I wait or shall I d-u and then do as towo wrote?
Code: [Select]
apt install iptables libxtables12 libxtables11-
What about xserver-xorg-input-vmmouse?

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.308
Re: Warnig: No dist-upgrade
« Reply #29 on: 2016/11/27, 00:55:24 »
Quote
What about xserver-xorg-input-vmmouse?
What about?
Ever read the description of that package?
You have running siduction in vmware, vbox or qemu? No? Then you won't need that package.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.