seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/06/16, 19:28:05


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Linux 4.10  (Read 6024 times)

0 Members and 1 Guest are viewing this topic.

Offline musca

  • Global Moderator
  • User
  • *****
  • Posts: 725
  • sid, fly high!
Re: Linux 4.10
« Reply #15 on: 2017/02/24, 23:15:39 »
Only debian maintainers did patch the existing nvidia driver, not the vendor.
jure shows us the changelog of the debian package, which refers to debian bug #855802.
„Es irrt der Mensch, solang er strebt.“  (Goethe, Faust)

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.866
    • Land of the Buckeye
Re: Linux 4.10
« Reply #16 on: 2017/02/24, 23:26:09 »
Aha -- gut, vielen dank.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.638
    • g-com.eu
Re: Linux 4.10
« Reply #17 on: 2017/02/25, 03:47:59 »
 @dibl - to be true, i would suggest to start with 4.10 for the time being. 8)
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.866
    • Land of the Buckeye
Re: Linux 4.10
« Reply #18 on: 2017/02/25, 11:38:13 »

OK, how's this?


(1)
Code: [Select]
System:    Host: Hibiscus Kernel: 4.10.0-towo.3-siduction-amd64 x86_64 (64 bit)
           Console: tty 1
           Distro: siduction 13.2.1 December - kde - (201401272125)
Machine:   Device: desktop System: ASUS product: All Series
           Mobo: ASUSTeK model: Z87-WS v: Rev 1.xx
           BIOS: American Megatrends v: 2004 date: 06/05/2014
CPU:       Quad core Intel Core i7-4770 (-HT-MCP-) cache: 8192 KB
           clock speeds: max: 3900 MHz 1: 893 MHz 2: 862 MHz 3: 892 MHz
           4: 1415 MHz 5: 899 MHz 6: 830 MHz 7: 1872 MHz 8: 911 MHz
Graphics:  Card: NVIDIA GM107 [GeForce GTX 750 Ti]
           Display Server: X.org 1.19.1 driver: nvidia
           tty size: 82x37 Advanced Data: N/A for root out of X
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller
           driver: snd_hda_intel
           Card-2 NVIDIA Device 0fbc driver: snd_hda_intel
           Sound: ALSA v: k4.10.0-towo.3-siduction-amd64
Network:   Card-1: Intel I210 Gigabit Network Connection driver: igb
           IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Intel I210 Gigabit Network Connection driver: igb
           IF: enp9s0 state: down mac: <filter>
Drives:    HDD Total Size: 3120.6GB (29.8% used)
           ID-1: /dev/sdc model: WDC_WD1000DHTZ size: 1000.2GB
           ID-2: /dev/sda model: WDC_WD1001FALS size: 1000.2GB
           ID-3: /dev/sdb model: OCZ_VERTEX size: 120.0GB
           ID-4: /dev/sdd model: WDC_WD1000DHTZ size: 1000.2GB
Partition: ID-1: / size: 26G used: 11G (44%) fs: ext4 dev: /dev/sdb1
           ID-2: /home size: 84G used: 51G (64%) fs: ext4 dev: /dev/sdb3
           ID-3: swap-1 size: 1.07GB used: 0.00GB (0%) fs: swap dev: /dev/sdb2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 248 Uptime: 11:53 Memory: 889.1/32119.6MB
           Init: systemd runlevel: 5 Client: Shell (bash) inxi: 2.3.5
           
(2)
Code: [Select]
System:    Host: hp-350g Kernel: 4.10.0-towo.3-siduction-amd64 x86_64 (64 bit)
           Desktop: KDE Plasma 5.8.4
           Distro: siduction 14.1.0 Indian Summer - kde - (201411230337)
Machine:   Device: laptop System: Hewlett-Packard product: HP 350 G1 v: 0992100000400010000634101
           Mobo: Hewlett-Packard model: 21B7 v: KBC Version 46.0B
           UEFI [Legacy]: Insyde v: F.12 date: 06/12/2014
Battery    BAT0: charge: 23.6 Wh 93.0% condition: 25.4/25.4 Wh (100%)
CPU:       Dual core Intel Core i5-4210U (-HT-MCP-) cache: 3072 KB
           clock speeds: max: 2700 MHz 1: 900 MHz 2: 906 MHz 3: 925 MHz
           4: 916 MHz
Graphics:  Card: Intel Haswell-ULT Integrated Graphics Controller
           Display Server: X.Org 1.19.1 drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1366x768@59.99hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile
           GLX Version: 3.0 Mesa 13.0.5
Audio:     Card-1 Intel 8 Series HD Audio Controller driver: snd_hda_intel
           Card-2 Intel Haswell-ULT HD Audio Controller driver: snd_hda_intel
           Sound: ALSA v: k4.10.0-towo.3-siduction-amd64
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169
           IF: eth0 state: down mac: <filter>
           Card-2: Ralink RT3290 Wireless 802.11n 1T/1R PCIe driver: rt2800pci
           IF: wlan0 state: up mac: <filter>
Drives:    HDD Total Size: 500.1GB (15.9% used)
           ID-1: /dev/sda model: Samsung_SSD_840 size: 500.1GB
Partition: ID-1: / size: 16G used: 9.9G (67%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
Sensors:   System Temperatures: cpu: 30.0C mobo: 0.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 199 Uptime: 7 min Memory: 972.6/3878.2MB
           Client: Shell (bash) inxi: 2.3.5
    8)
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline OppaErich

  • OLE
  • User
  • Posts: 375
Re: Linux 4.10
« Reply #19 on: 2017/02/25, 12:21:28 »
Also hier tut  er's nicht. 4.9.11 spielt aber.
Code: [Select]

oppa@oppa-hex-ssd:~$ inxi -G
Graphics:  Card: NVIDIA GM204 [GeForce GTX 970]
           Display Server: X.Org 1.19.1 driver: nvidia Resolution: 1920x1080@59.93hz
           GLX Renderer: GeForce GTX 970/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 375.39


Schönes Wochenende,
Stephan


Edit: Operation not permitted ?  :-\
Code: [Select]

Feb 25 13:00:53 oppa-hex-ssd systemd-modules-load[295]: Error running install command for nvidia_drm
Feb 25 13:00:53 oppa-hex-ssd systemd-modules-load[295]: Failed to insert 'nvidia_drm': Operation not permitted
Feb 25 13:00:53 oppa-hex-ssd systemd[1]: Failed to start Load Kernel Modules.
Feb 25 13:00:53 oppa-hex-ssd systemd-udevd[357]: Error running install command for nvidia
Feb 25 13:00:55 oppa-hex-ssd gnome-session-binary[1317]: Unrecoverable failure in required component org.gnome.Shell.desktop
« Last Edit: 2017/02/25, 12:28:04 by OppaErich »

Offline ReinerS

  • User
  • Posts: 919
Re: Linux 4.10
« Reply #20 on: 2017/02/25, 20:52:48 »
Läuft hier gut mit dem Legacy-Treiber 340.x und ner 8600 GT.

Grüße

Reiner
slackware => SuSE => kanotix => sidux => aptosid  => siduction

Offline harley-peter

  • User
  • Posts: 764
Re: Linux 4.10
« Reply #21 on: 2017/03/01, 14:56:08 »
Hier funktioniert es leider nicht mit dem legacy 340.102 und einer GeForce 210

Code: [Select]
Mär 01 14:42:29 master systemd-modules-load[271]: modprobe: FATAL: Module nvidia-legacy-340xx not found in directory /lib/modules/4.10.1-towo.1-siduction-amd64
Mär 01 14:42:29 master systemd-udevd[298]: modprobe: FATAL: Module nvidia-legacy-340xx not found in directory /lib/modules/4.10.1-towo.1-siduction-amd64
Mär 01 14:42:29 master systemd-modules-load[424]: modprobe: FATAL: Module nvidia-legacy-340xx not found in directory /lib/modules/4.10.1-towo.1-siduction-amd64
Mär 01 14:42:14 master systemd-modules-load[271]: Error running install command for nvidia
Mär 01 14:42:14 master systemd-modules-load[271]: Failed to insert 'nvidia': Operation not permitted
Mär 01 14:42:15 master systemd-udevd[336]: Error running install command for nvidia
Mär 01 14:42:16 master systemd-modules-load[424]: Error running install command for nvidia
Mär 01 14:42:16 master systemd-modules-load[424]: Failed to insert 'nvidia': Operation not permitted
« Last Edit: 2017/03/01, 15:16:46 by harley-peter »

Offline Maik

  • User
  • Posts: 57
Re: Linux 4.10
« Reply #22 on: 2017/03/01, 15:29:28 »
Hat auch rumgeeiert, scheint irgendwie man wolle "neue HW schmackhaft" machen, das bei den Mondpreisen. Wie auch immer, nv-dkms purged, mit m-a lief alles bei 1x sauber durch.
"Diejenigen, die bereit sind grundlegende Freiheiten aufzugeben, um ein wenig kurzfristige Sicherheit zu erlangen, verdienen weder Freiheit noch Sicherheit." Benjamin Franklin, Verfassungsvater

Offline TM

  • User
  • Posts: 14
Re: Linux 4.10
« Reply #23 on: 2017/03/03, 01:58:23 »
Hi,

Ich habe dies gerade überflogen. Nvidia betrifft mich auch.
https://forum.siduction.org/index.php?topic=6626.msg54114#msg54114
Welcher Nvidia Treiber, bzw. Version ist denn in der Iso?
Man kann ja auch auf ältere zurückgreifen. Manche Distris bieten gleich mehrere an, also auch frühere Versionen.

Welcher Kernel ist denn in der aktuellen Iso? Irgendwie bin ich zu blöd das zu finden.
Hier (Link aus eurer Seite) wird der 4.10 als stable angegeben.
Ich kenne mich da leider nicht aus und lade gerade das Iso
siduction-16.1.0-patience-xfce-amd64-201612240021 runter

Was auch verwirrend ist, wenn man auf den Downloadserver geht, wird nicht angezeigt, welche Iso es denn nun ist. Anscheinend wird die non-free Iso gar nicht angeboten? Und in der "normalen" Iso sind auch Nvidia Treiber drin?
Denn die beiden Links
http://ftp.spline.de/pub/siduction/fixes unstable main contrib non-free 
http://ftp.spline.de/pub/siduction/fixes unstable main contrib non-free

sind beide tot.


CPU: i7-3610QM 2,3 GHz (8 Kerne intel Hyper-Threading)
GPU: Nvidia GK104GLM (Quadro K4000M)
SSD für /
24 GB Ram + 24 GB mSata SLC Cache-Modul

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.336
Re: Linux 4.10
« Reply #24 on: 2017/03/03, 07:29:03 »
Proprietäre Nvidia-Treiber liefern wir nicht aus. Was auf einem Image drauf ist, geht aus der dazugehörigen Manifest-Datei hervor, die mit dem Image zum Download steht. Oder man liest die Release Notes und erfährt, das auf den Patience-Images Kernel 4.9 drauf ist. Was du damit meinst, die beiden Links seien tot, weiß ich nicht, denn du kannst ja draufklicken und wirst feststellen, dass die höchst lebendig sind.

Offline harley-peter

  • User
  • Posts: 764
Re: Linux 4.10
« Reply #25 on: 2017/03/03, 09:58:07 »
@ReinerS:
Wie hast du den 340er Treiber mit dem Kernel 4.10 zum Laufen bekommen?

Offline TM

  • User
  • Posts: 14
Re: Linux 4.10
« Reply #26 on: 2017/03/03, 11:28:50 »
Oder man liest die Release Notes und erfährt, das auf den Patience-Images Kernel 4.9 drauf ist.

Oops, peinlich, habe ich übersehen, war schon spät gestern. Danke!
Quote
Was du damit meinst, die beiden Links seien tot, weiß ich nicht, denn du kannst ja draufklicken und wirst feststellen, dass die höchst lebendig sind.

Stimmt. Jetzt gehen sie bei mir auch. Dann waren die zu so später Stunde vielleicht schlafen, oder es wurde ein Server Update gemacht? Egal. Iso ist eh schon herunter geladen. Dauert bei mir mit meiner üblen 3000-er Leitung 1 Std. *ächz*
CPU: i7-3610QM 2,3 GHz (8 Kerne intel Hyper-Threading)
GPU: Nvidia GK104GLM (Quadro K4000M)
SSD für /
24 GB Ram + 24 GB mSata SLC Cache-Modul

Offline horo

  • User
  • Posts: 198
Re: Linux 4.10
« Reply #27 on: 2017/03/03, 11:59:31 »
Ich vermute, dass TM das vermeintliche Problem mit den toten Links dort sieht:
https://forum.siduction.org/index.php?page=7
und auf die
deb http:// ftp.spline.de/...
Zeilen geklickt hat, die (zu Recht) keinen Link darstellen.

Ciao, Martin
omnia vincit pecunia :(

Offline harley-peter

  • User
  • Posts: 764
Re: Linux 4.10
« Reply #28 on: 2017/03/13, 13:02:16 »
Hallo,

hat jemand eine Info ob und wenn ja wann Nvidia den Legacy Treiber 340.xxx aktualisiert so dass er auch mit dem Kernel 4.10 funktioniert? Auf der Nvidia Homepage war leider nichts zu finden.

Offline Geier0815

  • User
  • Posts: 460
Re: Linux 4.10
« Reply #29 on: 2017/03/13, 13:30:40 »
Der geht nicht? Hmm, bei mir mit einem Rechner mit 'ner 9800GT und einem anderen mit einer Quadro läuft Kernel 4.10 mit dem legacy 340 recht gut.
Quote from: lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GK107GL [Quadro K600] (rev a1)
Quote from: lsmod | grep nvidia
nvidia              10508440  53
drm                   275165  3 nvidia
i2c_core               26163  3 nvidia,i2c_i801,drm
Quote from: uname -a
Linux pc 4.10.1-towo.1-siduction-amd64 #1 SMP PREEMPT siduction 4.10-3 (2017-02-26) x86_64 GNU/Linux
Quote from: apt-cache policy nvidia-legacy-340xx-driver
nvidia-legacy-340xx-driver:
  Installiert:           340.102-1
  Installationskandidat: 340.102-1
  Versionstabelle:
 *** 340.102-1 800
        700 http://ftp.de.debian.org/debian testing/non-free amd64 Packages
        800 http://ftp.de.debian.org/debian unstable/non-free amd64 Packages
        100 /var/lib/dpkg/status

Hab ich was falsch gemacht?
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?