seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/12/05, 18:06:52


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Unmet depends  (Read 872 times)

0 Members and 1 Guest are viewing this topic.

Offline mylo

  • User
  • Posts: 921
Unmet depends
« on: 2017/07/22, 10:02:24 »
got this today:

Code: [Select]
Holen:72 http://cdn-fastly.deb.debian.org/debian unstable/non-free i386 Packages 2017-07-22-0218.37.pdiff [273 B]     
Holen:72 http://cdn-fastly.deb.debian.org/debian unstable/non-free i386 Packages 2017-07-22-0218.37.pdiff [273 B]     
Holen:73 http://cdn-fastly.deb.debian.org/debian unstable/non-free Translation-en 2017-07-22-0218.37.pdiff [126 B]     
Holen:73 http://cdn-fastly.deb.debian.org/debian unstable/non-free Translation-en 2017-07-22-0218.37.pdiff [126 B]     
Es wurden 15,0 MB in 9 s geholt (1.585 kB/s).                                                                         
Paketlisten werden gelesen... Fertig
E: Fehler: Unterbrechungen durch pkgProblemResolver::Resolve hervorgerufen; dies könnte durch zurückgehaltene Pakete verursacht worden sein.
Paketlisten werden gelesen...
Abhängigkeitsbaum wird aufgebaut....
Statusinformationen werden eingelesen....
Paketaktualisierung (Upgrade) wird berechnet...
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 hunspell-en-us : Hängt ab von: dictionaries-common (>= 0.10) soll aber nicht installiert werden
root@tuap:~# apt-get -f install
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 79 nicht aktualisiert.

Code: [Select]
ap-get -f install did not heal. Seems waiting is the best way.
Regards mylo
____________________________________________ ____
"Die gefährlichste aller Weltanschauungen ist die Weltanschauung der Leute,
welche die Welt nicht angeschaut haben."               Alexander von Humboldt

Offline ragupo

  • User
  • Posts: 11
Re: Unmet depends
« Reply #1 on: 2017/07/22, 10:39:21 »
Yes here too.
One hour ago i had the same, with unmet dependencies
Now apt wants to remove 87 packages.
It probably clears up in a few hours




Offline Camelot

  • User
  • Posts: 30
Re: Unmet depends
« Reply #2 on: 2017/07/22, 10:46:57 »
See the notice from melmarker: Perl Upgrade 5.26 .

I hold temporary perl

Code: [Select]
echo perl hold|dpkg --set-selectionsthen normaly apt-get -V dist-upgrade

Finaly:
Code: [Select]
The following packages have been kept back:
   libtcl-perl (1.05+ds-1+b1 => 1.05+ds-1+b3)
   perl (5.24.1-7 => 5.26.0-4)
   perl-base (5.24.1-7 => 5.26.0-4)
...
34 upgraded, 2 newly installed, 0 to remove and 3 not upgraded.
« Last Edit: 2017/07/22, 11:08:05 by Camelot »

Offline hendrikL

  • User
  • Posts: 323
Re: Unmet depends
« Reply #3 on: 2017/07/22, 12:09:39 »
https://forum.siduction.org/index.php?topic=6788.0

edit: sorry, didn't read the thread above!
So we have a double posting about the perl transition!
« Last Edit: 2017/07/22, 12:18:07 by hendrikL »