seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/12/06, 18:37:41


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [solved] Perl Upgrade 5.26  (Read 1223 times)

0 Members and 1 Guest are viewing this topic.

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.779
    • g-com.eu
[solved] Perl Upgrade 5.26
« on: 2017/07/21, 21:08:08 »
With the next sync cycle perl 5.26 hit unstable - this can and will be funny, but normally the perl transitions are fast and will only last 1-2 days. So keep calm and do not dist-upgrade until this transition is over.

http://paste.debian.net/977558/
« Last Edit: 2017/07/23, 08:46:22 by devil »
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.723
  • we are the priests ... of the temples of syrinx
Re: Perl Upgrade 5.26
« Reply #1 on: 2017/07/23, 01:24:58 »
Please pay attention to what apt says, all mirrors may not be synced yet

Here we are good, might not be the case for everyone, just wait a little longer

Code: [Select]
The following NEW packages will be installed:
  libperl5.26 perl-modules-5.26
The following packages will be upgraded:
  imagemagick imagemagick-6.q16 irssi libacme-damn-perl libapt-pkg-perl libbit-vector-perl libclass-c3-xs-perl libclass-methodmaker-perl
  libclone-perl libcommon-sense-perl libcpupower1 libcurses-perl libdate-calc-xs-perl libdatetime-perl libdbd-mysql-perl libdbd-sqlite3-perl
  libdbi-perl libdevel-caller-perl libdevel-lexalias-perl libfcgi-perl libfile-libmagic-perl libforks-perl libhtml-parser-perl
  libimage-magick-q16-perl libio-pty-perl libjson-xs-perl liblist-moreutils-perl liblocale-gettext-perl libmagickcore-6.q16-3
  libmagickcore-6.q16-3-extra libmagickwand-6.q16-3 libnet-ssleay-perl libossp-uuid-perl libpackage-stash-xs-perl libpadwalker-perl
  libparams-classify-perl libparams-util-perl libparams-validate-perl libscalar-list-utils-perl libsnappy1v5 libsnappy1v5:i386
  libsocket6-perl libsub-identify-perl libsub-name-perl libsvn-perl libterm-readkey-perl libtext-bidi-perl libtext-iconv-perl
  libunicode-string-perl libvariable-magic-perl libxml-libxml-perl libxml-libxslt-perl libxml-parser-perl libyaml-libyaml-perl
  linux-cpupower linux-libc-dev perl perl-base
58 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/19.5 MB of archives.
After this operation, 41.0 MB of additional disk space will be used.
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.377
Re: Perl Upgrade 5.26
« Reply #2 on: 2017/07/23, 08:46:03 »
Done and over with. That was quick.

Offline cryptosteve

  • User
  • Posts: 675
Re: [solved] Perl Upgrade 5.26
« Reply #3 on: 2017/07/23, 10:49:54 »
I'll wait some hours ...

Code: [Select]
The following packages will be REMOVED:
  libgnome2-perl shutter
- born to create drama -
CS Virtual Travel Bug: VF6G5D

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.779
    • g-com.eu
Re: [solved] Perl Upgrade 5.26
« Reply #4 on: 2017/07/23, 12:05:16 »
@cryptosteve - gtk users has to wait a little bit longer :)

Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline cryptosteve

  • User
  • Posts: 675
Re: [solved] Perl Upgrade 5.26
« Reply #5 on: 2017/07/23, 12:18:35 »
Oh yeah,

Code: [Select]
The following packages were automatically installed and are no longer required:
  libclass-data-inheritable-perl libclass-method-modifiers-perl libcommon-sense-perl libcrypt-openssl-bignum-perl libcrypt-openssl-rsa-perl libdata-random-perl libextutils-depends-perl libextutils-pkgconfig-perl libfile-which-perl libgd-perl
  libgnome2-canvas-perl libgnome2-gconf-perl libgnome2-vfs-perl libgnome2-wnck-perl libgoo-canvas-perl libgoocanvas-common libgoocanvas3 libgtk2-appindicator-perl libgtk2-imageview-perl libgtk2-unique-perl libgtkimageview0 libhttp-server-simple-perl
  libjson-perl libjson-xs-perl libmouse-perl libnet-dropbox-api-perl libnet-oauth-perl libpath-class-perl libproc-processtable-perl libproc-simple-perl libsort-naturally-perl libtypes-serialiser-perl libunique-1.0-0 libwww-mechanize-perl
  libx11-protocol-other-perl pkg-config
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  libgnome2-perl shutter

So I think it's not [solved]
- born to create drama -
CS Virtual Travel Bug: VF6G5D

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.779
    • g-com.eu
Re: [solved] Perl Upgrade 5.26
« Reply #6 on: 2017/07/23, 12:25:06 »
So I think it's not [solved]
But, but, but it works for me™ - so it must be solved and done  8)
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline cryptosteve

  • User
  • Posts: 675
Re: [solved] Perl Upgrade 5.26
« Reply #7 on: 2017/07/23, 17:00:17 »
Hi,

now it's ok here for my cinnamon environment.

Code: [Select]
Calculating upgrade... Done
The following NEW packages will be installed:
  libperl5.26 linux-headers-4.12.3-towo.2-siduction-amd64 linux-image-4.12.3-towo.2-siduction-amd64 perl-modules-5.26
The following packages will be upgraded:
  bind9-host cpp-7 cups cups-client cups-common cups-core-drivers cups-daemon cups-ipp-utils cups-ppdc cups-server-common dnsutils fonts-opensymbol gcc-7 gcc-7-base gcc-7-base:i386 hexchat-perl hexchat-plugins hexchat-python3 ifupdown imagemagick
  imagemagick-6.q16 irssi libacme-damn-perl libapparmor1 libapt-pkg-perl libasan4 libatomic1 libbind9-140 libcairo-perl libcc1-0 libcilkrts5 libclone-perl libcommon-sense-perl libcpupower1 libcrypt-openssl-bignum-perl libcrypt-openssl-rsa-perl
  libcups2 libcupscgi1 libcupsimage2 libcupsmime1 libcupsppdc1 libcurses-perl libdns-export162 libdns162 libfcgi-perl libfile-fcntllock-perl libforks-perl libgcc-7-dev libgcc1 libgcc1:i386 libgd-perl libglib-perl libgnome2-canvas-perl
  libgnome2-gconf-perl libgnome2-perl libgnome2-vfs-perl libgnome2-wnck-perl libgomp1 libgoo-canvas-perl libgtk2-appindicator-perl libgtk2-imageview-perl libgtk2-perl libgtk2-unique-perl libhtml-parser-perl libimage-magick-q16-perl libio-pty-perl
  libisc-export160 libisc160 libisccc140 libisccfg140 libitm1 libjson-xs-perl libldap-2.4-2 liblist-moreutils-perl liblocale-gettext-perl liblsan0 liblwres141 libmagick++-6.q16-7 libmagickcore-6.q16-3 libmagickcore-6.q16-3-extra libmagickwand-6.q16-3
  libmouse-perl libmpx2 libnet-dbus-perl libnet-ssleay-perl libpango-perl libperlio-gzip-perl libproc-processtable-perl libpurple0 libquadmath0 libreoffice-avmedia-backend-gstreamer libreoffice-base-core libreoffice-calc libreoffice-common
  libreoffice-core libreoffice-draw libreoffice-gnome libreoffice-gtk3 libreoffice-impress libreoffice-math libreoffice-style-galaxy libreoffice-style-tango libreoffice-writer librsvg2-2 librsvg2-common libsnappy1v5 libsnmp30 libsocket6-perl
  libspice-server1 libstdc++6 libstdc++6:i386 libsub-name-perl libsys-cpu-perl libterm-readkey-perl libtext-iconv-perl libtracker-sparql-1.0-0 libtsan0 libubsan0 libxml-libxml-perl libxml-parser-perl libxmmsclient6 libyaml-libyaml-perl libzbar0
  linux-cpupower linux-headers-siduction-amd64 linux-image-siduction-amd64 linux-libc-dev manpages manpages-dev mosh nano perl perl-base pidgin printer-driver-escpr python3-uno tar uno-libs3 ure vim-nox weechat-core weechat-curses weechat-plugins xxd
144 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/236 MB of archives.
After this operation, 281 MB of additional disk space will be used.
- born to create drama -
CS Virtual Travel Bug: VF6G5D