seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/01/22, 08:27:13


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Timeshift not automated  (Read 268 times)

0 Members and 1 Guest are viewing this topic.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.388
Timeshift not automated
« on: 2020/01/02, 10:56:04 »
Anyone using Timeshift to do system images? I recently put together a new machine and for the life of me I can't get Timeshift to do scheduled Snapshots. They work fine manually. Researching the issue did not really help. I would love to set up a systemd.timer to do the job as I do for backups with Backintime, but due to the structure of Timeshift that is not an easy task. Everything worked fine on the old box and the setup using rsync is not really error prone. I am totally out of ideas, so any thought-provoking input is highly appreciated.

Online pjnsmb

  • User
  • Posts: 66
Re: Timeshift not automated
« Reply #1 on: 2020/01/02, 17:30:50 »
@devil


can you see the gui screen after running timeshift-gtk in a terminal ?
I have no problem using the settings screen and schedule the backup frequency  that I want

regards
pjnsmb

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.388
Re: Timeshift not automated
« Reply #2 on: 2020/01/03, 10:16:54 »
That is not the problem, the GUI works just fine and I can set a schedule, It is just not honored. No automated daily snapshots are made. No cron errors either in systemctl.

Online pjnsmb

  • User
  • Posts: 66
Re: Timeshift not automated
« Reply #3 on: 2020/01/03, 11:45:38 »
@devil
Are you using timeshift from apt or from git ?
I am running 19.08 from :
https://github.com/teejee2008/Timeshift/releases


installed by dpkg -i


 for daily and weekly backupswithout any problems but not using systemctl
regards
pjnsmb

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.388
Re: Timeshift not automated
« Reply #4 on: 2020/01/04, 06:58:11 »
Until now I am using the version in Debian, will try the version from git and see if that changes anything. Just looked at the settings in timeshift.json and they seem a bit off. Here is my settings in the GUI:
https://i.imgur.com/SkM5z4y.png
The corresponding file is:
Code: [Select]
{
  "backup_device_uuid" : "",
  "parent_device_uuid" : "",
  "do_first_run" : "true",
  "btrfs_mode" : "false",
  "include_btrfs_home" : "false",
  "stop_cron_emails" : "true",
  "schedule_monthly" : "false",
  "schedule_weekly" : "false",
  "schedule_daily" : "false",
  "schedule_hourly" : "false",
  "schedule_boot" : "false",
  "count_monthly" : "2",
  "count_weekly" : "3",
  "count_daily" : "5",
  "count_hourly" : "6",
  "count_boot" : "5",
  "snapshot_size" : "0",
  "snapshot_count" : "0",
  "exclude" : [
  ],
  "exclude-apps" : [
  ]
}
Could you compare this to yours please?

Online pjnsmb

  • User
  • Posts: 66
Re: Timeshift not automated
« Reply #5 on: 2020/01/04, 09:43:58 »
@devil


my timeshift.json file is identical to yours


my GUI is not ticked for startuo/boot


I have a file timeshift-hourly in /etc/cron.d (attached)


there are no other files referring to timeshift in the other /etc/cron files


any help in https://github.com/teejee2008/timeshift/issues ?







[/size][size=78%]  [/size]
regards
pjnsmb

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.388
Re: Timeshift not automated
« Reply #6 on: 2020/01/04, 14:18:55 »
Thanks for comparing the files. I know about the hourly cronjob. That is ok the way it is, it just checks on an hourly basis if there is anything to do. I guess I will have to ask on GitHub, even though answers are quite slow.