seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/08/07, 11:59:56


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Drucken in einem KDE Neon System nicht möglich  (Read 1685 times)

0 Members and 1 Guest are viewing this topic.

Offline bluelupo

  • Global Moderator
  • User
  • *****
  • Posts: 2.066
    • BluelupoMe
Drucken in einem KDE Neon System nicht möglich
« on: 2018/10/21, 21:18:48 »
Hi Community,

ich habe hier ein KDE Neon System (mit Unterbau Ubuntu Bionic Beaver) bei dem mein Drucker HP Color Laserjet 1515n (netzwerkfähig) nicht drucken will. Wenn ich einen Druckauftrag anstoße wird der leider nicht ausgedruckt. In der CUPS-GUI wird angezeigt "Filter failed" bzw. Datei "/usr/lib/cups/filter/foomatic-rip-hplip No such file or directory". Diese Datei gibt es auch nicht. Auch eine Neunanlage des Druckers in CUPS hat keinen Effekt.

Vermutlich kommt dieses Problem vom System-Upgrade letzte Woche bei Neon, denn die haben die Systembasis von Xenial auf Bionic aktualisiert. Vor dem System-Upgrade lief alles einwandfrei.

Eine Recherche im Netz brachte bis jetzt keine Lösung.

Hat jemand von euch einen Tipp wie ich das Problem lösen könnte.

EDIT:
Code: [Select]
# dpkg -l |grep -i cups | awk '{print $1,$2,$3}'
ii bluez-cups 5.48-0ubuntu3.1
ii cups 2.2.7-1ubuntu2.1
ii cups-browsed 1.20.2-0ubuntu3
ii cups-bsd 2.2.7-1ubuntu2.1
ii cups-client 2.2.7-1ubuntu2.1
ii cups-common 2.2.7-1ubuntu2.1
ii cups-core-drivers 2.2.7-1ubuntu2.1
ii cups-daemon 2.2.7-1ubuntu2.1
ii cups-filters 1.20.2-0ubuntu3
ii cups-filters-core-drivers 1.20.2-0ubuntu3
ii cups-ipp-utils 2.2.7-1ubuntu2.1
ii cups-ppdc 2.2.7-1ubuntu2.1
ii cups-server-common 2.2.7-1ubuntu2.1
ii libcups2:amd64 2.2.7-1ubuntu2.1
ii libcupscgi1:amd64 2.2.7-1ubuntu2.1
ii libcupsfilters1:amd64 1.20.2-0ubuntu3
ii libcupsimage2:amd64 2.2.7-1ubuntu2.1
ii libcupsmime1:amd64 2.2.7-1ubuntu2.1
ii libcupsppdc1:amd64 2.2.7-1ubuntu2.1
ii libfontembed1:amd64 1.20.2-0ubuntu3
ii printer-driver-cups-pdf 3.0.1-5
ii printer-driver-gutenprint 5.2.13-2
ii printer-driver-hpcups 3.17.10+repack0-5
ii python3-cups 1.9.73-2
ii python3-cupshelpers 1.5.11-1ubuntu2
« Last Edit: 2018/10/21, 22:14:06 by bluelupo »

Offline tommy2

  • User
  • Posts: 120
Re: Drucken in einem KDE Neon System nicht möglich
« Reply #1 on: 2018/10/22, 07:50:05 »
Hi bluelupo, don't know if this will help though I had something similar with my Samsung printer. I looked high and low for the reason and ended up installing --reinstalling hplip and it worked. Why I cannot answer it just worked.  :)

Offline axt

  • User
  • Posts: 409
    • axebase.net
Re: Drucken in einem KDE Neon System nicht möglich
« Reply #2 on: 2018/10/22, 08:25:13 »
Ping-bar scheint er ja zu sein, sprich NW i.O. Ich würde cups an sich erstmal reinstallieren. Soweit erinnerlich, hat das in Bionic (oder ist's Artful gewesen...egal) mal Probleme gehabt, die dadurch simpel zu lösen gewesen sind). hplip kann man natürlich auch reinstallieren oder statt aus den Ubuntu-Repos das Original (aber entweder oder).

 

Offline bluelupo

  • Global Moderator
  • User
  • *****
  • Posts: 2.066
    • BluelupoMe
Re: Drucken in einem KDE Neon System nicht möglich
« Reply #3 on: 2018/10/22, 20:40:45 »
Hi Axt,
ja pingbar ist der Drucker und auch der Selftest funktioniert. Folgende Pakete habe ich reinstalliert:
Code: [Select]
# apt-get install --reinstall hplip* hpijs*
# apt-get install --reinstall cups*

Hat nichts gebracht, immer noch der gleiche Fehler "Filter failed". Auf anderer HW (ACER Laptop) mit der identischen KDE Neon Installation tritt der Fehler ebenso auf. Bin momentan etwas ratlos :-((

EDIT: mit einer siduction Installtion druckt mein HP ;-) Also die Drucker HW ist okay.

« Last Edit: 2018/10/22, 20:48:52 by bluelupo »

Offline jure

  • User
  • Posts: 526
Re: Drucken in einem KDE Neon System nicht möglich
« Reply #4 on: 2018/10/22, 21:10:58 »
hast du mal versucht ob die Installation von "foomatic-filters" hilft, wenn die jetzt nicht vorhanden sind ...
Gruss Juergen

Offline bluelupo

  • Global Moderator
  • User
  • *****
  • Posts: 2.066
    • BluelupoMe
Re: Drucken in einem KDE Neon System nicht möglich
« Reply #5 on: 2018/10/22, 21:24:42 »
Hi jure,

die foomatic Pakete sind installiert bei KDE Neon:
Code: [Select]
dpkg -l | grep foomatic
ii  foomatic-db-compressed-ppds                     20180306-1                                       all          OpenPrinting printer support - Compressed PPDs derived from the database
ii  foomatic-db-engine                              4.0.13-1                                         amd64        OpenPrinting printer support - programs

Hmmm, ob das ratsam ist foomatic-filters zu installieren?
Code: [Select]
# apt-get install foomatic-filters -s
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) cups-filters:amd64 < 1.20.2-0ubuntu3 @ii mK Ib >
Broken cups-filters:amd64 Kollidiert mit on foomatic-filters:amd64 < none -> 4.0.17-10 @un puN >
  Considering foomatic-filters:amd64 10037 as a solution to cups-filters:amd64 112
  Removing cups-filters:amd64 rather than change foomatic-filters:amd64
Investigating (0) cups:amd64 < 2.2.7-1ubuntu2.1 @ii mK Ib >
Broken cups:amd64 Hängt ab von on cups-filters:amd64 < 1.20.2-0ubuntu3 @ii mR > (>= 1.0.24-3~)
  Considering cups-filters:amd64 112 as a solution to cups:amd64 45
  Removing cups:amd64 rather than change cups-filters:amd64
Investigating (0) printer-driver-gutenprint:amd64 < 5.2.13-2 @ii mK Ib >
Broken printer-driver-gutenprint:amd64 Hängt ab von on cups:amd64 < 2.2.7-1ubuntu2.1 @ii mR > (>= 1.3.0)
  Considering cups:amd64 45 as a solution to printer-driver-gutenprint:amd64 20
  Removing printer-driver-gutenprint:amd64 rather than change cups:amd64
Investigating (0) hplip:amd64 < 3.17.10+repack0-5 @ii mK Ib >
Broken hplip:amd64 Hängt ab von on cups:amd64 < 2.2.7-1ubuntu2.1 @ii mR >
  Considering cups:amd64 45 as a solution to hplip:amd64 6
  Removing hplip:amd64 rather than change cups:amd64
Investigating (0) printer-driver-postscript-hp:amd64 < 3.17.10+repack0-5 @ii mK Ib >
Broken printer-driver-postscript-hp:amd64 Hängt ab von on hplip:amd64 < 3.17.10+repack0-5 @ii mR > (>= 3.17.10+repack0-5)
  Considering hplip:amd64 6 as a solution to printer-driver-postscript-hp:amd64 5
  Removing printer-driver-postscript-hp:amd64 rather than change hplip:amd64
Investigating (0) printer-driver-hpcups:amd64 < 3.17.10+repack0-5 @ii mK Ib >
Broken printer-driver-hpcups:amd64 Hängt ab von on cups:amd64 < 2.2.7-1ubuntu2.1 @ii mR >
  Considering cups:amd64 45 as a solution to printer-driver-hpcups:amd64 5
  Removing printer-driver-hpcups:amd64 rather than change cups:amd64
Investigating (0) printer-driver-splix:amd64 < 2.0.0+svn315-6fakesync1 @ii mK Ib >
Broken printer-driver-splix:amd64 Hängt ab von on cups:amd64 < 2.2.7-1ubuntu2.1 @ii mR > (>= 1.5.0-3~)
  Considering cups:amd64 45 as a solution to printer-driver-splix:amd64 1
  Removing printer-driver-splix:amd64 rather than change cups:amd64
Investigating (0) bluez-cups:amd64 < 5.48-0ubuntu3.1 @ii mK Ib >
Broken bluez-cups:amd64 Hängt ab von on cups:amd64 < 2.2.7-1ubuntu2.1 @ii mR >
  Considering cups:amd64 45 as a solution to bluez-cups:amd64 1
  Removing bluez-cups:amd64 rather than change cups:amd64
Investigating (0) printer-driver-cups-pdf:amd64 < 3.0.1-5 @ii mK Ib >
Broken printer-driver-cups-pdf:amd64 Hängt ab von on cups:amd64 < 2.2.7-1ubuntu2.1 @ii mR >
  Considering cups:amd64 45 as a solution to printer-driver-cups-pdf:amd64 0
  Removing printer-driver-cups-pdf:amd64 rather than change cups:amd64
Investigating (0) hplip-gui:amd64 < 3.17.10+repack0-5 @ii mK Ib >
Broken hplip-gui:amd64 Hängt ab von on hplip:amd64 < 3.17.10+repack0-5 @ii mR > (>= 3.17.10+repack0-5)
  Considering hplip:amd64 6 as a solution to hplip-gui:amd64 0
  Removing hplip-gui:amd64 rather than change hplip:amd64
Investigating (0) cups-tea4cups:amd64 < 3.13~alpha0+svn3565-4 @ii mK Ib >
Broken cups-tea4cups:amd64 Hängt ab von on cups:amd64 < 2.2.7-1ubuntu2.1 @ii mR >
  Considering cups:amd64 45 as a solution to cups-tea4cups:amd64 0
  Removing cups-tea4cups:amd64 rather than change cups:amd64
Investigating (0) cups-x2go:amd64 < 3.0.1.3-2 @ii mK Ib >
Broken cups-x2go:amd64 Hängt ab von on cups:amd64 < 2.2.7-1ubuntu2.1 @ii mR >
  Considering cups:amd64 45 as a solution to cups-x2go:amd64 0
  Removing cups-x2go:amd64 rather than change cups:amd64
Done
Die folgenden Pakete werden ENTFERNT:
  bluez-cups cups cups-filters cups-tea4cups cups-x2go hplip hplip-gui printer-driver-cups-pdf printer-driver-gutenprint printer-driver-hpcups printer-driver-postscript-hp printer-driver-splix
Die folgenden NEUEN Pakete werden installiert:
  foomatic-filters
0 aktualisiert, 1 neu installiert, 12 zu entfernen und 17 nicht aktualisiert.
Remv bluez-cups [5.48-0ubuntu3.1]
Remv printer-driver-cups-pdf [3.0.1-5]
Remv cups-x2go [3.0.1.3-2]
Remv cups [2.2.7-1ubuntu2.1] [printer-driver-splix:amd64 printer-driver-hpcups:amd64 hplip:amd64 printer-driver-gutenprint:amd64 cups-tea4cups:amd64 ]
Remv printer-driver-splix [2.0.0+svn315-6fakesync1] [printer-driver-hpcups:amd64 hplip:amd64 printer-driver-gutenprint:amd64 cups-tea4cups:amd64 ]
Remv printer-driver-gutenprint [5.2.13-2] [printer-driver-hpcups:amd64 hplip:amd64 cups-tea4cups:amd64 ]
Remv cups-filters [1.20.2-0ubuntu3] [printer-driver-m2300w:amd64 printer-driver-hpcups:amd64 printer-driver-foo2zjs:amd64 printer-driver-pxljr:amd64 foomatic-db-engine:amd64 hplip:amd64 hpijs-ppds:amd64 cups-tea4cups:amd64 ]
Inst foomatic-filters (4.0.17-10 Ubuntu:18.04/bionic [amd64]) [printer-driver-hpcups:amd64 hplip:amd64 cups-tea4cups:amd64 ]
Remv cups-tea4cups [3.13~alpha0+svn3565-4] [printer-driver-hpcups:amd64 hplip:amd64 ]
Remv hplip-gui [3.17.10+repack0-5] [printer-driver-hpcups:amd64 hplip:amd64 ]
Remv printer-driver-postscript-hp [3.17.10+repack0-5] [printer-driver-hpcups:amd64 hplip:amd64 ]
Remv hplip [3.17.10+repack0-5] [printer-driver-hpcups:amd64 ]
Remv printer-driver-hpcups [3.17.10+repack0-5]
Conf foomatic-filters (4.0.17-10 Ubuntu:18.04/bionic [amd64])
« Last Edit: 2018/10/22, 21:34:34 by bluelupo »

Offline axt

  • User
  • Posts: 409
    • axebase.net
Re: Drucken in einem KDE Neon System nicht möglich
« Reply #6 on: 2018/10/22, 22:24:39 »
Wie gesagt, ich halte die Anleitung aktuell.