seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2018/11/21, 00:28:02


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Broken path environment after router interrupt  (Read 568 times)

0 Members and 1 Guest are viewing this topic.

Offline eQuacky

  • User
  • Posts: 51
Broken path environment after router interrupt
« on: 2018/09/10, 23:03:31 »
 Hi folks,

this morning I got an interruption in my router (combined hardware: cable modem + wlan-router), after that I heard it restarting. All other devices got a connection after restart, with the exception of my laptop - it was downloading some things in that moment. So the router later worked stable again.

Wicd wasn't able to reconnect, so I tried to start it manually with ifup/ifdown as root and got following notice:

Command 'ifdown' is available in '/sbin/ifdown' The command could not be located because '/sbin' is not included in the PATH environment variable.

With the command export PATH=$PATH:/usr/bin I had access to ifup/ifdown again.

But neither console nor wicd is able to get a connection to wlan. Seems to be that the interrupt messed up my path environment.

Any hints appreciated.

Greetings
Thomas

Offline eQuacky

  • User
  • Posts: 51
Re: Broken path environment after router interrupt
« Reply #1 on: 2018/09/10, 23:05:01 »
Oh forgot: the package python-wicd is installed not wicd

Offline Geier0815

  • User
  • Posts: 446
Re: Broken path environment after router interrupt
« Reply #2 on: 2018/09/11, 10:19:15 »
Had you configured your WiFi with /etc/network/interfaces? Or was it made by a network-manager? ifupdown will only work if there is a configuration in interfaces and in most cases with wpa_supplicant. Or are you using wicd as described here?
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Offline eQuacky

  • User
  • Posts: 51
Re: Broken path environment after router interrupt
« Reply #3 on: 2018/09/13, 13:31:50 »
 @geier
years ago (over five) I configured this thinkpad with ceni if I remember correctly. As I noticed wpasupplicant and network-manager had also been installed. But they never ran, checked it several times.
I used your link removed NM and wpasupplicant, installed the missing package wicd, and configured it as described but didn't work.
network/interfaces: all commented out excluded loopback
user was in the group netdev
ESSID and password are correct
Someways I am stuck


Offline Geier0815

  • User
  • Posts: 446
Re: Broken path environment after router interrupt
« Reply #4 on: 2018/09/14, 09:51:43 »
Code: [Select]
ip link show says what to the state and the name of your wifi-adapter? If it is down try
Code: [Select]
ip link set NAME up If this will not work, maybe you have disabled the device? Have a look for a key combination to enable it or have a closer look into your bios/uefi.
If the adapter is not listet by the first command, you may need a driver/firmware for it? In this case give us the result of
Code: [Select]
inxi -nBy the way: For the most people network-manager is the recommended way to configure the network.
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Offline hendrikL

  • User
  • Posts: 297
Re: Broken path environment after router interrupt
« Reply #5 on: 2018/09/14, 11:16:20 »
Maybe the reason for the broken $PATH environment is the new behaviour of 'su'

Quote from: /usr/share/doc/util-linux/NEWS.Debian.gz
util-linux (2.32-0.4) unstable; urgency=medium
[...]
  The first difference is probably the most user visible one. Doing
  plain 'su' is a really bad idea for many reasons, so using 'su -' is
  strongly recommended to always get a newly set up environment similar
  to a normal login. If you want to restore behaviour more similar to
  the previous one you can add 'ALWAYS_SET_PATH yes' in /etc/login.defs.

What you can try is to create a new file in '/etc/default' named 'su' with the ALWAYS_SET_PATH variable inside and restart the system.
Code: [Select]
echo -e "## user defined, that root path is set with normal su yes/no ##\nALWAYS_SET_PATH yes" > /etc/default/su

If that solves your problem, please fill a bug against wicd or what you are using with the full error output.
If not remove it,
Code: [Select]
rm /etc/default/su
Disclaimer: it is not recommended to use it, the normal way is to let the behaviour of su as it is.
In normal cases you should use 'su -' when you need the full root environment ($PATH).
So when it is fixed you should remove that file.

« Last Edit: 2018/09/14, 11:22:25 by hendrikL »

Offline eQuacky

  • User
  • Posts: 51
Re: Broken path environment after router interrupt
« Reply #6 on: 2018/09/15, 15:27:44 »
@hendrikI am so sorry, had forgotten to say that the broken path has been solved. First temporarily by export path variable and permamently by editing etc/network/interfaces, but thanks a lot.

Offline eQuacky

  • User
  • Posts: 51
Re: Broken path environment after router interrupt
« Reply #7 on: 2018/09/21, 12:34:39 »
ltq@sid-X121e:~$ ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
    link/ether 04:7d:7b:08:9b:c3 brd ff:ff:ff:ff:ff:ff
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT group default qlen 1000
    link/ether 60:d8:19:c1:f3:23 brd ff:ff:ff:ff:ff:ff

wlan0 seems to be down but it is to be seen both by wicd and iwlist scan.
ip link set NAMEOFMYESSID up
Cannot find device "nameofmyessid"
Don't know that I should have disabled my wifi, had no reason for doing that.The onliest entry I found in my bios regarding network was: Wireless LAN AND WiMax Radios [ON]No other related entries to be found.

inxi -n
Network:
  Device-1: Realtek RTL8188CE 802.11b/g/n WiFi Adapter driver: rtl8192ce
  IF: wlan0 state: down mac: 60:d8:19:c1:f3:23
  Device-2: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet driver: atl1c
  IF: eth0 state: up speed: 1000 Mbps duplex: full mac: 04:7d:7b:08:9b:c3




Offline Geier0815

  • User
  • Posts: 446
Re: Broken path environment after router interrupt
« Reply #8 on: 2018/09/21, 13:41:49 »
Code: [Select]
ip link set wlan0 up This is only to bring your device up. Networkconfiguration must be done with other tools, like wicd or better with network-manager. But that the device was found and a driver was loaded is a good sign.
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Offline eQuacky

  • User
  • Posts: 51
Re: Broken path environment after router interrupt
« Reply #9 on: 2018/10/24, 14:17:33 »
 @geier0815
ok - worked with networkmanager very well, but when I wanted to make a du I edited network/interfaces and released it with:
allow-hotplug wlan0
iface wlan0 inet dhcp       
wpa-psk mypassword
wpa-ssid myESSID
resulting in not being managed by nm in lxqt.
Is there a possibility to work both with nm in window manager as well as in cli without manually changing?

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.488
    • g-com.eu
Re: Broken path environment after router interrupt
« Reply #10 on: 2018/10/25, 00:30:51 »
there is a reason why we suggest connman in lxqt  - and /e/n/i in n-m is a bad idea. if you want to use eni, drop n-m and use pure ifupdown + ceni

Edit: beside ifupdown + ceni one could use nm-tray + n-m or network-manager-gnome but please leave eni alone in that case
« Last Edit: 2018/10/25, 00:35:23 by melmarker »
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline eQuacky

  • User
  • Posts: 51
Re: Broken path environment after router interrupt
« Reply #11 on: 2018/11/08, 20:14:22 »
Ok the combination connman and network-manager seems to run well after a few days of use.Thanks to all involved, especially geier0815 and melmarker!