seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2018/12/10, 07:12:49


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Can't get scanner to work.  (Read 451 times)

0 Members and 1 Guest are viewing this topic.

Offline vilde

  • User
  • Posts: 631
Can't get scanner to work.
« on: 2018/10/01, 19:53:47 »
Once again I like to use my scanner and as always I get problem(s). My old scanner is an Epson 4490 Photo. I have tried to find solutions on the net but not succeeded.

Here are some info:
Code: [Select]
$ id
uid=1000(vilde) gid=1004(vilde) grupper=1004(vilde),7(lp),20(dialout),24(cdrom),25(floppy),29(audio),30(dip),44(video),46(plugdev),101(systemd-journal),108(kvm),114(lpadmin),116(netdev),117(bluetooth),119(scanner),1000(fuse),1001(powerdev),1002(storage),1003(vboxusers)
Code: [Select]
lsusb
Bus 002 Device 003: ID 0bdb:1911 Ericsson Business Mobile Networks BV
Bus 002 Device 006: ID 04b8:0119 Seiko Epson Corp. GT-X750 [Perfection 4490 Photo]
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 062a:4101 Creative Labs Wireless Keyboard/Mouse
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
As user:
Code: [Select]
sane-find-scanner

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

could not open USB device 0x04b8/0x0119 at 001:005: Access denied (insufficient permissions)
  # No USB scanners found. If you expected something different, make sure that
  # you have loaded a kernel driver for your USB host controller and have setup
  # the USB system correctly. See man sane-usb for details.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

  # You may want to run this program as root to find all devices. Once you
  # found the scanner devices, be sure to adjust access permissions as
  # necessary.

As  root:
Code: [Select]
sane-find-scanner

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04b8 [EPSON], product=0x0119 [EPSON Scanner]) at libusb:001:005
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.
As root: scanimage -L
https://pastebin.com/7r7Xgyiz
(Don't manage to do it with simple-paste)






XFCE-64 bit

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.530
    • g-com.eu
Re: Can't get scanner to work.
« Reply #1 on: 2018/10/01, 20:22:42 »
And you think that you are not abit to optimistic to get a scanner from 2006 working?
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline vilde

  • User
  • Posts: 631
Re: Can't get scanner to work.
« Reply #2 on: 2018/10/01, 20:27:28 »
And you think that you are not abit to optimistic to get a scanner from 2006 working?
With Vuescan it works as root, but I don't want to pay for that application. Yes, maybe I'm to optimistic. But on the other hand I can't get the newer all-in-one  samsung to work either so, something is wrong (in the world)
XFCE-64 bit

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.530
    • g-com.eu
Re: Can't get scanner to work.
« Reply #3 on: 2018/10/01, 20:36:54 »
https://www.chiark.greenend.org.uk/doc/libsane/supported.html

Perfection 4490 PHOTO   USB   0x04b8/0x0119   
Unsupported   supported by the epkowa backend plus non-free interpreter   epson2
(1.0.124)   sane-epson2
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline vilde

  • User
  • Posts: 631
Re: Can't get scanner to work.
« Reply #4 on: 2018/10/01, 21:48:30 »
OK, thanks melmarker, the I have to start w----zzzz  :(
XFCE-64 bit

Offline tommy2

  • User
  • Posts: 91
Re: Can't get scanner to work.
« Reply #5 on: 2018/10/02, 11:36:37 »
You might need to go to the HP support and down load the Samsung driver(s) unpack and install "scripts" to get your newer printer working. That's what I had to do with my Samsung Xpress C480W and knock on wood all seems to function properly.  ;)

Offline vilde

  • User
  • Posts: 631
Re: Can't get scanner to work.
« Reply #6 on: 2018/10/02, 13:53:13 »
You might need to go to the HP support and down load the Samsung driver(s) unpack and install "scripts" to get your newer printer working. That's what I had to do with my Samsung Xpress C480W and knock on wood all seems to function properly.  ;)
Thank you tommy2, the thing is that the Samsung scanner is not as good as my older Epson for scanning photos, the Samsung is good for printing and copying documents but not photos. So it's just to start up the W--zzz shit and use the Epson scanner when I do the photo scanning.
XFCE-64 bit

Offline tommy2

  • User
  • Posts: 91
Re: Can't get scanner to work.
« Reply #7 on: 2018/10/04, 16:35:39 »
@vilde, sorry I don't have any experience with Epson's.  :(

Offline dieres

  • User
  • Posts: 700
Re: Can't get scanner to work.
« Reply #8 on: 2018/10/10, 15:50:07 »
I have buyed vuescan years ago, and still can download and install the newest software. The best about 64€ i ever spended for any software. Same soft for windows mac and linux. No Problems. except duplex scanning on brother mfc-J6910DW. Ed Hamrick is working on that.

Offline vilde

  • User
  • Posts: 631
Re: Can't get scanner to work.
« Reply #9 on: 2018/11/13, 13:32:13 »
I go on trying to get my scanner work here. With some help from drb I now get the scanner work, but only as root not as user.
When starting xsane as user I get the message as in the attachment. Its in Swedish so here is a try to translate the text to English. "Could not open unit" ------ "Access to resource denied"My user vilde is belonging to this groups : vilde lp dialout cdrom floppy audio dip video plugdev systemd-journal kvm lpadmin netdev bluetooth scanner saned fuse powerdev storage
« Last Edit: 2018/11/13, 13:45:06 by vilde »
XFCE-64 bit

Offline jure

  • User
  • Posts: 437
Re: Can't get scanner to work.
« Reply #10 on: 2018/11/13, 13:34:57 »
is the user member of the group "scanner"

Code: [Select]
groups
users lp mail dialout fax cdrom floppy sudo audio dip video plugdev fuse lpadmin scanner ....
Gruss Juergen

Offline vilde

  • User
  • Posts: 631
Re: Can't get scanner to work.
« Reply #11 on: 2018/11/13, 13:44:43 »
is the user member of the group "scanner"

Code: [Select]
groups
users lp mail dialout fax cdrom floppy sudo audio dip video plugdev fuse lpadmin scanner ....
Yes it's already written i my post
XFCE-64 bit

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.470
  • north of hell south of heaven
debian sid  |  apt into it

siduction d-u warnings

Dont Break Debian




we are the priests  ...  of the temples of syrinx  ...

Offline vilde

  • User
  • Posts: 631
XFCE-64 bit

Offline drb

  • User
  • Posts: 130
Re: Can't get scanner to work.
« Reply #14 on: 2018/11/13, 14:52:03 »
As in PMs, I managed to get my Epson 4490 working fine today as user by just installing iscan and iscan x750 plugin. Can anyone help me troubleshoot to see if I can identify any differences in my set up to vilde's?