seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2018/12/10, 08:37:41


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: 4.18.0-2-amd64 upgrade today, packages held back  (Read 1093 times)

0 Members and 1 Guest are viewing this topic.

Offline hhhorb

  • User
  • Posts: 10
4.18.0-2-amd64 upgrade today, packages held back
« on: 2018/10/04, 01:41:47 »
Reboot confirms the kernel upgrade, but 68 packages for my system were held back, another 50+ successfully upgraded.
Everything works and I haven't investigated it yet, just thought I should mention it.
Code: [Select]
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  accountwizard akonadi-backend-mysql akonadi-contacts-data akonadi-mime-data
  akonadi-server akregator kaddressbook kde-config-mailtransport kdepim-addons
  kdepim-runtime kdepim-themeeditors kf5-kdepim-apps-libs-data
  kf5-messagelib-data kio-ldap kmail knotes korganizer libkf5akonadi-data
  libkf5akonadiagentbase5 libkf5akonadicalendar-data
  libkf5akonadicalendar5abi1 libkf5akonadicontact5 libkf5akonadimime5
  libkf5akonadisearch-bin libkf5akonadisearch-plugins libkf5akonadisearchcore5
  libkf5akonadisearchdebug5 libkf5akonadisearchpim5 libkf5akonadiwidgets5abi1
  libkf5calendarsupport-data libkf5calendarsupport5abi1 libkf5contacteditor5
  libkf5followupreminder5 libkf5gravatar-data libkf5identitymanagement5
  libkf5incidenceeditor-data libkf5incidenceeditor5abi1
  libkf5kaddressbookgrantlee5 libkf5kaddressbookimportexport5
  libkf5kdepimdbusinterfaces5 libkf5kmanagesieve5 libkf5ksieve-data
  libkf5ksieve5 libkf5ksieveui5 libkf5libkdepim-plugins libkf5libkdepim5
  libkf5libkdepimakonadi5 libkf5libkleo-data libkf5libkleo5
  libkf5mailcommon-data libkf5mailimporterakonadi5 libkf5mailtransport-data
  libkf5mailtransport5 libkf5mailtransportakonadi5 libkf5pimcommon-data
  libkf5pimtextedit-data libkf5pimtextedit-plugins libkf5sendlater5
  libkf5templateparser5 libkpimgapi-data libkpimgapicalendar5
  libkpimgapicontacts5 libkpimgapitasks5 libkpimimportwizard5 libkpimkdav-data
  mbox-importer pim-data-exporter pim-sieve-editor

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.297
Re: 4.18.0-2-amd64 upgrade today, packages held back
« Reply #1 on: 2018/10/04, 11:22:34 »
KDE Frameworks and Qt 5.11 get updated. Just give it  a day or two.

Offline drb

  • User
  • Posts: 130
Re: 4.18.0-2-amd64 upgrade today, packages held back
« Reply #2 on: 2018/10/09, 11:35:00 »
Not sure if this is resolving itself, but I still have 39 packages to remove, including korganizer. But the version it says is to be removed isn't installed.

Code: [Select]
The following packages will be REMOVED:
   korganizer (4:18.08.1-1)
Code: [Select]
apt-cache policy korganizer
korganizer:
  Installed: 4:17.12.3-2
  Candidate: 4:18.08.1-1
  Version table:
     4:18.08.1-1 500
        500 http://http.debian.net/debian unstable/main amd64 Packages
 *** 4:17.12.3-2 500
        500 http://http.debian.net/debian testing/main amd64 Packages
        100 /var/lib/dpkg/status
 
 


Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.297
Re: 4.18.0-2-amd64 upgrade today, packages held back
« Reply #3 on: 2018/10/09, 19:54:46 »
It will not resolve itself. For me the solution was, after diffing what gets removed and what gets reinstalled, to go through with it. But I am not a KDE-Pim user, so I did not really care.

But afterwards I was able to reinstall all the missing stuff. First I reinstalled kde-standard, then akregator, which was enough to bring everything back.

Offline drb

  • User
  • Posts: 130
Re: 4.18.0-2-amd64 upgrade today, packages held back
« Reply #4 on: 2018/10/09, 20:01:29 »
Thanks for advice.

Offline tranquil

  • User
  • Posts: 45
Re: 4.18.0-2-amd64 upgrade today, packages held back
« Reply #5 on: 2018/10/09, 21:18:12 »
It will not resolve itself. For me the solution was, after diffing what gets removed and what gets reinstalled, to go through with it. But I am not a KDE-Pim user, so I did not really care.

But afterwards I was able to reinstall all the missing stuff. First I reinstalled kde-standard, then akregator, which was enough to bring everything back.
How do you know when something will not resolve itself?
Dual-booting Debian Stable and Unstable with Openbox window manager and Tint2 panel.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.297
Re: 4.18.0-2-amd64 upgrade today, packages held back
« Reply #6 on: 2018/10/10, 12:39:36 »
In this case I knew because I talked to the maintainer.

Offline finotti

  • User
  • Posts: 77
Re: 4.18.0-2-amd64 upgrade today, packages held back
« Reply #7 on: 2018/10/10, 14:36:34 »
It will not resolve itself. For me the solution was, after diffing what gets removed and what gets reinstalled, to go through with it. But I am not a KDE-Pim user, so I did not really care.

But afterwards I was able to reinstall all the missing stuff. First I reinstalled kde-standard, then akregator, which was enough to bring everything back.
I'm sorry if I'm being obtuse here, but does that mean that the Qt transition is over and we need to let the packages to be removed be removed and then reinstall them.  I was just waiting for those to go away.  Right now I have:
Code: [Select]
608 packages can be upgraded. Run 'apt list --upgradable' to see them.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  akregator consolekit kalarm kmail libkf5akonadicore5abi1 libkf5alarmcalendar5 libkf5calendarsupport5abi1 libkf5eventviews5
  libkf5gravatar5abi1 libkf5incidenceeditor-bin libkf5incidenceeditor5abi1 libkf5kaddressbookgrantlee5 libkf5ksieveui5 libkf5ldap5
  libkf5libkleo5 libkf5mailcommon-plugins libkf5mailcommon5abi1 libkf5messagecomposer5 libkf5messagecore5 libkf5messagelist5
  libkf5messageviewer5 libkf5pimcommonakonadi5 libkf5templateparser5 libkpimgapicore5 libkpimkdav5abi1 libkpimsmtp5 libmbedtls10
The following NEW packages will be installed:
  libcfitsio7 libgdbm6 libkf5akonadicore5abi2 libkf5akonadiprivate5abi2 libkf5alarmcalendar-data libkf5alarmcalendar5abi1
  libkf5calendarcore5abi2 libkf5imap-data libkf5ldap-data libkf5ldap5abi1 libkf5syndication5abi1 libkpimgapicore5abi1
  libkpimkdav5abi2 libkpimsmtp5abi1 libmbedcrypto3 libmbedtls12 libpodofo0.9.6 libqrencode4 libsasl2-modules-kdexoauth2 libunbound8
  libx265-165 linux-headers-4.18.0-12.slh.2-aptosid-amd64 linux-image-4.18.0-12.slh.2-aptosid-amd64 php-phpseclib php-random-compat
  python3-cairo
The following packages have been kept back:
  libkf5identitymanagement5 libkf5pimcommon-plugins libkf5pimtextedit-data
The following packages will be upgraded:
  adduser adwaita-icon-theme akonadi-backend-mysql akonadi-backend-sqlite akonadi-contacts-data akonadi-mime-data akonadi-server
  apache2 apache2-bin apache2-data apache2-doc apache2-utils apt apt-doc apt-utils at-spi2-core autopoint avidemux avidemux-common
  avidemux-plugins avidemux-qt bind9-host binutils binutils-common binutils-x86-64-linux-gnu browser-plugin-freshplayer-pepperflash
  cdrskin cm-super cm-super-minimal console-setup console-setup-linux cpp-6 cpp-8 cups-filters cups-filters-core-drivers
  dctrl-tools debhelper desktop-file-utils dh-python dh-strip-nondeterminism dirmngr djview4 dmidecode dnsutils dokuwiki dpkg
  dpkg-dev dvd+rw-tools elpa-htmlize emacsen-common evince-common eyed3 feh firefox fontconfig fontconfig-config fonts-opensymbol
  foomatic-db g++-6 g++-8 gawk gcc-6 gcc-6-base gcc-8 gcc-8-base gdal-data gettext gettext-base gfortran-6 gfortran-8 ghostscript
  ghostscript-x gimp-help-common gimp-help-en gir1.2-gdkpixbuf-2.0 gir1.2-gstreamer-1.0 gir1.2-gtk-3.0 gir1.2-libosinfo-1.0
  gir1.2-vte-2.91 git git-gui git-man gitk gnupg gnupg-agent gnupg-l10n gnupg-utils gnupg2 gnutls-bin gpg gpg-agent gpg-wks-client
  gpg-wks-server gpgconf gpgsm gpgv growisofs gsettings-desktop-schemas gstreamer1.0-libav gstreamer1.0-plugins-bad
  gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio gtk-update-icon-cache
  gwenview gzip handbrake-cli handbrake-gtk hostname hwinfo hyphen-de inxi julia kde-config-gtk-style kdepim-runtime
  keyboard-configuration kf5-kdepim-apps-libs-data kf5-messagelib-data kgpg kio-ldap kio-sieve krename ktorrent latexmk
  libafflib0v5 libapache2-mod-php libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libapt-inst2.0 libapt-pkg5.0 libarpack2
  libasan3 libasan5 libasprintf-dev libasprintf0v5 libatk-bridge2.0-0 libatomic1 libatspi2.0-0 libaubio5 libbabl-0.1-0
  libbasicusageenvironment1 libbind9-160 libbinutils libblockdev-crypto2 libblockdev-fs2 libblockdev-loop2 libblockdev-mdraid2
  libblockdev-part-err2 libblockdev-part2 libblockdev-swap2 libblockdev-utils2 libblockdev2 libbrotli1 libburn4 libcc1-0
  libclang1-6.0 libcupsfilters1 libdap25 libdapclient6v5 libdapserver7v5 libdbusmenu-glib4 libdbusmenu-gtk4 libdebconfclient0
  libdns-export1102 libdns1102 libdouble-conversion1 libdpkg-perl libepoxy0 libevdocument3-4 libevview3-3
  libfile-stripnondeterminism-perl libfontconfig1 libfontconfig1-dev libfontembed1 libgail-3-0 libgcc-6-dev libgcc-8-dev libgcc1
  libgdal20 libgdbm-compat4 libgdbm-dev libgdcm2.8 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgettextpo-dev libgettextpo0
  libgfortran-6-dev libgfortran-8-dev libgfortran3 libgfortran5 libgit2-27 libglib2.0-0 libglib2.0-bin libglib2.0-data
  libgnutls-dane0 libgnutls-openssl27 libgnutls30 libgomp1 libgpgme11 libgpgmepp6 libgpod4 libgraphicsmagick-q16-3 libgroupsock8
  libgs9 libgs9-common libgssapi-krb5-2 libgstreamer-gl1.0-0 libgstreamer-plugins-bad1.0-0 libgstreamer-plugins-base1.0-0
  libgstreamer1.0-0 libgtk-3-0 libgtk-3-bin libgtk-3-common libguestfs-perl libguestfs-tools libguestfs0 libgupnp-1.0-4
  libharfbuzz-icu0 libharfbuzz0b libhd21 libical3 libimobiledevice6 libinput-bin libinput10 libio-socket-ssl-perl libirs160
  libisc-export169 libisc169 libisccc160 libisccfg160 libisoburn1 libisofs6 libitm1 libiw30 libjavascriptcoregtk-4.0-18 libjpeg9
  libjs-jquery-cookie libjs-lodash libjs-prettify libjson-glib-1.0-0 libjson-glib-1.0-common libjulia0.7 libk5crypto3
  libkf5akonadi-data libkf5akonadiagentbase5 libkf5akonadicalendar-data libkf5akonadicalendar5abi1 libkf5akonadicontact5
  libkf5akonadimime5 libkf5akonadinotes5 libkf5akonadisearch-bin libkf5akonadisearch-data libkf5akonadisearch-plugins
  libkf5akonadisearchcore5 libkf5akonadisearchdebug5 libkf5akonadisearchpim5 libkf5akonadisearchxapian5 libkf5akonadiwidgets5abi1
  libkf5calendarsupport-data libkf5calendarutils5 libkf5contacteditor5 libkf5contacts-data libkf5contacts5 libkf5eventviews-data
  libkf5followupreminder5 libkf5gapi-data libkf5grantleetheme-plugins libkf5grantleetheme5 libkf5gravatar-data libkf5imap5
  libkf5incidenceeditor-data libkf5kdepimdbusinterfaces5 libkf5kmanagesieve5 libkf5kontactinterface-data libkf5kontactinterface5
  libkf5ksieve-data libkf5ksieve5 libkf5libkdepim-data libkf5libkdepim-plugins libkf5libkdepim5 libkf5libkdepimakonadi5
  libkf5libkleo-data libkf5mailcommon-data libkf5mailimporter5 libkf5mailtransport-data libkf5mailtransport5
  libkf5mailtransportakonadi5 libkf5mbox5 libkf5mime-data libkf5mime5abi1 libkf5pimcommon-data libkf5prison5 libkf5sendlater5
  libkf5tnef5 libkpathsea6 libkpimgapi-data libkpimgapicalendar5 libkpimgapicontacts5 libkpimgapitasks5 libkpimkdav-data libkrb5-3
  libkrb5support0 liblivemedia64 libllvm6.0 liblouis-bin liblouis-data liblouis16 liblsan0 libltdl7 liblwres160 libmbedx509-0
  libmpx2 libnewt0.52 libofa0 libopenal-data libopenal1 libopenmpt0 liborc-0.4-0 libosinfo-1.0-0 libpam-systemd
  libparted-fs-resize0 libparted2 libplist3 libplot2c2 libpodofo0.9.5 libproj13 libprotobuf-lite10 libproxy-tools libproxy1v5
  libptexenc1 libpulse-mainloop-glib0 libpulse0 libpulsedsp libpython3.6 libpython3.6-minimal libpython3.6-stdlib libqgpgme7
  libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5opengl5 libqt5printsupport5 libqt5qml5 libqt5quick5
  libqt5quickwidgets5 libqt5sql5 libqt5sql5-mysql libqt5sql5-sqlite libqt5test5 libqt5widgets5 libqt5xml5 libqtermwidget5-0
  libquadmath0 libreoffice libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core libreoffice-base-drivers
  libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-help-common libreoffice-help-de
  libreoffice-help-en-us libreoffice-impress libreoffice-java-common libreoffice-kde libreoffice-kde5 libreoffice-l10n-de
  libreoffice-librelogo libreoffice-math libreoffice-report-builder-bin libreoffice-script-provider-python libreoffice-style-breeze
  libreoffice-style-colibre libreoffice-style-tango libreoffice-wiki-publisher libreoffice-writer libruby2.5 libsane-common
  libsane1 libsasl2-2 libsasl2-modules libsasl2-modules-db libsctp1 libsdl1.2debian libsdl2-2.0-0 libsecret-1-0 libsecret-common
  libsgutils2-2 libsoup-gnome2.4-1 libsoup2.4-1 libsqlite3-0 libsqlite3-dev libstdc++-6-dev libstdc++-8-dev libstdc++6 libsynctex2
  libsystemd0 libtdb1 libtevent0 libtexlua52 libtexlua53 libtexluajit2 libtool libtsan0 libubsan1 libudev1 libudisks2-0
  libusageenvironment3 libusbmuxd4 libuv1 libva-drm2 libva-glx2 libva-wayland2 libva-x11-2 libva2 libvolume-key1 libvte-2.91-0
  libvte-2.91-common libwebkit2gtk-4.0-37 libx11-6 libx11-data libx11-dev libx11-xcb1 libx264-157 libxapian30 libxcb-composite0
  libxcb-damage0 libxcb-dpms0 libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0 libxcb-present0 libxcb-randr0 libxcb-record0 libxcb-render0
  libxcb-screensaver0 libxcb-shape0 libxcb-shm0 libxcb-sync1 libxcb-xfixes0 libxcb-xinerama0 libxcb-xkb1 libxcb-xtest0 libxcb-xv0
  libxcb1 libxcb1-dev libxerces-c3.2 libyajl2 libzvbi-common libzvbi0 linux-headers-aptosid-amd64 linux-image-aptosid-amd64
  linux-libc-dev mbr mkvtoolnix mkvtoolnix-gui mpv mythes-en-us nano net-tools ntpdate openprinting-ppds osinfo-db paprefs parted
  partitionmanager php php-common php-curl php-intl php-pear php-xml printer-driver-foo2zjs printer-driver-foo2zjs-common proj-data
  prosper psmisc pulseaudio pulseaudio-module-gsettings pulseaudio-module-zeroconf pulseaudio-utils pylint pylint-doc pylint3
  python-apt-common python-astroid python-concurrent.futures python-eyed3 python-gi python-gi-cairo python-olefile python-sip
  python3-apt python3-astroid python3-cloudpickle python3-eyed3 python3-gi python3-olefile python3-pickleshare python3-pycodestyle
  python3-pygments python3-sip python3-testpath python3-tornado python3-uno python3.6 python3.6-minimal
  qml-module-qt-labs-folderlistmodel qml-module-qt-labs-settings qml-module-qtqml-models2 qml-module-qtquick-layouts
  qml-module-qtquick-window2 qml-module-qtquick2 qtermwidget5-data rename rsyslog ruby2.5 sane-utils shared-mime-info skypeforlinux
  sphinx-rtd-theme-common systemd systemd-sysv texlive-base texlive-bibtex-extra texlive-binaries texlive-extra-utils
  texlive-font-utils texlive-fonts-extra texlive-fonts-extra-doc texlive-fonts-recommended texlive-fonts-recommended-doc
  texlive-formats-extra texlive-games texlive-generic-extra texlive-generic-recommended texlive-htmlxml texlive-humanities
  texlive-humanities-doc texlive-lang-english texlive-lang-european texlive-lang-french texlive-lang-greek texlive-lang-portuguese
  texlive-lang-spanish texlive-latex-base texlive-latex-base-doc texlive-latex-extra texlive-latex-extra-doc
  texlive-latex-recommended texlive-latex-recommended-doc texlive-luatex texlive-metapost texlive-metapost-doc texlive-music
  texlive-omega texlive-pictures texlive-pictures-doc texlive-plain-extra texlive-plain-generic texlive-pstricks
  texlive-pstricks-doc texlive-publishers texlive-publishers-doc texlive-science texlive-science-doc texlive-xetex thunderbird udev
  udisks2 uno-libs3 update-inetd ure usbmuxd wget whiptail wireless-tools xorriso xsane xsane-common xserver-common
  xserver-xorg-core xserver-xorg-video-amdgpu xserver-xorg-video-ati xserver-xorg-video-intel xserver-xorg-video-radeon xterm
594 upgraded, 26 newly installed, 27 to remove and 3 not upgraded.

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.530
    • g-com.eu
Re: 4.18.0-2-amd64 upgrade today, packages held back
« Reply #8 on: 2018/10/10, 18:17:18 »
@finotti
a) which Qt transition
b) consolekit should has been gone years ago
c) it's only KDE pim - so the best bet is use apt and check it package for package - or as devil did: Just ask the maintainer.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline tranquil

  • User
  • Posts: 45
Re: 4.18.0-2-amd64 upgrade today, packages held back
« Reply #9 on: 2018/10/11, 01:45:39 »
In this case I knew because I talked to the maintainer.
Thank you for the info.  Are there other ways of knowing?
Dual-booting Debian Stable and Unstable with Openbox window manager and Tint2 panel.

Offline kokurya

  • User
  • Posts: 57
Re: 4.18.0-2-amd64 upgrade today, packages held back
« Reply #10 on: 2018/10/11, 09:56:22 »
Just be carefull if you are using Kmail with gmail:b1 - #910531 - kdepim-runtime: Authenticating to gmail using "Gmail" authentication type (oauth, kgapi?) leads to segfault
Linux is highly user friendly, it is just highly selective who it is friends with.

Offline drb

  • User
  • Posts: 130
Re: 4.18.0-2-amd64 upgrade today, packages held back
« Reply #11 on: 2018/10/11, 12:21:32 »
SEE EDIT BELOWThat didn't go so well. After letting packages go and trying to reinstall kede-standard I get :
Code: [Select]
The following packages have unmet dependencies:
 kde-standard : Depends: akregator (>= 4:17.12.3) but it is not going to be installed
                Depends: kaddressbook (>= 4:17.12.3) but it is not going to be installed
                Depends: kmail (>= 4:17.12.3) but it is not going to be installed
                Depends: knotes (>= 4:17.12.3) but it is not going to be installed
                Depends: korganizer (>= 4:17.12.3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
EDIT After another dist-upgrade, two packages removed and then replaced and then the installation went through.
« Last Edit: 2018/10/11, 12:31:06 by drb »

Offline hhhorb

  • User
  • Posts: 10
Re: 4.18.0-2-amd64 upgrade today, packages held back
« Reply #12 on: 2018/10/21, 03:47:48 »
After nearly two weeks with the same 68 or so packages being held, I finally invested 15 minutes to fix it. Thanks for the replies everyone, you made it easy. I don't use Kmail, so I just removed some 173 packages with...
Code: [Select]
sudo apt --purge autoremove accountwizard akonadi-*Reboot, all good for me. YMMV.