seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/07/19, 18:47:25


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: qt5-Transition  (Read 3397 times)

0 Members and 2 Guests are viewing this topic.

Offline vayu

  • User
  • Posts: 200
Re: qt5-Transition
« Reply #30 on: 2019/01/07, 17:18:05 »
FWIW, all my systems have been upgraded a while ago without removals....

I'm pretty sure the qt5 transition is done: https://release.debian.org/transitions/
finotti, thanks for letting me know.
Knowing that plus this very cool command I've never seen before helped me get my system all up to date.
Code: [Select]
apt-get -o Debug::pkgProblemResolver=yes dist-upgrade

Offline finotti

  • User
  • Posts: 93
Re: qt5-Transition
« Reply #31 on: 2019/01/07, 17:24:14 »
The problem appears to be that I need akonadi-backend-sqlite 4:18.08.1-1+b2 but apt can't find it in sid, although it is the only package apparently available!
I just noticed that in your output of apt policy...  (I had missed it before.)  The obvious: did you run "apt update"?  If so, maybe change your repository, as it does show up as available to me:
Code: [Select]
# apt policy akonadi-backend-sqlite
akonadi-backend-sqlite:
  Installed: 4:18.08.1-1+b2
  Candidate: 4:18.08.1-1+b2
  Version table:
 *** 4:18.08.1-1+b2 500
        500 http://httpredir.debian.org/debian sid/main amd64 Packages
        500 http://httpredir.debian.org/debian testing/main amd64 Packages
        100 /var/lib/dpkg/status

Offline drb

  • User
  • Posts: 149
Re: qt5-Transition
« Reply #32 on: 2019/01/07, 17:27:15 »
Isn't the version I have 4:18.08.1-1.1 later than 4:18.08.1-1+b2? Even though only 4:18.08.1-1+b2 is downloadable from debian sid.

Offline jure

  • User
  • Posts: 503
Re: qt5-Transition
« Reply #33 on: 2019/01/07, 17:28:12 »
Quote
The problem appears to be that I need akonadi-backend-sqlite 4:18.08.1-1+b2 but apt can't find it in sid, although it is the only package apparently available!

try to disable "http://packages.siduction.org/fixes unstable/main amd64 Packages" in /etc/apt/sources.list.d....

than the debian version 4:18.08.1-1+b2  should be installed
Gruss Juergen

Offline drb

  • User
  • Posts: 149
Re: qt5-Transition
« Reply #34 on: 2019/01/07, 17:32:18 »
Thanks. I have already tried that earlier but still have a problem that b2 isn't found.

Offline jure

  • User
  • Posts: 503
Re: qt5-Transition
« Reply #35 on: 2019/01/07, 17:35:59 »
hmm - I did it just 15min before and reinstalled akonadi-backend-sqlite here

now it is
Code: [Select]
apt policy akonadi-backend-sqlite
akonadi-backend-sqlite:
  Installiert:           4:18.08.1-1+b2
  Installationskandidat: 4:18.08.1-1+b2
  Versionstabelle:
 *** 4:18.08.1-1+b2 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
Gruss Juergen

Offline drb

  • User
  • Posts: 149
Re: qt5-Transition
« Reply #36 on: 2019/01/07, 17:39:10 »
Did you let it go then reinstall it?
Also, what is your debian sources list?

Offline jure

  • User
  • Posts: 503
Re: qt5-Transition
« Reply #37 on: 2019/01/07, 17:40:40 »
yes I let it go 29.12.2018 and now reinstalled it

Code: [Select]
cat /etc/apt/sources.list.d/debian.list
# debian loadbalancer
deb http://httpredir.debian.org/debian/ unstable main contrib non-free
#deb-src http://http.debian.net/debian/ unstable main contrib non-free

#testing
#deb http://httpredir.debian.org/debian/ testing main contrib non-free

# Experimental
#deb http://ftp.us.debian.org/debian/ experimental main contrib non-free
#deb-src http://ftp.us.debian.org/debian/ experimental main contrib non-free

# stable
#deb http://ftp.nl.debian.org/debian/ stable main contrib non-free
Gruss Juergen

Offline drb

  • User
  • Posts: 149
Re: qt5-Transition
« Reply #38 on: 2019/01/07, 17:43:48 »
It looks like I've got to let  4:18.08.1-1.1 go then reinstall 4:18.08.1-1+b2 after disabling siduction/fixes.
PS Removal of akonadi-backend-sqlite, two dist-upgrades and reinstallation of akonadi-backend-sqlite got there!
« Last Edit: 2019/01/07, 18:12:59 by drb »