seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/07/24, 10:56:05


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [gelöst] boot-Fehlermeldung mit neuer Grafikkarte  (Read 308 times)

0 Members and 1 Guest are viewing this topic.

Offline harley-peter

  • User
  • Posts: 765
Hallo,

nachdem ich endlich meine nVidia-Karte durch eine AMD ersetzt habe bin ich einen stets wiederkehrenden Ärger endlich los.  :)
Es scheint auch alles soweit zu funktionieren bis auf folgende Fehlermeldung beim booten:
Code: [Select]
[   15.608948] radeon 0000:01:00.0: failed VCE resume (-110)
Kann ich das einfach ignorieren oder ist da was zu tun? Im Netz habe ich zwar ein paar Beiträge dazu gefunden aber richtig schlau bin ich daraus nicht geworden und eine Lösung habe ich auch nicht gefunden.

Noch ein paar Infos:
Code: [Select]
dmesg | egrep -i 'vce'
[   15.471502] radeon 0000:01:00.0: firmware: direct-loading firmware radeon/TAHITI_vce.bin
[   15.475193] [drm] Found VCE firmware/feedback version 50.0.1 / 17!
[   15.608948] radeon 0000:01:00.0: failed VCE resume (-110).

apt policy firmware-amd-graphics
firmware-amd-graphics:
  Installiert:           20190114-1
  Installationskandidat: 20190114-1
  Versionstabelle:
 *** 20190114-1 500
        500 http://ftp.de.debian.org/debian unstable/non-free amd64 Packages
        100 /var/lib/dpkg/status

inxi -G
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Oland PRO [Radeon R7 240/340] driver: radeon v: kernel
           Display: x11 server: X.Org 1.20.3 driver: ati,radeon unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz
           OpenGL: renderer: AMD OLAND (DRM 2.50.0 4.20.3-towo.1-siduction-amd64 LLVM 7.0.1) v: 4.5 Mesa 18.3.1
« Last Edit: 2019/01/18, 12:57:23 by harley-peter »

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.274
Re: boot-Fehlermeldung mit neuer Grafikkarte
« Reply #1 on: 2019/01/17, 16:38:45 »
2 Möglichkeiten:

1. Das System zwingen amdgpu statt radeon zu verwenden, dann prüfen, ob es hilft
2. echo options radeon vce=0 > /etc/modprobe.d/my-radeon.conf

dann ist der Fehler weg.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline harley-peter

  • User
  • Posts: 765
Re: boot-Fehlermeldung mit neuer Grafikkarte
« Reply #2 on: 2019/01/17, 16:56:07 »
Hallo towo,

danke für die superschnelle Antwort.

zu 1: wie zwingt man das System dazu?
zu 2: Funktioniert, aber bringt es irgendwelche Nachteile die VCE abzuschalten?

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.274
Re: boot-Fehlermeldung mit neuer Grafikkarte
« Reply #3 on: 2019/01/17, 17:00:37 »
zu 2. naja, VCE ist die Video Codec Engine und abschalten sollte man diese nicht unbedingt.

zu 1.

in /etc/default/grub

amdgpu.si_support=1 radeon.si_support=0 amdgpu.dc=1

bei GRUB_CMDLINE_LINUX

dazumalen und update-grub ausführen.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline harley-peter

  • User
  • Posts: 765
Re: boot-Fehlermeldung mit neuer Grafikkarte
« Reply #4 on: 2019/01/17, 17:21:44 »
zu 2: ich meinte irgendwo gelesen zu haben dass vce=0 die engine disabled. Vielleicht habe ich mich auch geirrt, ich habe es auf die Schnelle nicht mehr gefunden.

zu 1: probier ich morgen aus. Danke!

Edit: Vorschlag 1 hat funktioniert. Nochmals danke!
« Last Edit: 2019/01/18, 12:56:59 by harley-peter »