seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/07/24, 11:25:56


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: apt will 30 Pakete entfernen  (Read 1216 times)

0 Members and 1 Guest are viewing this topic.

Offline DeKa

  • User
  • Posts: 327
Re: apt will 30 Pakete entfernen
« Reply #15 on: 2019/01/26, 15:53:36 »
Okay @piper, but what about the network manager? It should also be uninstalled.
Gruß DeKa

"Der größte Feind des Wissens ist nicht Unwissenheit, sondern die Illusion wissend zu sein. Von Stephen Hawking"

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.655
  • we are the priests ... of the temples of syrinx
Re: apt will 30 Pakete entfernen
« Reply #16 on: 2019/01/26, 17:08:14 »
To be honest, I will have to look more closely at what you have to be removed and right at this moment, I just don't have the time (massive snow storm dumped lots of snow), maybe later I can have a better look.

But, my full-upgrade looks like this (I use wbar, not cairo-dock)

Code: [Select]
11:02:35 AM-Sat Jan 26-[piper@x1] $ su
Password:
root@x1:/home/piper# apt update; apt full-upgrade
Hit:1 http://10.10.10.3:3142/incoming.debian.org/debian-buildd buildd-unstable InRelease
Hit:2 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/debian unstable InRelease
Hit:3 http://10.10.10.3:3142/deb.debian.org/debian experimental InRelease
Hit:4 http://10.10.10.3:3142/packages.siduction.org/extra experimental InRelease
Hit:5 http://10.10.10.3:3142/mirror.math.princeton.edu/pub/siduction/extra unstable InRelease
Hit:6 http://10.10.10.3:3142/packages.siduction.org/fixes unstable InRelease
Hit:7 http://10.10.10.3:3142/www.deb-multimedia.org sid InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@x1:/home/piper#

I also use incoming buildds repo and dmo (dmo not supported here or debian period, mythtv)
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline DeKa

  • User
  • Posts: 327
Re: apt will 30 Pakete entfernen
« Reply #17 on: 2019/01/26, 17:18:49 »
Leider soll der Networkmanager deinstalliert werden, warum auch immer,

Code: [Select]
Die folgenden Pakete werden ENTFERNT:
  amarok bleachbit brasero cairo-dock cairo-dock-plug-ins
  cairo-dock-shortcuts-plug-in eboard-extras-pack1 gdebi gnome-settings-daemon
  gnome-system-tools gvfs gvfs-backends gvfs-daemons kde-runtime
  kdelibs5-plugins ktron libhal1-flash libpam-systemd libpolkit-qt-1-1
  libsensors4 libtirpc1 nautilus nautilus-extension-brasero network-manager
  network-manager-gnome network-manager-vpnc network-manager-vpnc-gnome
  policykit-1 policykit-1-gnome udisks2
Die folgenden NEUEN Pakete werden installiert:
  libsensors-config libsensors5
Die folgenden Pakete sind zurückgehalten worden:
  libsystemd0 systemd
Die folgenden Pakete werden aktualisiert (Upgrade):
  cairo-dock-system-monitor-plug-in eboard libgl1-mesa-dri libsnmp30
  libtirpc-common libtirpc3 lm-sensors xfce4-sensors-plugin
8 aktualisiert, 2 neu installiert, 30 zu entfernen und 2 nicht aktualisiert.
Es müssen 11,5 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 72,1 MB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n]
Gruß DeKa

"Der größte Feind des Wissens ist nicht Unwissenheit, sondern die Illusion wissend zu sein. Von Stephen Hawking"

Offline jure

  • User
  • Posts: 506
Re: apt will 30 Pakete entfernen
« Reply #18 on: 2019/01/26, 17:27:32 »
ergibt "aptitude why-not network-manager" was erhellendes ?
Gruss Juergen

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.655
  • we are the priests ... of the temples of syrinx
Re: apt will 30 Pakete entfernen
« Reply #19 on: 2019/01/26, 17:30:19 »
What does

Code: [Select]
apt upgrade -s
look like
I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

Offline axt

  • User
  • Posts: 287
    • axebase.net
Re: apt will 30 Pakete entfernen
« Reply #20 on: 2019/01/26, 18:28:26 »
DeKa, stets komplett von Befehlseingabe über dessen Ausgabe bis zum neuen leeren Prompt copypasten! Ist das jetzt schon die d-u-Ausgabe nach der sauber durchgelaufenen Deinstallation von multiarch?

Ich habe network-manager zwar derzeit nicht installiert, eine Installation würde jedoch offenbar durchlaufen (und mein System ist selbstredend up-to-date):

Code: [Select]
~$ dpkg -l network-manager* | grep ii
~$
~$ sudo apt install -s network-managerReading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  libndp0 libteamdctl0
Suggested packages:
  libteam-utils
The following NEW packages will be installed:
  libndp0 libteamdctl0 network-manager
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Inst libndp0 (1.6-1+b1 Debian:unstable [amd64])
Inst libteamdctl0 (1.27-1 Debian:unstable [amd64])
Inst network-manager (1.14.4-4 Debian:unstable [amd64])
Conf libndp0 (1.6-1+b1 Debian:unstable [amd64])
Conf libteamdctl0 (1.27-1 Debian:unstable [amd64])
Conf network-manager (1.14.4-4 Debian:unstable [amd64])
~$

Offline DeKa

  • User
  • Posts: 327
Re: apt will 30 Pakete entfernen
« Reply #21 on: 2019/01/26, 18:49:23 »
Hallo @axt,
die ganze Ausgabe ohne Multiarchiv ist in #Antwort 13 schon vorhanden.
Ich habe nur für @piper nochmals angemerkt dass der Networkmanager deinstalliert werden soll.
Werde den Tipp von @jure morgen früh durchführen
Gruß DeKa

"Der größte Feind des Wissens ist nicht Unwissenheit, sondern die Illusion wissend zu sein. Von Stephen Hawking"

Offline der_bud

  • User
  • Posts: 876
  • member
Re: apt will 30 Pakete entfernen
« Reply #22 on: 2019/01/26, 19:19:30 »
Mich irritiert noch
...
Code: [Select]
Die folgenden Pakete sind zurückgehalten worden:
  libsystemd0 systemd
  ... 

 Hast Du irgendwas auf hold gesetzt? Zeig mal bitte die Ausgaben von
Code: [Select]
apt-mark showholds
apt-cache policy systemd
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline DeKa

  • User
  • Posts: 327
Re: apt will 30 Pakete entfernen
« Reply #23 on: 2019/01/26, 19:37:01 »
So hier die Ausgaben und der versuch eines reinstall.

Code: [Select]
root@siductionbox:/home/deka# apt-mark showholds
root@siductionbox:/home/deka#
Code: [Select]
root@siductionbox:/home/deka# apt-cache policy systemd
systemd:
  Installiert:           239-9
  Installationskandidat: 240-4
  Versionstabelle:
     240-4 500
        500 http://ftp.uni-stuttgart.de/debian unstable/main amd64 Packages
 *** 239-9 100
        100 /var/lib/dpkg/status
     239-5.6 500
        500 http://packages.siduction.org/fixes unstable/main amd64 Packages
Code: [Select]
root@siductionbox:/home/deka# apt-cache policy libsystemd0
libsystemd0:
  Installiert:           239-9
  Installationskandidat: 240-4
  Versionstabelle:
     240-4 500
        500 http://ftp.uni-stuttgart.de/debian unstable/main amd64 Packages
 *** 239-9 100
        100 /var/lib/dpkg/status
     239-5.6 500
        500 http://packages.siduction.org/fixes unstable/main amd64 Packages
Code: [Select]
root@siductionbox:/home/deka# apt install --reinstall systemd libsystemd0
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  amarok-common amarok-utils docbook-xml docbook-xsl kate-data katepart
  kde-runtime-data kdegames-card-data-kf5 kdegames-mahjongg-data-kf5
  kdelibs-bin kdelibs5-data kdelibs5-plugins kdoctools kdoctools5
  kpackagetool5 kwayland-data kwayland-integration libattica0.4
  libdbusmenu-qt2 libdbusmenu-qt5-2 libdlrestrictions1 libdvbv5-0
  libgpgme++2v5 libgpod4 libgrantlee-templates5 libkactivities6
  libkatepartinterfaces4 libkcmutils4 libkde3support4 libkdeclarative5
  libkdecore5 libkdegames6abi1 libkdegamesprivate1abi1 libkdesu5 libkdeui5
  libkdewebkit5 libkdnssd4 libkemoticons4 libkf5archive5 libkf5attica5
  libkf5auth-data libkf5bookmarks-data libkf5codecs-data libkf5codecs5
  libkf5completion-data libkf5completion5 libkf5config-bin libkf5config-data
  libkf5configcore5 libkf5configgui5 libkf5configwidgets-data
  libkf5coreaddons-data libkf5coreaddons5 libkf5crash5 libkf5dbusaddons-bin
  libkf5dbusaddons-data libkf5dbusaddons5 libkf5declarative-data
  libkf5dnssd-data libkf5dnssd5 libkf5doctools5 libkf5globalaccel-bin
  libkf5globalaccel-data libkf5globalaccel5 libkf5globalaccelprivate5
  libkf5guiaddons5 libkf5i18n-data libkf5i18n5 libkf5iconthemes-data
  libkf5idletime5 libkf5itemviews-data libkf5itemviews5 libkf5jobwidgets-data
  libkf5jobwidgets5 libkf5js5 libkf5kdelibs4support-data libkf5khtml-data
  libkf5kiontlm5 libkf5newstuff-data libkf5notifications-data
  libkf5notifications5 libkf5notifyconfig-data libkf5package-data
  libkf5package5 libkf5parts-data libkf5service-bin libkf5service-data
  libkf5service5 libkf5solid5 libkf5solid5-data libkf5sonnet5-data
  libkf5sonnetcore5 libkf5sonnetui5 libkf5textwidgets-data libkf5wallet-data
  libkf5wallet5 libkf5waylandclient5 libkf5widgetsaddons-data
  libkf5widgetsaddons5 libkf5windowsystem-data libkf5windowsystem5
  libkf5xmlgui-bin libkf5xmlgui-data libkf5xmlrpcclient-data libkfile4
  libkhtml5 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4 libknewstuff3-4
  libknotifyconfig4 libkntlm4 libkparts4 libkpty4 libkrosscore4
  libktexteditor4 libkwalletbackend5-5 liblastfm1 libmariadbclient18
  libmariadbd18 libntrack-qt4-1 libntrack0 libphonon4 libphonon4qt5-4
  libplasma3 libpolkit-qt-1-1 libqca-qt5-2 libqca-qt5-2-plugins libqca2
  libqjson0 libqt4-opengl libqt4-qt3support libqt5quickwidgets5 libqt5script5
  libqt5texttospeech5 libqtscript4-core libqtscript4-gui libqtscript4-network
  libqtscript4-sql libqtscript4-uitools libqtscript4-xml libqtwebkit4
  libsolid4 libssh-gcrypt-4 libtag-extras1 libthreadweaver4 libxapian30
  libxml2-utils ntrack-module-libnl-0 oxygen-icon-theme palapeli-data phonon
  phonon-backend-vlc phonon4qt5 phonon4qt5-backend-vlc
  plasma-scriptengine-javascript qml-module-qtquick2 sgml-base sgml-data
  xml-core
Verwenden Sie »apt autoremove«, um sie zu entfernen.
Die folgenden zusätzlichen Pakete werden installiert:
  libpam-systemd
Vorgeschlagene Pakete:
  systemd-container
Die folgenden Pakete werden ENTFERNT:
  amarok bomber bovo consolekit drkonqi granatier kaffeine kapman katomic
  kbattleship kblackbox kblocks kbounce kbreakout kde-runtime kdiamond
  kgoldrunner khelpcenter kigo killbots kinit kio kiriki klickety klines
  kmahjongg kmines knavalbattle knetwalk kolf kollision konquest kreversi
  kshisen ksirk kspaceduel ksquares ksudoku ktron kubrick libkf5auth5
  libkf5bookmarks5 libkf5configwidgets5 libkf5declarative5
  libkf5iconthemes-bin libkf5iconthemes5 libkf5kdegames7
  libkf5kdegamesprivate1 libkf5kdelibs4support5 libkf5kdelibs4support5-bin
  libkf5khtml-bin libkf5khtml5 libkf5kiocore5 libkf5kiofilewidgets5
  libkf5kiowidgets5 libkf5kmahjongglib5 libkf5newstuff5 libkf5newstuffcore5
  libkf5notifyconfig5 libkf5parts-plugins libkf5parts5 libkf5textwidgets5
  libkf5wallet-bin libkf5xmlgui5 libkf5xmlrpcclient5 libpolkit-qt5-1-1 lskat
  palapeli picmi qml-module-org-kde-games-core
Die folgenden Pakete werden aktualisiert (Upgrade):
  libpam-systemd libsystemd0 systemd
3 aktualisiert, 0 neu installiert, 70 zu entfernen und 9 nicht aktualisiert.
Es müssen 4.000 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 224 MB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n]
Gruß DeKa

"Der größte Feind des Wissens ist nicht Unwissenheit, sondern die Illusion wissend zu sein. Von Stephen Hawking"

Offline axt

  • User
  • Posts: 287
    • axebase.net
Re: apt will 30 Pakete entfernen
« Reply #24 on: 2019/01/26, 20:21:19 »
Wenn man sieht, seit wann systemd-240-x 239 ersetzt hat, also auch kein d-u gelaufen ist...ich würd's einfach mal machen lassen (sonst wird das endlos, man muß auch mal harte Entscheidungen treffen, hrr) - vorher die zu entfernenden, jedoch gewünschten Anwendungen (also nicht nötige Pakete dazu, libkf-hastenichgesehn, von denen es ohnehin aktualisierte zu installierende Pakete gibt) notieren, wenn man das nicht im Kopf hat, und vll. ein über IRC aktuell erstelltes Image ziehen für den Notfall, grin.

Dann fliegt der Plasma-Kram eben 'runter - so what? Wenn dann hoffentlich der Unterbau wieder geradegerückt ist, installierst Du Metapakete und besagte Anwendungen wieder nach.

Offline DeKa

  • User
  • Posts: 327
Re: apt will 30 Pakete entfernen
« Reply #25 on: 2019/01/29, 18:39:27 »
Hallo @axt,
Danke für deinen Tipp, werde das mal durchziehen und schauen ob es dann geht.


#edit:
Habe erst den reinstall von systemd und libsystem0 durchgeführt, danach dann das normale upgrade und dann full-upgrade.

Alles wieder i.O. gibt nichts zu meckern ;-)

Hab vielen Dank für den Tipp mit dem loslassen.
« Last Edit: 2019/01/29, 19:04:11 by DeKa »
Gruß DeKa

"Der größte Feind des Wissens ist nicht Unwissenheit, sondern die Illusion wissend zu sein. Von Stephen Hawking"