seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/11/21, 20:45:36


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [gelöst] Double Commander - Schnellsuche  (Read 2395 times)

0 Members and 1 Guest are viewing this topic.

Offline d146

  • User
  • Posts: 14
[gelöst] Double Commander - Schnellsuche
« on: 2019/09/19, 14:30:10 »
Hallo Leute,
ich bin auf ein zugegebenermaßen ziemlich spezielles Problem mit dem Dateimanager Double Commander (DC) gestoßen.

Man kann DC so konfigurieren, dass beim Tippen von Zeichen das gerade ausgewählte Verzeichnis inkrementell durchsucht wird und man somit, gerade in Verzeichnissen mit vielen Dateien, sehr schnell die gesuchte findet. Ein äußerst praktisches Feature also, das ich ständig nutze. Nur: Unter siduction funktioniert es einfach nicht. Habe  bisher auf Fedora und aktuell noch auf Debian Stretch & Buster keinerlei Probleme damit. Bei siduction verhält sich DC trotz 100%ig identischer Konfiguration dagegen so, dass durch Eingabe der einzelnen Zeichen nicht die Suche beginnt, sondern schon bei Tippen des ersten Zeichens (egal welches) sofort das Menü "Dateien" aufgerufen wird, so, als hätte ich ALT+D gedrückt.

Ich nutze siduction-Mate, habe aber zur Eingrenzung auch mal siduction-Gnome vom Stick getestet, ob es evtl. einen Unterschied bei den Desktops gibt - Ergebnis: identisch.

 Vielleicht nutzt ja jemand von Euch den DC ebenfalls und hat eine Idee, woran das  liegen könnte? Ich weiß einfach nicht mehr, wo ich noch suchen soll.

Danke und viele Grüße
« Last Edit: 2019/09/20, 20:26:46 by d146 »

Offline axt

  • User
  • Posts: 327
    • axebase.net
Re: Double Commander - Schnellsuche
« Reply #1 on: 2019/09/19, 19:23:01 »
Quote from: d146
beim Tippen von Zeichen das gerade ausgewählte Verzeichnis inkrementell durchsucht wird und man somit, gerade in Verzeichnissen mit vielen Dateien, sehr schnell die gesuchte findet.

Funktioniert hier mit siduction und doublecmd-qt (derzeit aus den sid-Repos) unter LXQt genau so.

(Ich nutze seit Äonen exzessiv krusader, habe hier doublecmd jedoch zusätzlich und auf sämtlichen anderen genutzten Systemen als hauptsächlichen Fileman installiert, nutze ihn gerade auch in Linux-Live-Systemen, wenn von verhunzten Kd.-Win-Rechnern ach so wichtige Dateien gesichert werden sollen.)

Vielleicht macht es einen Unterschied, ob Du doublecmd-qt oder -gtk installiert hast (da hat es durchaus schon bei dem jeweils Einem Probleme, beim Anderem nicht gegeben). Und hast Du's aus den sid-Repos oder direkt vom Programmierer? Die unterscheiden sich (Qt-Version).
« Last Edit: 2019/09/19, 19:27:05 by axt »

Offline d146

  • User
  • Posts: 14
Re: Double Commander - Schnellsuche
« Reply #2 on: 2019/09/19, 20:03:00 »
Danke für das schnelle Feedback - schön, dass Du Deine Erfahrungswerte gepostet hast.

Hatte ich ganz vergessen: Ich nutze bisher immer die gtk-Version, aktuell diese:
ii  doublecmd-gtk    0.9.6-1  amd64  twin-panel (commander-style) file manager (GTK2)
aus dem sid-Repo.

Vielleicht versuche ich es tatsächlich mal mit der qt-Version - auf den Gedanke war ich noch gar nicht gekommen, da eben die anderen gtk-Versionen nie Probleme gemacht hatten.

Danke noch mal und viele Grüße

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.768
    • g-com.eu
Re: Double Commander - Schnellsuche
« Reply #3 on: 2019/09/19, 20:26:21 »
Wie wäre es, das Teil einfach richtig zu konfigurieren? Vor allem die Filterbar. Leider habe ich nichts gefunden, was in Richtung einer Auto-Aktivierung der Menushortcuts ging. Genau das heisst bei doublecmd aber nix, Übersichtlichkeit war da noch nie ne Stärke, weder in der Programmierung noch in den Optionen.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline der_bud

  • User
  • Posts: 893
  • member
Re: Double Commander - Schnellsuche
« Reply #4 on: 2019/09/19, 20:48:26 »
Hier bei mir unter KDE mit doublecmd-qt 0.9.6-1 ist das Verhalten so wie es soll. Du hast ja schon geschrieben "trotz identische Konfiguration", aber check zur Sicherheit noch mal doppelt unter Konfigurieren-Optionen-Tasten > Tippen, Buchstabe: Schnellsuche. Sonst könnte ich mir höchstens noch vorstellen dass es bei Mate selber eine Desktop-/Fenstermanager-Einstellung hinsichtlich Tastaturkürzel ist...
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline d146

  • User
  • Posts: 14
Re: Double Commander - Schnellsuche
« Reply #5 on: 2019/09/19, 21:02:19 »
melmarker, der_bud: Danke für Eure Infos.

"Das Teil einfach richtig konfigurieren" - ich versuche schon alles, bevor ich mir hier melde ;-) Das Problem ist ja, dass ich langsam nicht mehr weiß, wo ich noch suchen soll. Ich habe auch mal von einem funktionierenden Buster einfach das doublecmd-Verzeichnis aus ~/.config kopiert habe - alle Einstellungen werden sauber übernommen, lediglich das geschilderte Verhalten bei der Schnellsuche ändert sich dadurch nicht. Übrigens reproduzierbar auch auf einem zweiten siduction-Mate.

Meine Vermutung ging und geht auch langsam in Richtung Desktop-Settings (daher ja auch der eingangs erwähnte Test mit Gnome), wo irgendeine Einstellungen noch vor dem doublecmd "zuschlägt", bevor dessen Einstellung wirksam wird.

Ich suche mal weiter.
Danke Euch.

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.768
    • g-com.eu
Re: Double Commander - Schnellsuche
« Reply #6 on: 2019/09/20, 00:18:46 »
und ich ziehe mir nen Mate :P
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.768
    • g-com.eu
Re: Double Commander - Schnellsuche
« Reply #7 on: 2019/09/20, 00:49:44 »
ok, das Verhalten von doublecmd-gtk kann ich bestätigen - und die -qt Version zeigt dieses Verhalten nicht. Ist eventuell mal nen Bug an den/die Entwicker wert, es kann und soll nicht sein, dass Accelerators einfach mal so angesprochen werden in GTK - obwohl sie nicht sichtbar sind.

Im Übrigen bin ich mir mit den Accels nicht sicher, da das Hauptmenu der Applikation bei jedem ersten Buchstaben aufpoppt. Ok, an der Qt-Version hab ich eigentlich nur zu nörgeln, dass die Accels ständig sichtbar sind - das ist wohl aber Qt default und nicht so einfach zu ändern.

Fällt mir nur auf, weil wir wegen diesem Mist mehr oder weniger große Probleme mit Applikationen in qterminal hatten und die Einstellung einfach mal implementiert haben:



Vielleicht findet sich ja sowas auch irgendwo in Gnome/Mate - oder die Buben haben es in irgendeiner tieferliegenden lib versaubeutelt - ich würde aber noch mal wiederholen, ist nen debian und nen upstream-bug wert.
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)

Offline d146

  • User
  • Posts: 14
Re: Double Commander - Schnellsuche
« Reply #8 on: 2019/09/20, 20:22:01 »
Herzlichen Dank für Deine Mühe und das Untersuchen des Phänomens!

Bin erst mal etwas "beruhigt", dass der Effekt bei Dir reproduzierbar ist. Ich habe der Vollständigkeit halber bei mir mal sowohl die Qt-Version von sid als auch die GTK-Version aus Alexanders Repo getestet: Die Qt-Version zeigt bei mir ebenfalls keine Probleme, die Alexx2000-GTK-Version dagegen ebenfalls den Fehler.

Daraufhin habe ich vorhin mal mit strace geschaut, was da ggf. zu sehen ist. Dabei ist mir schon in der Shell aufgefallen, dass bei jedem Druck auf beliebige Buchstaben-, Ziffern- oder Tasten wie Alt, Strg, Shift etc. diese Meldung kommt:

Code: [Select]
(doublecmd:9992): Gtk-WARNING **: 19:52:29.967: Failed to parse menu bar accelerator 'null'
Ein identischer Test als Vergleich mit z. B. Pluma zeigt keinerlei Fehlermeldungen dieser Art. Daraufhin habe ich mich mal mit dem dconf-Editor auf die Suche gemacht und bei

Code: [Select]
org.mate.interface.menubar-accel
den Default 'null' testhalber in 'F10' geändert - bingo. Damit taucht a) die o. g. Fehlermeldung nicht mehr auf und b) funktioniert damit nun auch bei der GTK-Version die Schnellsuche.  :)

Negative Auswirkungen habe ich auf die Schnelle noch nicht bemerkt. Keine Ahnung, ob das erst mal nur ein Workaround und nicht vielleicht doch eine Macke bei Mate/DC ist - ich schaue mir das alles mal noch genauer an. Und am Montag komme ich wieder an meine Buster-Rechner mit älterem Mate ran, vielleicht zeigt ein Vergleich da Unterschiede.

Vielen Dank noch mal für Deine/Eure Hilfe!
« Last Edit: 2019/09/20, 20:27:02 by d146 »

Offline melmarker

  • Global Moderator
  • User
  • *****
  • Posts: 2.768
    • g-com.eu
Re: [gelöst] Double Commander - Schnellsuche
« Reply #9 on: 2019/09/20, 23:37:40 »
org.mate.interface.menubar-accel - jau, genau so fühlte sich das an: alles, was bei 3 nicht auf dem Baum ist, löst das aus :D - wenn nicht irgendwodurch vorher abgefangen :D
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. (Benjamin Franklin, November 11, 1755)
Never attribute to malice that which can be adequately explained by stupidity. (Hanlons razor)