seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/10/22, 01:07:24


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: video playback with nouveau driver broken?  (Read 394 times)

0 Members and 1 Guest are viewing this topic.

Offline qord

  • User
  • Posts: 22
video playback with nouveau driver broken?
« on: 2019/08/06, 23:16:36 »
After todays d-u [1], on a pc with a Nvidia GT610 (GF119) card, almost all video players are crashing at the start of playback with a libva-related error:

Code: [Select]
VLC media player 3.0.7.1 Vetinari (revision 3.0.7.1-0-gf3940db4af)[000055bf2f054570] main libvlc: VLC wird mit dem Standard-Interface ausgeführt. Benutzen Sie 'cvlc', um VLC ohne Interface zu verwenden.
uint DBusMenuExporterDBus::GetLayout(int, int, const QStringList&, DBusMenuLayoutItem&): Condition failed: menu
libva info: VA-API version 1.5.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/nouveau_drv_video.so
libva info: va_openDriver() returns -1
[00007fd968002cc0] glconv_vaapi_x11 gl error: vaInitialize: unknown libva error
libva info: VA-API version 1.5.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/nouveau_drv_video.so
libva info: va_openDriver() returns -1
[00007fd968002cc0] glconv_vaapi_drm gl error: vaInitialize: unknown libva error
libva info: VA-API version 1.5.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/nouveau_drv_video.so
libva info: va_openDriver() returns -1
[00007fd968002cc0] glconv_vaapi_drm gl error: vaInitialize: unknown libva error
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = vlc path = /usr/bin pid = 4012
KCrash: Arguments: /usr/bin/vlc
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi from kdeinit
sock_file=/run/user/1000/kdeinit5__0
The only player I tried that still worked was totem, vlc could be configure to work by turning opengl off (switch to xvideo / XCB).
The nvidia binary driver does not properly install at the moment (legacy 390.xx), so I couldn't check if it also happens with the proprietary driver.

[1] The pc was used for the first time in 4 weeks today, so the issue might be older...

Offline DeepDayze

  • User
  • Posts: 409
Re: video playback with nouveau driver broken?
« Reply #1 on: 2019/08/06, 23:43:44 »
I got smplayer to work and I also am using Nouveau on an nVidia GT 730. Seems like libva is borken somehow.
Seems to be no bugs for the libva* packages
« Last Edit: 2019/08/07, 00:08:14 by DeepDayze »

Offline axt

  • User
  • Posts: 322
    • axebase.net
Re: video playback with nouveau driver broken?
« Reply #2 on: 2019/08/07, 08:20:07 »
GF GT710, nouveau. Several d-u last night, including gstreamer.

No problems with vlc and smplayer (either with mplayer or mpv). Now and at night.
« Last Edit: 2019/08/07, 08:25:40 by axt »

Offline DeepDayze

  • User
  • Posts: 409
Re: video playback with nouveau driver broken?
« Reply #3 on: 2019/08/09, 03:04:35 »
Looks like the new version of Mesa has corrected the issue with VLC and now videos play in VLC with codec set to Automatic.