seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/01/26, 13:30:08


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: With Kernel 5.4 hdmi sounds no available  (Read 277 times)

0 Members and 1 Guest are viewing this topic.

Offline Mte90

  • User
  • Posts: 141
  • KDE & Debian lover
    • http://www.mte90.net
With Kernel 5.4 hdmi sounds no available
« on: 2020/01/19, 17:07:58 »
I have this problems since few months and after a lot of testing, purge pulseaudio and so on I finished the idea for other debugging.So looking on reddit I found this https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=942803 and I was thinking, ehi I update always the kernel and maybe the problem is that because I didn't changed anything else.
So I installed linux-headers-5.3.14-towo.1-siduction-amd64 and now the audio on hdmi is back again.I just wanted to share here in case there is someone else with the issue and to report it.
PS: I was using the latest 5.4.11 kernel version.

Offline axt

  • User
  • Posts: 355
    • axebase.net
Re: With Kernel 5.4 hdmi sounds no available
« Reply #1 on: 2020/01/19, 18:56:44 »
Issues with pulseaudo I believe you.

Installing header files of a kernel, using a different kernel version, is definitely not the solution. Probably you have unknowingly changed something else at the same time.

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 1.945
    • Land of the Buckeye
Re: With Kernel 5.4 hdmi sounds no available
« Reply #2 on: 2020/01/19, 21:03:02 »
Pulseaudo on plasma desktop is working well here:

Code: [Select]
System:    Host: dibl-HP350 Kernel: 5.4.12-towo.2-siduction-amd64 x86_64 bits: 64
           Desktop: KDE Plasma 5.14.5 Distro: siduction 18.3.0 Patience - kde - (201805132121)
Audio:     Device-1: Intel Haswell-ULT HD Audio driver: snd_hda_intel
           Device-2: Intel 8 Series HD Audio driver: snd_hda_intel
           Sound Server: ALSA v: k5.4.12-towo.2-siduction-amd64
don@dibl-HP350:~$ sudo apt policy pulseaudio
pulseaudio:
  Installed: 13.0-3
  Candidate: 13.0-3
  Version table:
 *** 13.0-3 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline Mte90

  • User
  • Posts: 141
  • KDE & Debian lover
    • http://www.mte90.net
Re: With Kernel 5.4 hdmi sounds no available
« Reply #3 on: 2020/01/20, 10:15:48 »
Just to add more information:
  • Pulseaudio detect the HDMI output
  • Purged pulseaudio, removed and reinstalled, removed the folder in config, restarted pulseaudio also with log, I don't have any asound.rc (all of them multiple times)
  • In some cases the audio was available only selecting HDMI surround option but there was a delay with the video
  • In pavucontrol the audio on HDMI was available (the bar was moving) with no audio on the TV
  • Tried with different TVs without success
I tried installing that kernel without changing anything on pulseaudio, restart and now the audio was working.I have a Intel Haswell for HDMI on a laptop with 2 video cards and one is a Nvidia card.
My test with another kernel was the unique option that I didn't try, it is the first time that I did it.
Everything was updated to the latest version.