seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/10/21, 08:08:54


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [gelöst] Mate: An-/Abmeldeverzögerungen (at-spi-bus-launcher)  (Read 177 times)

0 Members and 1 Guest are viewing this topic.

Offline d146

  • User
  • Posts: 13
Hallo Leute,
ich hoffe, ich darf Euch zu diesem Thema um Hilfe bitten.
Seit einigen Tagen beobachte ich das Phänomen, dass

- man nach Eingabe der Anmeldedaten ca. 25 Sekunden warten muss, bis der Desktop erscheint (das dauerte bisher so ca. 2-3 Sekunden)
- beim Herunterfahren des Rechners diese Fehlermeldung erscheint:
  "Eine Anwendung läuft noch
   at-spi-bus-launcher
   keine Antwort"

   diese muss man zweimal wegklicken, dann dauert es auch hier knapp 30 Sekunden (bislang nur wenige Sekunden) und erst dann wird der Desktop beendet und der restliche Shutdown (Textmodus) wird durchgeführt.

Im syslog erscheinen da immer Meldungen wie diese:
at-spi-bus-laun[3732]: Failed to register client: Timeout was reached


Bei einem der Upgrades Anfang Oktober wurde dieses Paket upgegradet:
at-spi2-core:amd64 (2.34.0-2, 2.34.0-3)


zu dem /usr/lib/at-spi2-core/at-spi-bus-launcher gehört. Ich weiß allerdings nicht, ob das nur Zufall ist oder das Auftreten des Fehlers tatsächlich damit zusammenhängt - zeitlich würde es jedenfalls passen. Ich hatte beim ersten Auftreten gedacht, es sei nur Zufall, dass das Anmelden so sehr viel länger gedauert hat als gewohnt und beim Abmelden die Fehlermeldung erschien. Da das aber seither jedesmal so ist, habe ich dann genauer nachgeschaut.

Jedenfalls weiß ich nicht so richtig, wo ich ansetzen muss. Ein Test auf einer zweiten, identisch eingerichteten Maschine, die ich vor ungefähr zwei Wochen das letzte Mal benutzt hatte und die vorhin mal auf den neuesten Stand gebracht habe, zeigt nun haargenau das gleiche Problem - es scheint also reproduzierbar zu sein.

Falls also jemand mehr Ahnung von dieser Materie hat und evtl. dasselbe Problem beobachtet, wäre ich für Infos jeglicher Art sehr dankbar. Eine Suche im Web zeigte bisher leider nicht so wirklich hilfreiche Treffer.
« Last Edit: 2019/10/13, 11:15:39 by d146 »

Offline unklarer

  • User
  • Posts: 480
Re: Mate: An-/Abmeldeverzögerungen (at-spi-bus-launcher)
« Reply #1 on: 2019/10/11, 10:29:04 »
Ich fahre kein Mate. Das hier ist aus Lxde.

Code: [Select]
apt policy at-spi2-core
at-spi2-core:
  Installiert:           (keine)
  Installationskandidat: 2.34.0-3
  Versionstabelle:
     2.34.0-3 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
Code: [Select]
apt show at-spi2-core
Package: at-spi2-core
Version: 2.34.0-3
Priority: optional
Section: misc
Maintainer: Debian Accessibility Team <pkg-a11y-devel@lists.alioth.debian.org>
Installed-Size: 432 kB
Depends: libatspi2.0-0 (>= 2.9.90), libc6 (>= 2.7), libdbus-1-3 (>= 1.9.14), libglib2.0-0 (>= 2.37.3), libx11-6, libxtst6
Breaks: gdm3 (<< 3.4)
Homepage: https://wiki.gnome.org/Accessibility
Download-Size: 72,0 kB
APT-Sources: http://httpredir.debian.org/debian unstable/main amd64 Packages
Description: Assistive Technology Service Provider Interface (D-Bus-Kern)
 Dieses Paket enthält die Kernkomponenten von GNOME Accessibility.

Hier siehst du, für was das Paket zuständig ist.
Du beschreibst das zwar schlüssig, besser wäre aber, du würdest mit journalctl arbeiten/zeigen.

z.B.
Code: [Select]
$ journalctl -p warning -e
$ journalctl -p err -b -e
das -e kannst du auch weglassen. Es bewirkt nur, das die Ausgabe gleich an das Ende springt.
Oder beim Herunterfahren probieren
Code: [Select]
# journalctl -af > /home/user/RUNTERFAHREN.txtetc. damit du dir das beim nächsten Start ansehen kannst.

Schau dir das Journal an, es gibt viele Befehle, um deinem Problem nah zu kommen. Wenn es eine ~/.xsession-errors gibt, solltest du auch mal reinschauen...

Offline d146

  • User
  • Posts: 13
Re: Mate: An-/Abmeldeverzögerungen (at-spi-bus-launcher)
« Reply #2 on: 2019/10/13, 11:15:02 »
Hallo unklarer,
herzlichen Dank für Deine Antwort und die Infos. Was at-spi2-core beinhaltet, Analyse der Fehlermeldungen mit journalctl und auch Check von ~/.xsession-errors u. a. hatte ich natürlich schon gemacht, bevor ich mir hier gemeldet habe. Meine Infos waren sozusagen der erste Extrakt - ich wollte nicht haufenweise Infos posten, wo jemand das Phänomen vielleicht eh schon kannte und gleich Bescheid wusste.

Kurzes Update von meiner Seite: Ich habe nach weiterem Durchforsten der Logs gesehen, dass da im Umfeld der at-spi-bus-launcher-Einträge auch Meldungen bzgl. gnome-keyring-daemon (couldn't set environment variable in session) auftauchten.

Nach weiterer Recherche bin ich dann auf Hinweise gestoßen, dass es wohl im Zuge eines Updates von gnome-keyring zu den bei mir beobachteten Effekten kommt. Und tatsächlich war in der history.log dieses Update vermerkt:
gnome-keyring:amd64 (3.28.2-5, 3.34.0-1)

Also: testhalber downgrade von gnome-keyring auf 3.28.2-5
--> bingo. Beim Anmelden Zeit von Eingabe des Passworts bis fertig aufgebauter Mate-Desktop: 1,5 Sekunden. Beim Herunterfahren: Keine Meldung mehr bzgl. at-spi-bus-launcher und nach 2 Sekunden ist der Rechner down.

Alles wieder wie vorher - mit dem Workaround kann ich erst mal leben. Vielleicht ist das ja auch bald mit einem Update grundsätzlich erledigt:
https://github.com/mate-desktop/mate-session-manager/issues/222
https://github.com/mate-desktop/mate-session-manager/pull/223

Falls also jemand ähnliche Probleme hat, das alles zur Info.

Danke noch mal für Deine Hilfe und viele Grüße