seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/09/29, 23:33:53


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [solved] scribus - unerfüllte Abhängigkeiten  (Read 1729 times)

0 Members and 1 Guest are viewing this topic.

Offline 10toe

  • User
  • Posts: 159
[solved] scribus - unerfüllte Abhängigkeiten
« on: 2020/02/26, 17:15:18 »
Hi everybody!
I'm struggling with the scribus installation at the moment:
Code: [Select]
# apt-get install scribus
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 scribus : Hängt ab von: libopenscenegraph160 soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
Any ideas/recommends? Thank you very much in advance!Cheers! :-)
Hans


edit: solved
« Last Edit: 2020/02/26, 22:03:02 by 10toe »

Online towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.382
Re: scribus - unerfüllte Abhängigkeiten
« Reply #1 on: 2020/02/26, 17:46:40 »
Code: [Select]
towo:Defiant> LANG=C apt install scribus -s
NOTE: This is only a simulation!
      apt needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  fonts-roboto-hinted gir1.2-budgie-1.0 kodi-visualization-spectrum libavresample4:i386 libbdplus0 libbotan-2-9 libdata-parsebinary-perl libdns1107 libisc1104 libjs-iscroll libmysofa0 libprocps7
  libssh-gcrypt-4 libusrsctp1 libx264-155 libx264-155:i386 libx265-179:i386 linux-headers-5.5.5-towo.1-siduction-amd64 linux-image-5.5.5-towo.1-siduction-amd64
Use 'apt autoremove' to remove them.
The following additional packages will be installed:
  cups-bsd cups-client cups-common gdal-data hyphen-pt-pt icc-profiles-free libaec0 libarmadillo9 libarpack2 libcfitsio8 libcharls2 libcoin80c libcollada-dom2.4-dp0 libdap25 libdapclient6v5 libepsilon1
  libfreehand-0.1-1 libfreexl1 libfyba0 libgdal26 libgeos-3.8.0 libgeos-c1v5 libgeotiff5 libgraphicsmagick-q16-3 libhdf4-0-alt libhdf5-103 libkmlbase1 libkmldom1 libkmlengine1 libmspub-0.1-1 libnetcdf15
  libogdi4.1 libopenscenegraph160 libopenthreads21 libpagemaker-0.0-0 libpodofo0.9.6 libpq5 libproj15 libqhull7 libqxp-0.0-0 libspatialite7 libsuperlu5 libsz2 libxerces-c3.2 libzmf-0.0-0 odbcinst
  odbcinst1debian2 proj-bin proj-data scribus-data
Suggested packages:
  cups inetutils-inetd | inet-superserver libreoffice-writer libopenal0a libsimage-dev libbullet2 geotiff-bin gdal-bin libgeotiff-epsg graphicsmagick-dbg libhdf4-doc libhdf4-alt-dev hdf4-tools ogdi-bin
  icc-profiles scribus-ng-doc scribus-template texlive-latex-recommended
The following NEW packages will be installed:
  cups-bsd cups-client cups-common gdal-data hyphen-pt-pt icc-profiles-free libaec0 libarmadillo9 libarpack2 libcfitsio8 libcharls2 libcoin80c libcollada-dom2.4-dp0 libdap25 libdapclient6v5 libepsilon1
  libfreehand-0.1-1 libfreexl1 libfyba0 libgdal26 libgeos-3.8.0 libgeos-c1v5 libgeotiff5 libgraphicsmagick-q16-3 libhdf4-0-alt libhdf5-103 libkmlbase1 libkmldom1 libkmlengine1 libmspub-0.1-1 libnetcdf15
  libogdi4.1 libopenscenegraph160 libopenthreads21 libpagemaker-0.0-0 libpodofo0.9.6 libpq5 libproj15 libqhull7 libqxp-0.0-0 libspatialite7 libsuperlu5 libsz2 libxerces-c3.2 libzmf-0.0-0 odbcinst
  odbcinst1debian2 proj-bin proj-data scribus scribus-data
0 upgraded, 51 newly installed, 0 to remove and 0 not upgraded.
Inst cups-common (2.3.1-11 Debian:unstable, Debian:buildd-unstable [all])
Inst cups-client (2.3.1-11 Debian:unstable, Debian:buildd-unstable [amd64])
Inst cups-bsd (2.3.1-11 Debian:unstable, Debian:buildd-unstable [amd64])
Inst gdal-data (3.0.4+dfsg-1 Debian:unstable, Debian:testing [all])
Inst hyphen-pt-pt (1:6.4.0~rc2-1 Debian:unstable, Debian:testing [all])
Inst icc-profiles-free (2.0.1+dfsg-1 Debian:unstable, Debian:testing [all])
Inst libaec0 (1.0.4-1 Debian:unstable, Debian:testing [amd64])
Inst libarpack2 (3.7.0-3 Debian:unstable, Debian:testing [amd64])
Inst libsuperlu5 (5.2.1+dfsg1-4 Debian:unstable, Debian:testing [amd64])
Inst libarmadillo9 (1:9.800.4+dfsg-1 Debian:unstable, Debian:testing [amd64])
Inst libcfitsio8 (3.470-3 Debian:unstable, Debian:testing [amd64])
Inst libcharls2 (2.0.0+dfsg-1+b1 Debian:unstable, Debian:testing [amd64])
Inst libcoin80c (4.0.0+ds-1 Debian:unstable, Debian:testing [amd64])
Inst libcollada-dom2.4-dp0 (2.4.4+ds1-2+b3 Debian:unstable, Debian:testing [amd64])
Inst libdap25 (3.20.5-1 Debian:unstable, Debian:testing [amd64])
Inst libdapclient6v5 (3.20.5-1 Debian:unstable, Debian:testing [amd64])
Inst libepsilon1 (0.9.2+dfsg-4+b1 Debian:unstable, Debian:testing [amd64])
Inst libfreehand-0.1-1 (0.1.2-2 Debian:unstable, Debian:testing [amd64])
Inst libfreexl1 (1.0.5-3+b1 Debian:unstable, Debian:testing [amd64])
Inst libfyba0 (4.1.1-6 Debian:unstable, Debian:testing [amd64])
Inst libgeos-3.8.0 (3.8.0-1 Debian:unstable, Debian:testing [amd64])
Inst libgeos-c1v5 (3.8.0-1 Debian:unstable, Debian:testing [amd64])
Inst proj-data (6.3.1-1 Debian:unstable, Debian:testing [all])
Inst libproj15 (6.3.1-1 Debian:unstable, Debian:testing [amd64])
Inst libgeotiff5 (1.5.1-2 Debian:unstable, Debian:testing [amd64])
Inst libhdf4-0-alt (4.2.14-1 Debian:unstable, Debian:testing [amd64])
Inst libsz2 (1.0.4-1 Debian:unstable, Debian:testing [amd64])
Inst libhdf5-103 (1.10.4+repack-11 Debian:unstable [amd64])
Inst libkmlbase1 (1.3.0-8 Debian:unstable, Debian:testing [amd64])
Inst libkmldom1 (1.3.0-8 Debian:unstable, Debian:testing [amd64])
Inst libkmlengine1 (1.3.0-8 Debian:unstable, Debian:testing [amd64])
Inst libnetcdf15 (1:4.7.3-1 Debian:unstable, Debian:testing [amd64])
Inst libogdi4.1 (4.1.0+ds-1 Debian:unstable, Debian:testing [amd64])
Inst libpq5 (12.2-1 Debian:unstable, Debian:testing [amd64])
Inst libqhull7 (2015.2-4 Debian:unstable, Debian:testing [amd64])
Inst libspatialite7 (4.3.0a-6+b1 Debian:unstable, Debian:testing [amd64])
Inst libxerces-c3.2 (3.2.2+debian-1+b1 Debian:unstable, Debian:testing [amd64])
Inst odbcinst (2.3.6-0.1+b1 Debian:unstable, Debian:testing [amd64]) []
Inst odbcinst1debian2 (2.3.6-0.1+b1 Debian:unstable, Debian:testing [amd64])
Inst libgdal26 (3.0.4+dfsg-1 Debian:unstable, Debian:testing [amd64])
Inst libgraphicsmagick-q16-3 (1.4+really1.3.35-1 Debian:unstable, Debian:testing [amd64])
Inst libmspub-0.1-1 (0.1.4-1+b2 Debian:unstable, Debian:testing [amd64])
Inst libopenthreads21 (3.6.4+dfsg1-3+b10 Debian:unstable, Debian:testing [amd64])
Inst libopenscenegraph160 (3.6.4+dfsg1-3+b10 Debian:unstable, Debian:testing [amd64])
Inst libpagemaker-0.0-0 (0.0.4-1 Debian:unstable, Debian:testing [amd64])
Inst libpodofo0.9.6 (0.9.6+dfsg-5 Debian:unstable, Debian:testing [amd64])
Inst libqxp-0.0-0 (0.0.2-1 Debian:unstable, Debian:testing [amd64])
Inst libzmf-0.0-0 (0.0.2-1+b2 Debian:unstable, Debian:testing [amd64])
Inst proj-bin (6.3.1-1 Debian:unstable, Debian:testing [amd64])
Inst scribus-data (1.5.5+dfsg-5 Debian:unstable, Debian:testing [all])
Inst scribus (1.5.5+dfsg-5 Debian:unstable, Debian:testing [amd64])
Conf cups-common (2.3.1-11 Debian:unstable, Debian:buildd-unstable [all])
Conf cups-client (2.3.1-11 Debian:unstable, Debian:buildd-unstable [amd64])
Conf cups-bsd (2.3.1-11 Debian:unstable, Debian:buildd-unstable [amd64])
Conf gdal-data (3.0.4+dfsg-1 Debian:unstable, Debian:testing [all])
Conf hyphen-pt-pt (1:6.4.0~rc2-1 Debian:unstable, Debian:testing [all])
Conf icc-profiles-free (2.0.1+dfsg-1 Debian:unstable, Debian:testing [all])
Conf libaec0 (1.0.4-1 Debian:unstable, Debian:testing [amd64])
Conf libarpack2 (3.7.0-3 Debian:unstable, Debian:testing [amd64])
Conf libsuperlu5 (5.2.1+dfsg1-4 Debian:unstable, Debian:testing [amd64])
Conf libarmadillo9 (1:9.800.4+dfsg-1 Debian:unstable, Debian:testing [amd64])
Conf libcfitsio8 (3.470-3 Debian:unstable, Debian:testing [amd64])
Conf libcharls2 (2.0.0+dfsg-1+b1 Debian:unstable, Debian:testing [amd64])
Conf libcoin80c (4.0.0+ds-1 Debian:unstable, Debian:testing [amd64])
Conf libcollada-dom2.4-dp0 (2.4.4+ds1-2+b3 Debian:unstable, Debian:testing [amd64])
Conf libdap25 (3.20.5-1 Debian:unstable, Debian:testing [amd64])
Conf libdapclient6v5 (3.20.5-1 Debian:unstable, Debian:testing [amd64])
Conf libepsilon1 (0.9.2+dfsg-4+b1 Debian:unstable, Debian:testing [amd64])
Conf libfreehand-0.1-1 (0.1.2-2 Debian:unstable, Debian:testing [amd64])
Conf libfreexl1 (1.0.5-3+b1 Debian:unstable, Debian:testing [amd64])
Conf libfyba0 (4.1.1-6 Debian:unstable, Debian:testing [amd64])
Conf libgeos-3.8.0 (3.8.0-1 Debian:unstable, Debian:testing [amd64])
Conf libgeos-c1v5 (3.8.0-1 Debian:unstable, Debian:testing [amd64])
Conf proj-data (6.3.1-1 Debian:unstable, Debian:testing [all])
Conf libproj15 (6.3.1-1 Debian:unstable, Debian:testing [amd64])
Conf libgeotiff5 (1.5.1-2 Debian:unstable, Debian:testing [amd64])
Conf libhdf4-0-alt (4.2.14-1 Debian:unstable, Debian:testing [amd64])
Conf libsz2 (1.0.4-1 Debian:unstable, Debian:testing [amd64])
Conf libhdf5-103 (1.10.4+repack-11 Debian:unstable [amd64])
Conf libkmlbase1 (1.3.0-8 Debian:unstable, Debian:testing [amd64])
Conf libkmldom1 (1.3.0-8 Debian:unstable, Debian:testing [amd64])
Conf libkmlengine1 (1.3.0-8 Debian:unstable, Debian:testing [amd64])
Conf libnetcdf15 (1:4.7.3-1 Debian:unstable, Debian:testing [amd64])
Conf libogdi4.1 (4.1.0+ds-1 Debian:unstable, Debian:testing [amd64])
Conf libpq5 (12.2-1 Debian:unstable, Debian:testing [amd64])
Conf libqhull7 (2015.2-4 Debian:unstable, Debian:testing [amd64])
Conf libspatialite7 (4.3.0a-6+b1 Debian:unstable, Debian:testing [amd64])
Conf libxerces-c3.2 (3.2.2+debian-1+b1 Debian:unstable, Debian:testing [amd64])
Conf odbcinst (2.3.6-0.1+b1 Debian:unstable, Debian:testing [amd64])
Conf odbcinst1debian2 (2.3.6-0.1+b1 Debian:unstable, Debian:testing [amd64])
Conf libgdal26 (3.0.4+dfsg-1 Debian:unstable, Debian:testing [amd64])
Conf libgraphicsmagick-q16-3 (1.4+really1.3.35-1 Debian:unstable, Debian:testing [amd64])
Conf libmspub-0.1-1 (0.1.4-1+b2 Debian:unstable, Debian:testing [amd64])
Conf libopenthreads21 (3.6.4+dfsg1-3+b10 Debian:unstable, Debian:testing [amd64])
Conf libopenscenegraph160 (3.6.4+dfsg1-3+b10 Debian:unstable, Debian:testing [amd64])
Conf libpagemaker-0.0-0 (0.0.4-1 Debian:unstable, Debian:testing [amd64])
Conf libpodofo0.9.6 (0.9.6+dfsg-5 Debian:unstable, Debian:testing [amd64])
Conf libqxp-0.0-0 (0.0.2-1 Debian:unstable, Debian:testing [amd64])
Conf libzmf-0.0-0 (0.0.2-1+b2 Debian:unstable, Debian:testing [amd64])
Conf proj-bin (6.3.1-1 Debian:unstable, Debian:testing [amd64])
Conf scribus-data (1.5.5+dfsg-5 Debian:unstable, Debian:testing [all])
Conf scribus (1.5.5+dfsg-5 Debian:unstable, Debian:testing [amd64])

apt policy libopenscenegraph160

Sayes what?
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline 10toe

  • User
  • Posts: 159
Re: scribus - unerfüllte Abhängigkeiten
« Reply #2 on: 2020/02/26, 20:52:06 »
apt policy libopenscenegraph160

Sayes what?
Code: [Select]
$ apt policy libopenscenegraph160
libopenscenegraph160:
  Installiert:           (keine)
  Installationskandidat: 3.6.4+dfsg1-3+b10
  Versionstabelle:
     3.6.4+dfsg1-3+b10 500
        500 http://ftp2.de.debian.org/debian unstable/main amd64 Packages

Online towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.382
Re: scribus - unerfüllte Abhängigkeiten
« Reply #3 on: 2020/02/26, 21:27:11 »
apt install libopenscenegraph160
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline 10toe

  • User
  • Posts: 159
Re: scribus - unerfüllte Abhängigkeiten
« Reply #4 on: 2020/02/26, 21:35:56 »
Code: [Select]
# apt-get install libopenscenegraph160
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libopenscenegraph160 : Hängt ab von: libgdal26 (>= 3.0.0) soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
Code: [Select]
# apt policy libgdal26
libgdal26:
  Installiert:           (keine)
  Installationskandidat: 3.0.4+dfsg-1
  Versionstabelle:
     3.0.4+dfsg-1 500
        500 http://ftp2.de.debian.org/debian unstable/main amd64 Packages
Code: [Select]
# apt-get install libgdal26
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libgdal26 : Hängt ab von: gdal-data (>= 3.0.4+dfsg-1) aber 3.0.2+dfsg-1 soll installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
Code: [Select]
# apt-get install gdal-data
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  digikam-data digikam-private-libs enblend enchant enfuse guile-2.0-libs hugin hugin-data hugin-tools kipi-plugins-common libaec0
  libarchive-zip-perl libarmadillo9 libarpack2 libastro1 libcharls2 libdap25 libdapclient6v5 libdns-export1104 libdns1107
  libenchant1c2a libepsilon1 libexiv2-14 libfreexl1 libfyba0 libgdal26 libgdcm2.8 libgdcm3.0 libgeos-3.8.0 libgeos-c1v5 libgeotiff5
  libgps25 libhdf4-0-alt libhdf5-103 libimage-exiftool-perl libiptc0 libisc-export1100 libisc1104 libkf5jsembed-data libkf5jsembed5
  libkf5mediawiki5 libkf5xmlrpcclient-data libkf5xmlrpcclient5 libkmlbase1 libkmldom1 libkmlengine1 libkwineffects11
  libkwinglutils11 libkwinxrenderutils11 liblensfun-data-v1 liblensfun1 liblivemedia68 libmarblewidget-qt5-28 libmime-charset-perl
  libmysofa0 libnetcdf13 libnetcdf15 libodbc1 libogdi4.1 libopencv-calib3d4.2 libopencv-core3.2 libopencv-core4.2
  libopencv-features2d4.2 libopencv-flann4.2 libopencv-highgui4.2 libopencv-imgcodecs4.2 libopencv-imgproc3.2 libopencv-imgproc4.2
  libopencv-ml3.2 libopencv-ml4.2 libopencv-objdetect4.2 libopencv-videoio4.2 libpano13-3 libpano13-bin libposix-strptime-perl
  libprocps7 libproj15 libqhull7 libqt5serialport5 libqtav1 libqtavwidgets1 libshp2 libsocket++1 libsombok3 libspatialite7
  libsuperlu5 libsz2 libtaskmanager6 libtbb2 libunicode-linebreak-perl liburiparser1 libvigraimpex11 libwxbase3.0-0v5
  libwxgtk3.0-gtk3-0v5 linux-headers-5.3.14-towo.1-siduction-amd64 linux-headers-5.4.7-towo.2-siduction-amd64
  linux-image-5.3.14-towo.1-siduction-amd64 linux-image-5.4.7-towo.2-siduction-amd64 marble-plugins marble-qt-data minidlna
  odbcinst odbcinst1debian2 opencv-data paperkey proj-bin proj-data python3-asn1crypto qml-module-qtquick-controls-styles-breeze
Verwenden Sie »apt autoremove«, um sie zu entfernen.
Die folgenden zusätzlichen Pakete werden installiert:
  digikam-private-libs libgdal26 libgdcm3.0 libnetcdf15 libopencv-calib3d4.2 libopencv-core4.2 libopencv-features2d4.2
  libopencv-flann4.2 libopencv-highgui4.2 libopencv-imgcodecs4.2 libopencv-imgproc4.2 libopencv-ml4.2 libopencv-objdetect4.2
  libopencv-videoio4.2
Die folgenden Pakete werden ENTFERNT:
  libgdal20 libopencv-highgui3.2 libopencv-imgcodecs3.2 libopencv-objdetect3.2 libopencv-videoio3.2
Die folgenden NEUEN Pakete werden installiert:
  libgdal26 libgdcm3.0 libnetcdf15 libopencv-calib3d4.2 libopencv-core4.2 libopencv-features2d4.2 libopencv-flann4.2
  libopencv-highgui4.2 libopencv-imgcodecs4.2 libopencv-imgproc4.2 libopencv-ml4.2 libopencv-objdetect4.2 libopencv-videoio4.2
Die folgenden Pakete werden aktualisiert (Upgrade):
  digikam-private-libs gdal-data
2 aktualisiert, 13 neu installiert, 5 zu entfernen und 0 nicht aktualisiert.
Es müssen 27,0 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 45,2 MB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n]
Should I proceed?

Online towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.382
Re: scribus - unerfüllte Abhängigkeiten
« Reply #5 on: 2020/02/26, 21:38:43 »
Es ist dein System. Bei mir ist

Code: [Select]
libgdal20 libopencv-highgui3.2 libopencv-imgcodecs3.2 libopencv-objdetect3.2 libopencv-videoio3.2
davon nichts installiert.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline 10toe

  • User
  • Posts: 159
Re: scribus - unerfüllte Abhängigkeiten
« Reply #6 on: 2020/02/26, 22:02:36 »
Works!!! Danke wieder einmal für den richtigen Denkanstoß!
Viele Grüße!Hans