seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/08/07, 20:15:26


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: probleme mit public-key Übertragung auf ssh-server  (Read 669 times)

0 Members and 1 Guest are viewing this topic.

Offline dieres

  • User
  • Posts: 750
moin,
ich habe 2 Nas mit debian buster und Openmedivault aufgesetzt. Dort läuft je ein openssh server auf nicht standard port. auf den Servern und dem Laptop Client existiert je der gleiche User.

Dann habe ich mit ssh-keygen -t rsa -b 4096 ein Schlüsselpar erstellt, das ich mit ssh-copy-id -p PORT -i .ssh/id_rsa.bub user@IP-des-Servers auf die beiden Server übertragen habe. Bei einem klappt das beim anderen nicht, dort werde ich immer noch nach dem Passwort gefragt.
Der Softwarestand ist bei beiden Servern exact gleich, genauso wie die Rechte des Verzeichnis und der Dateien in .ssh.

Ich steh hier auf dem Schlauch, woran kann das noch liegen?

Offline dieres

  • User
  • Posts: 750
Re: probleme mit public-key Übertragung auf ssh-server
« Reply #1 on: 2020/03/30, 11:21:53 »
Beim Schreiben dieses Beitrags hab ich erahnt, das es sinnvoll wäre statt mit ls -la mal mit ls -lna nachzuschauen. Und siehe da, der user hatte eine andere Gruppe und eine andere nummerische gruppenid.
nachdem ich das korrigiert habe geht es.

Offline dieres

  • User
  • Posts: 750
Re: probleme mit public-key Übertragung auf ssh-server
« Reply #2 on: 2020/03/30, 11:37:46 »
Nun sind die nummerischen Werte für UID und GID des users auf dem Server wo es sofort ging allerdings auch unterschiedlich! Fragt sich wo der Fehler nun wirklich gesteckt hat?

Auf der anderen Seite: nun geht es!