seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/11/28, 00:17:50


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: WebDav mit Dolphin geht nicht (mehr)  (Read 453 times)

0 Members and 1 Guest are viewing this topic.

Offline paco

  • User
  • Posts: 50
WebDav mit Dolphin geht nicht (mehr)
« on: 2020/07/02, 18:54:22 »
Hallo zusammen,

früher konnte ich mittels Dolphin und WebDav (wie hier https://kb.mailbox.org/display/MBOKB/WebDav+unter+Linux perfekt beschrieben) problemlos auf z. B. mailbox.org zugreifen, nun leider jedoch nicht mehr.

Wenn ich in der Suchleiste von Dolphin "webdavs://dav.mailbox.org/servlet/webdav.infostore/" oder einen der anderen Vorschläge eingebe, dann passiert ........ NICHTS! :-(

Fehlt mir da ein plugin (welches) oder wo kann ich ggf. weitersuchen?

Mittels davfs2 funktioniert das übrigens problemlos, nur habe ich da bei manchen Servern Probleme mit Leerzeichen in den Datei-/Verzeichnisnamen, die dann einfach nicht angezeigt werden und folglich auch nicht zugänglich sind.
 
Ich wünsche Euch noch eine schöne Restwoche und alles Gute
paco

Mein System ist ein nahezu täglich mittels du aktualisertes Siduction mit KDE (ohne Fremdquellen!):
Code: [Select]
inxi -v2
System:    Host: hypnos Kernel: 5.7.7-towo.1-siduction-amd64 x86_64 bits: 64 Console: tty 2
           Distro: siduction 18.3.0 Patience - kde - (202002031718)
Machine:   Type: Desktop Mobo: Micro-Star model: B450M MORTAR MAX (MS-7B89) v: 1.0 serial: J816077350
           UEFI: American Megatrends v: 2.70 date: 04/21/2020
CPU:       6-Core: AMD Ryzen 5 3600 type: MT MCP speed: 2198 MHz min/max: 2200/3600 MHz
Graphics:  Device-1: Conexant Systems CX23885 PCI Video and Audio Decoder driver: cx23885 v: 0.0.4
           Device-2: NVIDIA GP107 [GeForce GTX 1050] driver: nvidia v: 440.100
           Display: server: X.Org 1.20.8 driver: nvidia unloaded: fbdev,modesetting,nouveau,vesa resolution: 2560x1440~60Hz
           OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
Drives:    Local Storage: total: 6.37 TiB used: 2.46 TiB (38.7%)
Info:      Processes: 339 Uptime: 15m Memory: 23.50 GiB used: 11.19 GiB (47.6%) Shell: Bash inxi: 3.1.04
Code: [Select]
dpkg -l | grep dolphin
ii  dolphin                                       4:20.04.2-1                        amd64        file manager
ii  dolphin-plugins                               4:20.04.2-1                        amd64        plugins for Dolphin
ii  libdolphinvcs5:amd64                          4:20.04.2-1                        amd64        library to show version control in Dolphin

 

Offline unklarer

  • User
  • Posts: 534
Re: WebDav mit Dolphin geht nicht (mehr)
« Reply #1 on: 2020/07/02, 19:55:42 »
Quote from: paco
Wenn ich in der Suchleiste von Dolphin "webdavs://dav.mailbox.org/servlet/webdav.infostore/" oder einen der anderen Vorschläge eingebe, dann passiert ........ NICHTS!

Du hast dolphin aus dem Terminal gestartet, die Suchleist entsprechend befüllt...    ;)
Welche Fehlermeldung und was sagt die "Tante" dazu?

Offline hendrikL

  • User
  • Posts: 447
Re: WebDav mit Dolphin geht nicht (mehr)
« Reply #2 on: 2020/07/02, 21:22:09 »
Es muss wohl der webdav Ordner explizit hinzugefügt werden.
Siehe

« Last Edit: 2020/07/02, 21:27:17 by hendrikL »

Offline paco

  • User
  • Posts: 50
Re: WebDav mit Dolphin geht nicht (mehr)
« Reply #3 on: 2020/07/02, 21:43:18 »
@ unklarer: Ja, keine Ausgabe auf der Konsole! Null

@ hendrikL: Super, muss man erst drauf kommen. Danke, scheint der richtige Weg u sein, komme aber trotzdem nicht weiter. Vermutlich ist der Port 80 falsch. Es geht per https, da wäre doch wohl 443 statt 80 angemessen, oder?

Offline paco

  • User
  • Posts: 50
Re: WebDav mit Dolphin geht nicht (mehr)
« Reply #4 on: 2020/07/02, 21:46:48 »
es geht aber weder mit Port 80 noch mit 443! :-(

Offline hendrikL

  • User
  • Posts: 447
Re: WebDav mit Dolphin geht nicht (mehr)
« Reply #5 on: 2020/07/02, 22:21:42 »
Versuche mal ohne das https:// vor der sever-adresse und unten Verschlüsselung anklicken, der Pfad zum Ordner muss auch stimmen.

So hat das bei mir funktioniert!

Ps.: test==foo, ersetzen mit richtigen Bezeichnern/Namen
« Last Edit: 2020/07/02, 22:49:10 by hendrikL »

Offline paco

  • User
  • Posts: 50
Re: WebDav mit Dolphin geht nicht (mehr)
« Reply #6 on: 2020/07/03, 00:04:58 »
@hendrikL: Danke vielmals, manchmal sieht man doch den Wald vor lauter Bäumen nicht mehr.
Hat geklappt!
Kann man eigentlich die Zugangsdaten dauerhaft speichern?
Noch ein sehr schönes Wochenende

Offline paco

  • User
  • Posts: 50
Re: WebDav mit Dolphin geht nicht (mehr)
« Reply #7 on: 2020/07/03, 00:18:39 »
Doch eine Frage:Wenn ich mittels davfs2 auf einen WebDav-Server zugreife, sehe ich keine Dateien/Verzeichnisse, die ein Leerzeichen im Namen enthalten. Mittels Dolphin gibt es jedoch kein Problem.
Grübel grübel ...

Offline hendrikL

  • User
  • Posts: 447
Re: WebDav mit Dolphin geht nicht (mehr)
« Reply #8 on: 2020/07/03, 01:12:37 »
Code: [Select]
mount.davfs server ~/foo
cd ~/foo
ls
 lost+found  'Public infostore'   Userstore

Bei mir™ werden Verzeichnisse mit Leerzeichen angezeigt.
« Last Edit: 2020/07/03, 01:18:46 by hendrikL »

Offline paco

  • User
  • Posts: 50
Re: WebDav mit Dolphin geht nicht (mehr)
« Reply #9 on: 2020/07/03, 01:25:21 »
Ich muss mich korrigieren: Das Problem tritt hier nur bei einem Server (vhs.cloud) auf.
Mittels Dolphin ist alles perfekt und wie erwartet, mittels davfs2 sehe ich dort aber keine Dateien/Verzeichnisse, die Leerzeichen enthalten. Auch nicht, wenn ich sie selber anlege!
Das scheint also eher ein Serverproblem zu sein, nur: wie kann ich das umgehen?

Könnte das ein Zeichensatzproblem sein, oder eine Konfigvariable in davfs2.conf?