seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/05/31, 00:41:54


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Probleme mit Intel GPU  (Read 280 times)

0 Members and 1 Guest are viewing this topic.

Offline pit

  • User
  • Posts: 200
Probleme mit Intel GPU
« on: 2020/04/11, 02:17:41 »
Seit längerer Zeit beobachte ich mit meinem Thinkpad T480 immer wieder Störungen auf dem Display. Es laufen dann von unten nach oben Streifen durchs Bild. CPU/GPU: Intel Core i7-8550U/Intel UHD Graphics 620, Treiber i915
 
Immer, wenn das passiert, sagt das Logfile (journalctl -f):
Code: [Select]
[drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
Installiert ist bzw. war:
Code: [Select]
ii  xserver-xorg-video-intel           2:2.99.917+git20190815-1Hier [1] ist zu lesen:
"If your graphic card is etc. 2007 and newer, try uninstalling xserver-xorg-video-intel and use the builtin modesetting driver (xserver-xorg-core) instead."
 
Ich habe daraufhin xserver-xorg-video-intel deinstalliert. Die Probleme sind leider nicht vom Tisch.

Wenn man nach der Fehlermeldung googelt, bekommt man diverse Treffer (z.T. schon zwei, drei Jahre zurückliegend). Eine echte Lösung habe ich nicht entdeckt. Ich denke nicht, dass es ein Hardware-Schaden ist, ich kann dieses Verhalten mit Win10 nicht beobachten (Dual Boot System).


System ist up to date, mache fast täglich full-upgrades.

Code: [Select]
System:    Host: t480 Kernel: 5.6.3-towo.1-siduction-amd64 x86_64 bits: 64 Desktop: KDE Plasma 5.17.5
Distro: siduction 18.3.0 Patience - kde - (201805132121)

Hat jemand einen Tipp, was ich tun könnte?


[1] https://wiki.debian.org/GraphicsCard#Intel

Offline axt

  • User
  • Posts: 378
    • axebase.net
Re: Probleme mit Intel GPU
« Reply #1 on: 2020/04/11, 10:09:26 »
Die bei dieser Error-Msg. oft als helfend genannte Begrenzung der C-States (1, 2) durch eine der folgenden Bootoptionen getestet?

Code: [Select]
intel_idle.max_cstate=4
oder

Code: [Select]
i915.enable_rc6=0
Wobei das Fehlerbild bei Dir mit den wandernden Streifen nicht das gleiche ist, deutet jedoch auch auf falsche Frequenzen hin. Da könntest Du, falls obiges nicht hilft, eine "/usr/share/X11/xorg.conf.d/20-intel.conf" mit entsprechenden Werten (Modelines) für Dein Display schreiben.
« Last Edit: 2020/04/11, 10:16:03 by axt »

Offline pit

  • User
  • Posts: 200
Re: Probleme mit Intel GPU
« Reply #2 on: 2020/04/14, 20:18:50 »
Hallo axt,


ganz herzlichen Dank für deine Tipps! Ich habe die beiden Boot-Parameter getestet, der Fehler trat leider weiter auf.
Quote
eine "/usr/share/X11/xorg.conf.d/20-intel.conf" mit entsprechenden Werten (Modelines) für Dein Display
... habe ich nocht nicht probiert. Ich war aber mal so frech, mir temporär einen Liqorix-Kernel zu installieren und zu booten.


Die aktuelle Session auf meinem Thinkpad verhält sich bis jetzt unauffällig. Egal was ich mache, den Fehler konnte ich bis jetzt nicht reproduzieren.


Ich kann leider nicht mehr sagen, seit wann (respektive seit welcher Version von towos Kernels) der Fehler aufgetreten ist (derzeit installiert ist 5.6.3-towo.2-siduction-amd64). Jedenfalls gab es anfangs keine Probleme (ich habe den Lenovo Thinkpad seit Ende September 2018, Siduction von Anfang an installiert und seitdem fast täglich aktualisiert).


Der Liqorix Kernel ist noch eine 5.5er Version:
Code: [Select]
Linux t480 5.5.0-16.2-liquorix-amd64 #1 ZEN SMP PREEMPT liquorix 5.5-21.1~sid (2020-04-11) x86_64 GNU/Linux

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.352
Re: Probleme mit Intel GPU
« Reply #3 on: 2020/04/14, 21:30:54 »
Bitte boote das System mal mit intel_iommu=igfx_off als Bootparameter.
Alternativ kannst Du auch härter mit intel_iommu=off agieren.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline pit

  • User
  • Posts: 200
Re: Probleme mit Intel GPU
« Reply #4 on: 2020/04/14, 22:47:04 »
Hallo towo,
Quote
Bitte boote das System mal mit intel_iommu=igfx_off als Bootparameter.
Sieht gut aus - das Problem ist bisher nicht wieder aufgetreten. Ich werde das wohl mal in die /etc/default/grub schreiben + sudo update grub.