Siduction Forum > Hardware-Support (DE)

WWAN Gerät erscheint nicht im Netzwerkmanager - Gelöst

(1/2) > >>

tomsiduction:
Hallo
Ich habe ein eingebautes LTE Modem.

Lt hwinfo:


--- Code: --- USB 00.c: 0200 Ethernet controller
  [Created at usb.122]
  Unique ID: CNRg.h8XqqTxwmE6
  Parent ID: k4bc.2DFUsyrieMD
  SysFS ID: /devices/pci0000:00/0000:00:14.0/usb1/1-6/1-6:2.12
  SysFS BusID: 1-6:2.12
  Hardware Class: network
  Model: "Sierra Wireless EM7305"
  Hotplug: USB
  Vendor: usb 0x1199 "Sierra Wireless, Inc."
  Device: usb 0x9041 "EM7305"
  Revision: "0.06"
  Driver: "cdc_mbim"
  Driver Modules: "cdc_mbim"
  Device File: wwan0
  Speed: 480 Mbps
  HW Address: be:b9:1e:d6:37:90
  Link detected: no
  Module Alias: "usb:v1199p9041d0006dc00dsc00dp00ic02isc0Eip00in0 C"
  Driver Info #0:
    Driver Status: qcserial is active
    Driver Activation Cmd: "modprobe qcserial"
  Driver Info #1:
    Driver Status: cdc_mbim is active
    Driver Activation Cmd: "modprobe cdc_mbim"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #58 (Hub)

--- End code ---

Das Gerät ist jedoch im Netzwerkmanager nicht zu sehen.

Ich bin für jeden Hinweis dankbar

Vielen Dank im Voraus

axt:
Da es durch eine nicht aufgeführte Abfrage gefunden wird, kann es nicht durch einen SW-/HW-Schalter deaktiviert sein und ist überhaupt auch tatsächlich vorhanden (nicht wenige User denken, sie hätten WWAN, nur weil ein SIM-Kartenslot vorhanden ist - eine Karte gesteckt hast Du aber?).

Danach gesucht, findet man bspw. dies für ähnliche/Nachfolge-Sierra-Wireless-Modelle. Ich würde mit den Hayes-Befehlen testen:



--- Code: ---AT!ENTERCND="A710"
AT#USBCOMP=1,1,100D
AT!RESET

--- End code ---

axt:
Sucht man weiter, findet man diesen launchpad.net-Thread. Darin wird auf Dell Wireless 5809e support in Linux - a followup (und darin auch auf AirPrime - EM73xx/7655/8805 - AT Command Reference) verlinkt. Daraus ist /etc/udev/rules.d/99-em7305.rules erstellt worden.

tomsiduction:
Hallo und vielen Dank
Ich habe die
 /etc/udev/rules.d/99-em7305.rules
hinzugefügt.
Ohne Erfolg.
Ich habe nun folgendes ausprobiert:

Start von siduction vom USB-Stick:

->Ein Start von siduction vom USB-Stick findet das Modem sofort.

Wo muss ich bitte nachschauen bzw. die Konfiguration übernehmen?


--- Code: ---AT!ENTERCND="A710"
führt zu
bash: !ENTERCND="A710": event not found

--- End code ---


Vielen Dank


axt:

--- Quote from: tomsiduction ---Ein Start von siduction vom USB-Stick findet das Modem sofort.
--- End quote ---

Ja, aber Du hast gelesen, daß es um den Modus geht? Ich habe "alles" verlinkt. Sowas mache ich auch, damit Hilfesuchende sehen können, wie man Informationen finden kann, wie man sucht.


--- Quote ---Wo muss ich bitte nachschauen bzw. die Konfiguration übernehmen?
--- End quote ---

Ich habe nun schon Hayes- und nicht nur AT-Befehle geschrieben (sprich, danach hättest Du suchen können, da Du offensichtlich nie mit der Materie Analogmodems und Ausführen von AT-Befehlen in entsprechenden Terminals zu tun gehabt hast - zu jung für die 90er ;-), aber wie Du siehst, braucht man immer noch).

Beides mit root-Rechten:


--- Code: ---# apt install minicom
# minicom -o console

--- End code ---

Navigation

[0] Message Index

[#] Next page

Go to full version