seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/07/16, 20:07:01


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: WWAN Gerät erscheint nicht im Netzwerkmanager - Gelöst  (Read 1442 times)

0 Members and 1 Guest are viewing this topic.

Offline tomsiduction

  • User
  • Posts: 140
Hallo
Ich habe ein eingebautes LTE Modem.

Lt hwinfo:

Code: [Select]
USB 00.c: 0200 Ethernet controller
  [Created at usb.122]
  Unique ID: CNRg.h8XqqTxwmE6
  Parent ID: k4bc.2DFUsyrieMD
  SysFS ID: /devices/pci0000:00/0000:00:14.0/usb1/1-6/1-6:2.12
  SysFS BusID: 1-6:2.12
  Hardware Class: network
  Model: "Sierra Wireless EM7305"
  Hotplug: USB
  Vendor: usb 0x1199 "Sierra Wireless, Inc."
  Device: usb 0x9041 "EM7305"
  Revision: "0.06"
  Driver: "cdc_mbim"
  Driver Modules: "cdc_mbim"
  Device File: wwan0
  Speed: 480 Mbps
  HW Address: be:b9:1e:d6:37:90
  Link detected: no
  Module Alias: "usb:v1199p9041d0006dc00dsc00dp00ic02isc0Eip00in0 C"
  Driver Info #0:
    Driver Status: qcserial is active
    Driver Activation Cmd: "modprobe qcserial"
  Driver Info #1:
    Driver Status: cdc_mbim is active
    Driver Activation Cmd: "modprobe cdc_mbim"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #58 (Hub)

Das Gerät ist jedoch im Netzwerkmanager nicht zu sehen.

Ich bin für jeden Hinweis dankbar

Vielen Dank im Voraus
« Last Edit: 2020/06/08, 07:11:15 by tomsiduction »

Offline axt

  • User
  • Posts: 394
    • axebase.net
Re: WWAN Gerät erscheint nicht im Netzwerkmanager
« Reply #1 on: 2020/06/01, 11:56:15 »
Da es durch eine nicht aufgeführte Abfrage gefunden wird, kann es nicht durch einen SW-/HW-Schalter deaktiviert sein und ist überhaupt auch tatsächlich vorhanden (nicht wenige User denken, sie hätten WWAN, nur weil ein SIM-Kartenslot vorhanden ist - eine Karte gesteckt hast Du aber?).

Danach gesucht, findet man bspw. dies für ähnliche/Nachfolge-Sierra-Wireless-Modelle. Ich würde mit den Hayes-Befehlen testen:


Code: [Select]
AT!ENTERCND="A710"
AT#USBCOMP=1,1,100D
AT!RESET

Offline axt

  • User
  • Posts: 394
    • axebase.net
Re: WWAN Gerät erscheint nicht im Netzwerkmanager
« Reply #2 on: 2020/06/01, 12:38:28 »
Sucht man weiter, findet man diesen launchpad.net-Thread. Darin wird auf Dell Wireless 5809e support in Linux - a followup (und darin auch auf AirPrime - EM73xx/7655/8805 - AT Command Reference) verlinkt. Daraus ist /etc/udev/rules.d/99-em7305.rules erstellt worden.

Offline tomsiduction

  • User
  • Posts: 140
Re: WWAN Gerät erscheint nicht im Netzwerkmanager
« Reply #3 on: 2020/06/01, 17:22:38 »
Hallo und vielen Dank
Ich habe die
 /etc/udev/rules.d/99-em7305.rules
hinzugefügt.
Ohne Erfolg.
Ich habe nun folgendes ausprobiert:

Start von siduction vom USB-Stick:

->Ein Start von siduction vom USB-Stick findet das Modem sofort.

Wo muss ich bitte nachschauen bzw. die Konfiguration übernehmen?

Code: [Select]
AT!ENTERCND="A710"
führt zu
bash: !ENTERCND="A710": event not found


Vielen Dank



Offline axt

  • User
  • Posts: 394
    • axebase.net
Re: WWAN Gerät erscheint nicht im Netzwerkmanager
« Reply #4 on: 2020/06/01, 18:06:29 »
Quote from: tomsiduction
Ein Start von siduction vom USB-Stick findet das Modem sofort.

Ja, aber Du hast gelesen, daß es um den Modus geht? Ich habe "alles" verlinkt. Sowas mache ich auch, damit Hilfesuchende sehen können, wie man Informationen finden kann, wie man sucht.

Quote
Wo muss ich bitte nachschauen bzw. die Konfiguration übernehmen?

Ich habe nun schon Hayes- und nicht nur AT-Befehle geschrieben (sprich, danach hättest Du suchen können, da Du offensichtlich nie mit der Materie Analogmodems und Ausführen von AT-Befehlen in entsprechenden Terminals zu tun gehabt hast - zu jung für die 90er ;-), aber wie Du siehst, braucht man immer noch).

Beides mit root-Rechten:

Code: [Select]
# apt install minicom
# minicom -o console

Offline tomsiduction

  • User
  • Posts: 140
Re: WWAN Gerät erscheint nicht im Netzwerkmanager
« Reply #5 on: 2020/06/01, 18:16:21 »
Hallo und zuerst einmal herzlichen Dank.

mit minicom klappt es noch nicht so recht:

Code: [Select]
minicom
minicom: Fehler beim Öffnen der Datei »/dev/modem«: Datei oder Verzeichnis nicht gefunden

Ich kann daher auch keine AT Befehle senden.


Ein

Code: [Select]
mmcli -S
error: couldn't request to scan devices: 'GDBus.Error:org.freedesktop.ModemManager1.Error.Core.Can celled: Operation was cancelled'

Code: [Select]
mmcli -L
No modems were found

mit
Linux siduction 5.6.0-2-amd64 #1 SMP Debian 5.6.14-1 (2020-05-23) x86_64 GNU/Linux

erhalte ich

Code: [Select]
mmcli -S
successfully requested to scan devices

mmcli -L
No modems were found

Die Lösung sieht wie folgt aus:
/etc/udev/rules.d/99-em7305.rules
   einstellen
- Das Modem auf die whitelist setzen
   https://www.freedesktop.org/software/ModemManager/api/1.8.0/ref-overview-modem-filter.html

Dann arbeitet es auch mit dem
Linux siduction 5.6.16-towo.1-siduction-amd64

Vielen Dank auch an "Axt"
« Last Edit: 2020/06/08, 07:15:56 by tomsiduction »