seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/11/28, 06:15:16


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Careful Full or Distro Upgrading  (Read 965 times)

0 Members and 1 Guest are viewing this topic.

Offline tranquil

  • User
  • Posts: 85
Careful Full or Distro Upgrading
« on: 2020/10/16, 22:23:24 »
I attempted to sudo apt full-upgrade almost an hour ago and was greeted by the following:

Code: [Select]
The following packages were automatically installed and are no longer required:
  docbook-xml enchant freepats gir1.2-javascriptcoregtk-4.0 gir1.2-soup-2.4
  gir1.2-wnck-3.0 gjs gnome-session-canberra gnucash-common gnucash-docs guile-2.2
  guile-2.2-libs guile-3.0-libs kactivities-bin kde-cli-tools-data kio-extras-data
  kpackagetool5 libaccounts-glib0 libaccounts-qt5-1 libalgorithm-c3-perl
  libaqbanking-data libaqbanking44 libaribb24-0 libbasicusageenvironment1
  libboost-program-options1.71.0 libboost-regex1.71.0 libcgi-fast-perl
  libcgi-pm-perl libclass-c3-perl libclass-c3-xs-perl libclass-singleton-perl
  libdate-manip-perl libdatetime-format-strptime-perl libdatetime-locale-perl
  libdatetime-perl libdatetime-timezone-perl libdbi1 libdbusmenu-qt5-2 libdca0
  libdvbpsi10 libebml5 libenchant1c2a libeval-closure-perl libfakekey0 libfam0
  libfile-sharedir-perl libfinance-quote-perl libfluidsynth2 libgarcon-1-0
  libgarcon-common libgarcon-gtk3-1-0 libgdome2-0 libgjs0g libgles2
  libgnome-panel0 libgrantlee-textdocument5 libgraphene-1.0-0 libgroupsock8
  libgssdp-1.2-0 libgstreamer-plugins-bad1.0-0 libgupnp-1.2-0 libgupnp-igd-1.0-4
  libgwengui-gtk3-79 libgwenhywfar-data libgwenhywfar79 libhfstospell11
  libhtml-tableextract-perl libinstpatch-1.0-2 libixml10
  libjavascriptcoregtk-4.0-18 libjson-parse-perl libkaccounts2 libkate1
  libkf5activities5 libkf5activitiesstats1 libkf5archive5 libkf5attica5
  libkf5auth-data libkf5auth5 libkf5authcore5 libkf5bluezqt-data libkf5bluezqt6
  libkf5bookmarks-data libkf5bookmarks5 libkf5calendarevents5 libkf5codecs-data
  libkf5codecs5 libkf5completion-data libkf5completion5 libkf5config-bin
  libkf5config-data libkf5configcore5 libkf5configgui5 libkf5configwidgets-data
  libkf5configwidgets5 libkf5coreaddons-data libkf5coreaddons5 libkf5crash5
  libkf5dbusaddons-bin libkf5dbusaddons-data libkf5dbusaddons5
  libkf5declarative-data libkf5dnssd-data libkf5dnssd5 libkf5doctools5
  libkf5globalaccel-bin libkf5globalaccel-data libkf5globalaccel5
  libkf5globalaccelprivate5 libkf5i18n-data libkf5i18n5 libkf5iconthemes-bin
  libkf5iconthemes-data libkf5iconthemes5 libkf5itemmodels5 libkf5itemviews-data
  libkf5itemviews5 libkf5jobwidgets-data libkf5jobwidgets5 libkf5kcmutils-data
  libkf5kiocore5 libkf5kiofilewidgets5 libkf5kiogui5 libkf5kiontlm5
  libkf5kiowidgets5 libkf5kirigami2-5 libkf5libkleo-data libkf5mime-data
  libkf5mime5abi1 libkf5notifications-data libkf5package-data libkf5package5
  libkf5parts-data libkf5people-data libkf5people5 libkf5peoplebackend5
  libkf5peoplewidgets5 libkf5pimtextedit-data libkf5pty-data libkf5pty5
  libkf5pulseaudioqt2 libkf5service-bin libkf5service-data libkf5service5
  libkf5solid5 libkf5solid5-data libkf5sonnet5-data libkf5sonnetcore5
  libkf5sonnetui5 libkf5su-bin libkf5su-data libkf5su5
  libkf5syntaxhighlighting-data libkf5syntaxhighlighting5 libkf5textwidgets-data
  libkf5textwidgets5 libkf5wallet-data libkf5widgetsaddons-data
  libkf5widgetsaddons5 libkf5xmlgui-bin libkf5xmlgui-data libkf5xmlgui5
  libkworkspace5-5 liblirc-client0 liblivemedia77 libltc11
  libmate-panel-applet-4-1 libmatroska7 libmjpegutils-2.1-0 libmms0 libmozjs-78-0
  libmpeg2encpp-2.1-0 libmplex2-2.1-0 libmro-compat-perl libnice10 libofa0 libofx7
  libopenmpt-modplug1 libopenni2-0 libosp5 libparams-validationcompiler-perl
  libphonon4qt5-4 libphonon4qt5-data libplacebo72 libpolkit-qt5-1-1
  libprotobuf-lite23 libqca-qt5-2 libqca-qt5-2-plugins libqgpgme7
  libqt5multimediawidgets5 libqt5opengl5 libqt5qmlworkerscript5
  libqt5quickcontrols2-5 libqt5quicktemplates2-5 libqt5texttospeech5
  libqt5waylandclient5 libqt5waylandcompositor5 libsdl-image1.2 libsdl1.2debian
  libsignon-plugins-common1 libsignon-qt5-1 libsoundtouch1 libspandsp2
  libspatialaudio0 libspecio-perl libspeechd2 libsrtp2-1 libssh-4
  libtest-fatal-perl libupnp13 libusageenvironment3 libva-wayland2 libvlc-bin
  libvlc5 libvncclient1 libvo-aacenc0 libvo-amrwbenc0 libvoikko1
  libwildmidi-config libwildmidi2 libwnck-3-0 libwnck-3-common libwpe-1.0-1
  libwpebackend-fdo-1.0-1 libxatracker2 libxcb-xv0 libxfont2 libxres1
  libxstring-perl libxvmc1 libzbar0 media-player-info paperkey python3-gnucash
  qml-module-org-kde-bluezqt qml-module-org-kde-people
  qml-module-qt-labs-folderlistmodel qml-module-qt-labs-settings qml-module-qtqml
  qml-module-qtqml-models2 qml-module-qtquick-controls2 qml-module-qtquick-layouts
  qml-module-qtquick-templates2 qml-module-qtquick-window2
  qtspeech5-speechd-plugin sgml-base sgml-data signon-plugin-oauth2 sonnet-plugins
  sshfs timgm6mb-soundfont ufw vlc-bin vlc-data vlc-l10n vlc-plugin-access-extra
  vlc-plugin-base vlc-plugin-qt vlc-plugin-samba vlc-plugin-skins2
  vlc-plugin-video-splitter vlc-plugin-visualization workrave-data x11-apps
  x11-session-utils x11-xkb-utils xdg-dbus-proxy xfce4-panel xfonts-100dpi
  xfonts-75dpi xfonts-base xfonts-encodings xfonts-scalable xfonts-utils xinit
  xml-core xserver-common xserver-xorg-legacy yelp-xsl zenity-common
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  com.github.johnfactotum.foliate falkon gir1.2-gst-plugins-base-1.0
  gir1.2-webkit2-4.0 gnucash gstreamer1.0-gl gstreamer1.0-plugins-bad gufw
  kaccounts-providers kactivitymanagerd kazam kde-cli-tools kdeconnect
  keditbookmarks kio kio-extras kleopatra kpackagelauncherqml libgstreamer-gl1.0-0
  libkf5declarative5 libkf5kcmutils5 libkf5libkleo5 libkf5notifications5
  libkf5parts-plugins libkf5parts5 libkf5pimtextedit-plugins
  libkf5pimtextedit5abi2 libkf5plasma5 libkf5plasmaquick5 libkf5purpose-bin
  libkf5purpose5 libkf5quickaddons5 libkf5wallet-bin libkf5wallet5
  libkwalletbackend5-5 libosmesa6 libqt5multimedia5-plugins
  libqt5multimediagsttools5 libwebkit2gtk-4.0-37 libwebkitgtk-1.0-0 libyelp0
  mesa-vulkan-drivers mpv phonon4qt5 phonon4qt5-backend-vlc plasma-framework
  qml-module-org-kde-kconfig qml-module-org-kde-kirigami2
  qml-module-org-kde-kquickcontrols qml-module-org-kde-kquickcontrolsaddons
  qml-module-org-kde-purpose qml-module-qtgraphicaleffects
  qml-module-qtquick-controls qml-module-qtquick-dialogs
  qml-module-qtquick-privatewidgets qml-module-qtquick2 qml-module-qtwebengine
  qtwayland5 vlc vlc-plugin-video-output workrave xorg xserver-xorg
  xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-evdev
  xserver-xorg-input-libinput xserver-xorg-input-synaptics
  xserver-xorg-input-wacom xserver-xorg-video-all xserver-xorg-video-amdgpu
  xserver-xorg-video-ati xserver-xorg-video-fbdev xserver-xorg-video-intel
  xserver-xorg-video-nouveau xserver-xorg-video-qxl xserver-xorg-video-radeon
  xserver-xorg-video-vesa xserver-xorg-video-vmware yelp zenity
The following NEW packages will be installed:
  libcurl4:i386 libllvm11:i386 libnsl-dev libnsl2 libnss-nis libnss-nis:i386
  libnss-nisplus libnss-nisplus:i386 libtirpc-common libtirpc-dev libtirpc3
  linux-headers-5.8.0-3-amd64 linux-headers-5.8.0-3-common
  linux-image-5.8.0-3-amd64
The following packages have been kept back:
  libegl-mesa0 libgbm1 libgbm1:i386 libgl1-mesa-dri libgl1-mesa-dri:i386
  libglapi-mesa libglapi-mesa:i386 libglx-mesa0 libglx-mesa0:i386 libosmesa6:i386
  libxatracker2 mesa-va-drivers mesa-va-drivers:i386 mesa-vdpau-drivers
  mesa-vdpau-drivers:i386
The following packages will be upgraded:
  ant ant-optional apparmor asunder at base-passwd bash coinor-libcbc3 cpp-10
  cups-browsed cups-filters cups-filters-core-drivers evince evince-common
  fonts-opensymbol fuse3 g++-10 gcc-10 gcc-10-base gcc-10-base:i386
  gir1.2-freedesktop gir1.2-glib-2.0 gjs goodvibes hplip hplip-data hplip-doc
  hplip-gui intel-media-va-driver intel-media-va-driver:i386 kbd libapparmor1
  libasan6 libatomic1 libatomic1:i386 libaudit-common libaudit1
  libboost-date-time1.71.0 libboost-filesystem1.71.0 libboost-iostreams1.71.0
  libboost-locale1.71.0 libboost-program-options1.71.0 libboost-regex1.71.0
  libboost-thread1.71.0 libbrotli1 libbrotli1:i386 libc-bin libc-dev-bin libc-l10n
  libc6 libc6:i386 libc6-dev libcap2 libcap2:i386 libcap2-bin libcc1-0
  libcupsfilters1 libevdocument3-4 libevview3-3 libfontembed1 libfuse3-3
  libgcc-10-dev libgcc-s1 libgcc-s1:i386 libgfortran5 libgirepository-1.0-1
  libgjs0g libglib2.0-0 libglib2.0-0:i386 libglib2.0-bin libglib2.0-data
  libgnome-panel0 libgomp1 libgomp1:i386 libgpgme11 libgpgmepp6 libgphoto2-6
  libgphoto2-6:i386 libgphoto2-l10n libgphoto2-port12 libgphoto2-port12:i386
  libhpmud0 libitm1 libjuh-java libjurt-java liblibreoffice-java libllvm10
  libllvm10:i386 libllvm9 liblsan0 libmariadb3 libmfx1 libmm-glib0
  libnautilus-extension1a libnewt0.52 libnss-systemd libpam-cap libpam-systemd
  libpq5 libprotobuf-lite23 libpython3-stdlib libqgpgme7 libqscintilla2-qt5-15
  libquadmath0 libreoffice-base-core libreoffice-calc libreoffice-common
  libreoffice-core libreoffice-draw libreoffice-java-common libreoffice-math
  libreoffice-nlpsolver libreoffice-script-provider-bsh
  libreoffice-script-provider-js libreoffice-script-provider-python
  libreoffice-sdbc-mysql libreoffice-sdbc-postgresql libreoffice-style-colibre
  libreoffice-wiki-publisher libreoffice-writer libridl-java libruby2.7
  libsane-hpaio libseccomp2 libselinux1 libselinux1:i386 libsemanage1
  libsigc++-2.0-0v5 libsphinxbase3 libssl1.1 libssl1.1:i386 libstdc++-10-dev
  libstdc++6 libstdc++6:i386 libsystemd0 libsystemd0:i386 libtsan0 libubsan1
  libudev1 libudev1:i386 libuno-cppu3 libuno-cppuhelpergcc3-3
  libuno-purpenvhelpergcc3-3 libuno-sal3 libuno-salhelpergcc3-3 libunoil-java
  libunoloader-java libxkbcommon-x11-0 libxkbcommon0 libxkbcommon0:i386 libxml2
  libxml2:i386 libxmmsclient6 lintian linux-compiler-gcc-10-x86
  linux-headers-amd64 linux-image-amd64 linux-kbuild-5.8 linux-libc-dev locales
  mariadb-common mesa-vulkan-drivers:i386 modemmanager nmap nmap-common openssl
  opera-stable printer-driver-hpcups printer-driver-postscript-hp
  python-apt-common python3 python3-apsw python3-apt python3-cairo
  python3-cffi-backend python3-chm python3-cryptography python3-cups python3-dbus
  python3-dbus.mainloop.pyqt5 python3-feedparser python3-gi python3-gi-cairo
  python3-gpg python3-html5-parser python3-lxml python3-markdown python3-minimal
  python3-msgpack python3-netifaces python3-pil python3-psutil python3-ptyprocess
  python3-pycurl python3-pyqt5 python3-pyqt5.qtsvg python3-pyqt5.qtwebchannel
  python3-pyqt5.qtwebengine python3-pyqt5.sip python3-pyxattr python3-regex
  python3-renderpm python3-reportlab python3-reportlab-accel python3-smbc
  python3-uno python3-yaml ruby2.7 systemd systemd-sysv tzdata udev
  uno-libs-private ure vivaldi-stable vorbis-tools whiptail
217 upgraded, 14 newly installed, 81 to remove and 15 not upgraded.
Need to get 495 MB of archives.
After this operation, 167 MB of additional disk space will be used.

Performing a sudo apt upgrade worked. Thank you for that tip, devil.  ;)
Dual-booting Debian Stable and Unstable with Openbox window manager and Tint2 panel.

Offline Penyelam

  • User
  • Posts: 158
Re: Careful Full or Distro Upgrading
« Reply #1 on: 2020/10/17, 12:03:28 »
Code: [Select]
# apt update && apt dist-upgrade

242 aktualisiert, 7 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

Offline harley-peter

  • User
  • Posts: 845
Re: Careful Full or Distro Upgrading
« Reply #2 on: 2020/10/17, 21:24:28 »
Here a du will only remove phpmyadmin since about one week.

Offline sunrat

  • User
  • Posts: 376
Re: Careful Full or Distro Upgrading
« Reply #3 on: 2020/10/18, 13:17:11 »
All clear here too:
Code: [Select]
# apt full-upgrade
...
138 upgraded, 7 newly installed, 0 to remove and 0 not upgraded.

I think OP's system must be in a bad state. The kernel proposed to install is Debian Sid kernel, not siduction, and "com.github.johnfactotum.foliate" is not a Debian/siduction package at all.
No idea how to fix it though.

Offline Mister00X

  • User
  • Posts: 26
Re: Careful Full or Distro Upgrading
« Reply #4 on: 2020/10/18, 13:48:09 »
On my system it's similar, not as bad as on @tranquil's system though.
Code: [Select]
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
libcharls2 libpgm-5.2-0 x11-apps x11-session-utils xinit
Verwenden Sie »apt autoremove«, um sie zu entfernen.
Die folgenden Pakete werden ENTFERNT:
  mesa-vulkan-drivers steam:i386 xorg
Die folgenden NEUEN Pakete werden installiert:
  libllvm11:i386
Die folgenden Pakete sind zurückgehalten worden:
  libegl-mesa0 libgbm1 libgbm1:i386 libgl1-mesa-dri libgl1-mesa-dri:i386 libglapi-mesa libglapi-mesa:i386 libglx-mesa0 libglx-mesa0:i386 libosmesa6:i386 mesa-va-drivers mesa-va-drivers:i386 mesa-vdpau-drivers mesa-vdpau-drivers:i386
Die folgenden Pakete werden aktualisiert (Upgrade):
  flameshot fonts-ipafont-gothic fonts-ipafont-mincho irssi-scripts libcpupower1 libdatetime-timezone-perl libnpth0 linux-cpupower linux-libc-dev mesa-vulkan-drivers:i386
10 aktualisiert, 1 neu installiert, 3 zu entfernen und 14 nicht aktualisiert.

I assume it has something to do with mesa, but that's just a guess.

Mister00X
Arguing that you don't care about the right to privacy because you have nothing to hide is no different than saying you don't care about free speech because you have nothing to say. – Edward Snowden

Offline sunrat

  • User
  • Posts: 376
Re: Careful Full or Distro Upgrading
« Reply #5 on: 2020/10/18, 14:36:28 »
Looks like you both have multiarch. May be significant. Or not.

Offline Harakiri

  • User
  • Posts: 15
Re: Careful Full or Distro Upgrading
« Reply #6 on: 2020/10/18, 22:11:08 »
Just Debian/sid here. Because of Wine I have lots of i386 installed too. Nonrepo apps are installed by dpkg and not integrated into sources.listLooks like this:
Code: [Select]
apt full-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  bubblewrap calf-plugins epiphany-browser-data gaviotatb geoclue-2.0 gir1.2-javascriptcoregtk-4.0 gir1.2-keybinder-3.0 gir1.2-rsvg-2.0 gjs
  gstreamer1.0-crystalizer-pulseeffects gthumb-data iio-sensor-proxy lib32gcc-s1 lib32stdc++6 libc6-i386 libcdio18 libchromaprint-tools
  libclang-common-10-dev libclang-cpp10 libclc-dev libclutter-1.0-common libcogl-common libdazzle-1.0-0 libdca0 libfluidsynth2 libgaviotatb1 libgcr-ui-3-1
  libgjs0g libgpod-common libgpod4 libgraphene-1.0-0 libhandy-1-0 libinstpatch-1.0-2 libkate1 liblirc-client0 libltc11 libmjpegutils-2.1-0 libmozjs-78-0
  libmpeg2encpp-2.1-0 libmplex2-2.1-0 libnice10 libofa0 libopenni2-0 libpoppler-qt5-1 libprotobuf23 libpython3.9 libpython3.9-minimal libpython3.9-stdlib
  libqscintilla2-qt5-l10n libqt5concurrent5 libqt5positioning5 libqt5qml5 libqt5qmlmodels5 libqt5quick5-gles libqt5sensors5 libqt5test5 libqt5webchannel5
  libsgutils2-2 libspandsp2 libspectre1 libsynctex2 libvo-aacenc0 libvorbisidec1 libwildmidi2 libwoff1 libwpe-1.0-1 libwpebackend-fdo-1.0-1 libxvmc1
  libykpers-1-1 libyubikey-udev libyubikey0 libzbar0 libzxcvbn0 python3-libdiscid python3-pyinotify python3-pyqt5.sip python3-sip python3-websockets
  python3-wxgtk4.0 rubberband-ladspa timgm6mb-soundfont x11-apps x11-session-utils xbitmaps xclip xdg-dbus-proxy xinit xserver-xorg-legacy yelp-xsl
  zam-plugins
Verwenden Sie »apt autoremove«, um sie zu entfernen.
Die folgenden Pakete werden ENTFERNT:
  com.github.johnfactotum.foliate epiphany-browser firetools gir1.2-gst-plugins-bad-1.0 gir1.2-gst-plugins-base-1.0 gir1.2-webkit2-4.0 gstreamer1.0-gl
  gstreamer1.0-gtk3 gstreamer1.0-plugins-bad gthumb jerry keepassxc kid3-core kid3-qt libclc-amdgcn libclc-r600 libclutter-1.0-0 libclutter-gtk-1.0-0
  libcogl-pango20 libcogl-path20 libcogl20 libd3dadapter9-mesa libdirectfb-1.7-7 libgstreamer-gl1.0-0 libgstreamer1-perl libmpv-dev libmpv1 libosmesa6
  libqscintilla2-qt5-15 libqt5designer5 libqt5gui5 libqt5help5 libqt5multimedia5-plugins libqt5multimediagsttools5 libqt5multimediawidgets5 libqt5opengl5
  libqt5printsupport5 libqt5svg5 libqt5webkit5 libqt5widgets5 libswt-webkit-gtk-4-jni libwebkit2gtk-4.0-37 libyelp0 mesa-opencl-icd mesa-utils-extra
  mesa-va-drivers mesa-vdpau-drivers mesa-vulkan-drivers mplayer mpv photofilmstrip picard pulseeffects pychess python3-gst-1.0 python3-pyqt5
  python3-pyqt5.qtmultimedia qpdfview qpdfview-djvu-plugin qpdfview-ps-plugin qpdfview-translations qt5-gtk2-platformtheme qt5-style-plugin-cleanlooks
  qt5-style-plugin-motif qt5-style-plugin-plastique qt5-style-plugins qt5ct quodlibet smplayer smplayer-l10n smplayer-themes sqlitebrowser strawberry
  uefitool virtualbox-qt xorg xserver-xorg xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-libinput xserver-xorg-input-multitouch
  xserver-xorg-input-synaptics xserver-xorg-input-wacom xserver-xorg-video-fbdev xserver-xorg-video-qxl xserver-xorg-video-vesa xserver-xorg-video-vmware
  yelp zenity
Die folgenden NEUEN Pakete werden installiert:
  libllvm11:i386 libnsl2:i386 libqt5gui5-gles libtirpc3:i386
Die folgenden Pakete sind zurückgehalten worden:
  libegl-mesa0 libgbm1 libgbm1:i386 libgl1-mesa-dri libgl1-mesa-dri:i386 libglapi-mesa libglapi-mesa:i386 libglx-mesa0 libglx-mesa0:i386 libosmesa6:i386
  libxatracker2 xserver-xorg-video-amdgpu
Die folgenden Pakete werden aktualisiert (Upgrade):
  bison firejail firejail-profiles libclc-dev libcpupower1 libd3dadapter9-mesa:i386 libdouble-conversion3 libimage-exiftool-perl libnpth0 libnss-nis
  libnss-nis:i386 libnss-nisplus libnss-nisplus:i386 libpython3.9 libpython3.9-minimal libpython3.9-stdlib linux-compiler-gcc-10-x86 linux-cpupower
  linux-libc-dev mesa-va-drivers:i386 mesa-vdpau-drivers:i386 mesa-vulkan-drivers:i386 thunderbird thunderbird-l10n-de
24 aktualisiert, 4 neu installiert, 89 zu entfernen und 12 nicht aktualisiert.
Es müssen 88,4 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 434 MB Plattenplatz freigegeben.

Offline Mister00X

  • User
  • Posts: 26
Re: Careful Full or Distro Upgrading
« Reply #7 on: 2020/10/18, 22:28:32 »
So if I'm interpreting this right, then there is some kind of dependency issue with the 32-bit architecture. I'm not sure if this is caused by mesa or not, but it seems to be one of the things everyone with this issue has in common.

I guess the best strategy is to wait with d-u's until this dependency issue is resolved.
Arguing that you don't care about the right to privacy because you have nothing to hide is no different than saying you don't care about free speech because you have nothing to say. – Edward Snowden

Offline dpanter

  • User
  • Posts: 10
Re: Careful Full or Distro Upgrading
« Reply #8 on: 2020/10/19, 20:34:11 »
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=972323
Mesa 20.2 depends on llvm11 which has a version mismatch currently.
libllvm11:amd64 - 1:11.0.0-2
libllvm11:i386 - 1:11.0.0-2+b1

Best to wait for the versions to be synced. If you're desperate to get rid of the errors immediately, purge llvm11 from your machine and downgrade mesa to 20.1.9-1 from testing as it depends on llvm10.

edit: llvm-11 is updated to 11.0.0-3 now so it should be good to go.
« Last Edit: 2020/10/20, 21:42:37 by dpanter »
<< insert signature here >>