seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/11/24, 18:56:48


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: New Board, no spdif and network not working properly (r8169)  (Read 310 times)

0 Members and 1 Guest are viewing this topic.

Offline Lanzi

  • User
  • Posts: 1.664
I got a new board and a AMD prozessor for the first time. But there are some problems. Maybe you have run in similar problems and could help:

1. Sound works, but, SPDIF seems dead. In Audiosettings I cannot choose Spdif

2. With the board comes the Realtek RTL8125. With towos experimental kernel 5.9.1 it works finally, but slowly with only 100Mbit. Kerneldriver r8169 seems to be in use.

If you need more date, please tell me.Thanks for any help

Code: [Select]
inxi -v5
System:    Host: hal Kernel: 5.9.1-towo.2-siduction-amd64 x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: KDE Plasma 5.17.5 
          Distro: siduction 18.3.0 Patience - kde - (202008212153) base: Debian GNU/Linux bullseye/sid
Machine:   Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser/root required>
          Mobo: ASUSTeK model: TUF GAMING B550-PLUS v: Rev X.0x serial: <superuser/root required> BIOS: American Megatrends
          v: 1002 date: 08/04/2020
Battery:   Device-1: hidpp_battery_0 model: Logitech M705 charge: 65% status: Discharging
Memory:    RAM: total: 62.20 GiB used: 4.43 GiB (7.1%)
          RAM Report: permissions: Unable to run dmidecode. Root privileges required.
CPU:       Info: 8-Core model: AMD Ryzen 7 PRO 4750G with Radeon Graphics bits: 64 type: MT MCP arch: Zen rev: 1
          L2 cache: 4096 KiB
          flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 114973
          Speed: 1697 MHz min/max: 1400/3600 MHz boost: enabled Core speeds (MHz): 1: 1697 2: 1696 3: 1212 4: 1696 5: 1428
          6: 1289 7: 1288 8: 1393 9: 1212 10: 1697 11: 1542 12: 1283 13: 1279 14: 1342 15: 1696 16: 1697
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Renoir vendor: ASUSTeK driver: amdgpu v: kernel bus ID: 06:00.0
          Display: x11 server: X.Org 1.20.9 driver: amdgpu FAILED: ati unloaded: fbdev,modesetting,vesa resolution:
          1: 3840x2160~60Hz 2: 3840x2160~60Hz
          OpenGL: renderer: AMD RENOIR (DRM 3.39.0 5.9.1-towo.2-siduction-amd64 LLVM 11.0.0) v: 4.6 Mesa 20.2.1
          direct render: Yes
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 06:00.1
          Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
          bus ID: 06:00.6
          Device-3: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo bus ID: 1-1:2
          Sound Server: ALSA v: k5.9.1-towo.2-siduction-amd64
Network:   Device-1: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel port: f000 bus ID: 04:00.0
          IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: 24:4b:fe:79:87:1e
Partition: ID-1: / size: 1.72 TiB used: 565.81 GiB (32.0%) fs: ext4 dev: /dev/nvme0n1p1 label: N/A
          uuid: 2bcf4573-ec7c-4a96-a5fc-7613da4e0426
Swap:      Alert: No Swap data was found.
Sensors:   System Temperatures: cpu: 33.6 C mobo: N/A gpu: amdgpu temp: 23.0 C
          Fan Speeds (RPM): N/A
Info:      Processes: 323 Uptime: 15h 11m Init: systemd runlevel: 5 Compilers: gcc: 10.2.0 Packages: 3413 Shell: Bash
          v: 5.1.0-rc1 inxi: 3.1.08


Code: [Select]
lspci -knn | grep Eth -A3

04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller [10ec:8125] (rev 04)
       Subsystem: ASUSTeK Computer Inc. RTL8125 2.5GbE Controller [1043:87d7]
       Kernel driver in use: r8169
       Kernel modules: r8169

Offline Lanzi

  • User
  • Posts: 1.664
So, I tried until now the following:

I installed the driver from the realtek page:
described here.
https://ubuntu-mate.community/t/realtek-rtl8125-2-5gbe-ethernet-not-working-on-amd-b550-mobo/22469

I got then:
Code: [Select]
lspci -knn | grep Eth -A3

04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller [10ec:8125] (rev 04)
       Subsystem: ASUSTeK Computer Inc. RTL8125 2.5GbE Controller [1043:87d7]
       Kernel driver in use: r8169
       Kernel modules: r8169, r8125


It seems I have to blacklist realtek-r8169 driver.

So I created a realtek.conf file in /etc/modprobe.d

Code: [Select]
# Do not load the module on boot.
blacklist r8169

After reboot I got the same.

Code: [Select]
lspci -knn | grep Eth -A3

04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller [10ec:8125] (rev 04)
       Subsystem: ASUSTeK Computer Inc. RTL8125 2.5GbE Controller [1043:87d7]
       Kernel driver in use: r8169
       Kernel modules: r8169, r8125

so I am still running with 100 Mbit/s  :(

Offline jure

  • User
  • Posts: 536
I am not an expert on this, but may be you need to update-initramfs https://community.hetzner.com/tutorials/installing-the-r8168-driver

Quote
Debian/Ubuntu

After installing the driver, update the module dependencies.

depmod -a

First the r8169 network driver needs to be blocked, so as to prevent the kernel from loading it. Note: If additional NICs are installed in the server, the driver must not be blocked.

Ubuntu/Debian 6.0 (Squeeze):

echo "blacklist r8169" >> /etc/modprobe.d/blacklist.conf

Next, the kernel must be forced to include the driver in the initrd. This also ensures that if additional NICs have been installed the new r8168 module is loaded before the r8169 module.

echo "r8168" >> /etc/initramfs-tools/modules

Afterwards the initrd will be rebuilt.

update-initramfs -v -t -u


Now you can reboot the server.

After a kernel update the driver might need to be recompiled.
Gruss Juergen

Offline Lanzi

  • User
  • Posts: 1.664
Thanks jure for qour quick answer. There is some progress

I did like in yourdescription:
install driver
depmod -a
blacklist r8169
added r8125 to /etc/initramfs-tools/nodules
update-initramfs -v -t -u
and reboot...

I checked and the Kernel driver in use is r8125!

Code: [Select]

lspci -knn | grep Eth -A3
04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller [10ec:8125] (rev 04)
       Subsystem: ASUSTeK Computer Inc. RTL8125 2.5GbE Controller [1043:87d7]
       Kernel driver in use: r8125
       Kernel modules: r8169, r8125
[
BUT: my speed is still 100Mbit/s   :P





Offline der_bud

  • User
  • Posts: 955
  • member
How did you measure that speed, did you use some speedtest tool or tranfer big files over network-connection? If you just used inxis output I am not sure if it does test the real speed or only shows what it thinks the module reports. What ist the output of
Code: [Select]
ethtool enp4s0 And how is the LAN connected, to a router or switch that is Gigabit-capable at the port used?
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline Lanzi

  • User
  • Posts: 1.664
Hi Bud,it's what networkmanager shows me, but your command shows the same output.

Code: [Select]
ethtool enp4s0

Settings for enp4s0:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
                                2500baseX/Full
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  Not reported
        Advertised pause frame use: No
        Advertised auto-negotiation: No
        Advertised FEC modes: Not reported
        Speed: 100Mb/s
        Duplex: Full
        Auto-negotiation: off
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        MDI-X: Unknown
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000033 (51)
                               drv probe ifdown ifup
        Link detected: yes
and coping files to my server is really slow.
My fritzbox-router has the setting 1Gbit for all 4 Lan-Channels, so that there is no problem.

Offline Lanzi

  • User
  • Posts: 1.664
I found the setting in Networkmanager. "Link negotiantion" ("Automatisches Aushandeln zulassen"). It was deactivated, maybe because of the former driver. So, I activated it and everything seems good now.
Thanks to all helpers.
« Last Edit: 2020/11/02, 17:29:11 by Lanzi »