Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] GoogleEarth  (Read 9179 times)

mischu

  • Guest
[DE] Re:Google Earth
« Reply #15 on: 2010/10/12, 20:05:38 »
Anscheinend bin ich nicht der Einzigste der die Install von GE nicht rafft.Ich hab zigmal versucht nach Towo's Anweisung das Paket zu bauen und zu installieren.Aber es funktioniert einfach nicht,es kommen schon beim Paketbau ungezählte meldungen von fehlern und abhängigkeiten die ich leider nicht in der Lage bin wider zu geben.Die Konsole ist noch nicht mein Freund.
Ich geb erst mal auf,vielleicht gibt es mal irgendwann ein fertiges debian-paket.
Trotzdem danke für die tips.

mischu

Offline phen

  • User
  • Posts: 85
Re:Google Earth
« Reply #16 on: 2010/10/12, 21:18:03 »
Naja, Du könntest einfach mal die "ungezählten meldungen von fehlern und abhängigkeiten" hier reinkopieren..

Offline reddark

  • User
  • Posts: 1.062
    • http://www.klangruinen.de/
GoogleEarth
« Reply #17 on: 2010/10/12, 21:27:54 »
Hmm, auch wenn ich es nicht brauche, hab ichs jetzt trotzdem mal versucht (auf 64bit-system).

Mit
Code: [Select]
als root:
apt-get install googleearth-package

als User:
make-googleearth-package

hat es super funktioniert - es gab zwar ne menge Fehlermeldungen, aber zum Schluss hat er ein deb-paket gebaut, was ich dann auch installieren konnte. Musste noch lib32nss-mdns nachinstallieren und nun läuft google-earth auch auf meinem Rechner.

Offline phen

  • User
  • Posts: 85
GoogleEarth
« Reply #18 on: 2010/10/12, 21:34:21 »
Diese "Fehlermeldungen", waren das nicht eher Warnungen, oder tatsächlich "Fehler"?

Offline reddark

  • User
  • Posts: 1.062
    • http://www.klangruinen.de/
GoogleEarth
« Reply #19 on: 2010/10/12, 21:59:02 »
@phen: Beides.

z.B.:
Code: [Select]
dpkg-shlibdeps: Fehler: Keine Abhängigkeitsinformationen für /usr/lib32/libGL.so.1 (verwendet von ../usr/lib/googleearth/libIGCore.so) gefunden.
Code: [Select]
dpkg-shlibdeps: Fehler: Keine Abhängigkeitsinformationen für /usr/lib32/libGL.so.1 (verwendet von ../usr/lib/googleearth/libIGMath.so) gefunden.
und ein paar mehr. Aber stimmt schon, das meiste waren Warnungen... ;)

Offline ralfi

  • User
  • Posts: 389
GoogleEarth
« Reply #20 on: 2010/10/13, 08:19:37 »
reddark: lib32nss-mdns ? Wo gibts die denn ?
Gruss, ralfi

Niveau sieht von unten oft wie Arroganz aus ...

Offline reddark

  • User
  • Posts: 1.062
    • http://www.klangruinen.de/
GoogleEarth
« Reply #21 on: 2010/10/13, 08:50:19 »
Code: [Select]
# apt-cache policy lib32nss-mdns
lib32nss-mdns:
  Installiert: 0.10-3.1
  Kandidat:    0.10-3.1
  Versionstabelle:
 *** 0.10-3.1 0
        500 http://ftp.de.debian.org/debian/ unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian/ testing/main amd64 Packages
        100 /var/lib/dpkg/status

Offline ralfi

  • User
  • Posts: 389
GoogleEarth
« Reply #22 on: 2010/10/14, 18:10:05 »
Komisch, hatte ich nicht gefunden, vielleicht Schreibfehler, ist aber auf meinem system vorhanden. Aber das bringt mich dazu, nochmal meinen GE Fehler zu beschreiben. Das Programm wird korrekt geladen, alle Menüs etc.pp funktionieren aber die liebe Erde (oder der Mond ....) wird nicht dargestellt, einfach nicht angezeigt.

Dabei ist die Verbindung zu GE Server vorhanden, es werden auch Daten von dort geladen. Meine GE Version ist 5.2.1.1588+0.5.7-1. Die üblichen Dinge wie lokalen Cache löschen und so habe ich schon gemacht. Es hilft auch nichts, wenn ich Composite ausschalte.

Hat vielleicht schonmal jemand so ein Problem gehabt und noch besser - gelöst ?
Gruss, ralfi

Niveau sieht von unten oft wie Arroganz aus ...

Offline phen

  • User
  • Posts: 85
GoogleEarth
« Reply #23 on: 2010/10/14, 18:14:45 »
Code: [Select]
$ glxinfo | grep rendering
?

Offline ralfi

  • User
  • Posts: 389
GoogleEarth
« Reply #24 on: 2010/10/14, 18:53:47 »
Mmmh, fehlt da was ?
LIBGL_DEBUG Variable setzen bringt keine weiteren Erkenntnisse ...

Code: [Select]

direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)

GLX version: 1.4
GLX extensions:
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 8600 GT/PCI/SSE2
OpenGL version string: 3.2.0 NVIDIA 195.36.31
OpenGL shading language version string: (null)

ii  libgl1-nvidia-alternatives                              195.36.31-5                             simplifies replacing MESA libGL with GPU vendor libraries
ii  libgl1-nvidia-glx                                       195.36.31-5                             NVIDIA binary OpenGL libraries
ii  libglx-nvidia-alternatives                              195.36.31-5                             simplifies replacing Xorg module libglx.so with GPU vendor library
ii  nvidia-glx                                              195.36.31-5                             NVIDIA binary Xorg driver
ii  nvidia-kernel-2.6.34-0.slh.11-sidux-amd64               195.36.31-5+2.6.34-12                   NVIDIA binary kernel module for Linux 2.6.34-0.slh.11-sidux-amd64
ii  nvidia-kernel-common                                    20100522+2                              NVIDIA binary kernel module support files
ii  nvidia-kernel-dkms                                      195.36.31-5                             NVIDIA binary kernel module DKMS source
ii  nvidia-kernel-source                                    195.36.31-5                             NVIDIA binary kernel module source

Gruss, ralfi

Niveau sieht von unten oft wie Arroganz aus ...

Offline ralfi

  • User
  • Posts: 389
GoogleEarth
« Reply #25 on: 2010/10/14, 19:09:36 »
Jo, es fehlte was, gefunden im sidux Forum ...

apt-get install nvidia-glx-ia32

Nun geht alles bestens
Gruss, ralfi

Niveau sieht von unten oft wie Arroganz aus ...