Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [solved]no Grub screen with the latest (xfce) iso image on Lenovo E125  (Read 7145 times)

Offline gour

  • User
  • Posts: 27
[EN] Re: no Grub screen with the latest (xfce) iso image on Lenovo E125
« Reply #15 on: 2023/10/16, 21:44:23 »
The parted command can also be issued by any other Linux...  (debian preferred)

At the moment, I was only able to boot sysrescuecd since I do not have any distro installed...

Quote
Please give also the machine data for the people who know about EFI: 
Code: [Select]
inxi -MGxxx

Here is the output:

Code: [Select]
root@sysrescue ~]# inxi -MGxxx
Machine:
  Type: Laptop System: LENOVO product: 303527G v: ThinkPad Edge E125
    serial: LR4B4ND Chassis: type: 10 serial: LR4B4ND
  Mobo: LENOVO model: 303527G serial: 1ZJKR17F37D UEFI: LENOVO
    v: 8PET36WW (1.18 ) date: 10/31/2012
Graphics:
  Device-1: AMD Wrestler [Radeon HD 6310] vendor: Lenovo driver: radeon
    v: kernel arch: TeraScale-2 ports: active: LVDS-1 empty: HDMI-A-1,VGA-1
    bus-ID: 00:01.0 chip-ID: 1002:9802 class-ID: 0300
  Device-2: Suyin Integrated Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 bus-ID: 2-5:2 chip-ID: 064e:e285 class-ID: 0e02
    serial: HF0316-S71L-MI03-VL-R00.01.02
  Display: server: X.Org v: 21.1.8 compositor: xfwm v: 4.18.0 driver: X:
    loaded: radeon unloaded: fbdev,modesetting,vesa dri: r600 gpu: radeon
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: LVDS-1 mapped: LVDS model: AU Optronics 0x315c res: 1366x768
    hz: 60 dpi: 136 size: 256x144mm (10.08x5.67") diag: 294mm (11.6") modes:
    max: 1366x768 min: 640x480
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
    missing.

Any hint?

Offline gour

  • User
  • Posts: 27
I suspect one of the frequently described problems with Secure Boot and/or the CSM setting in the bios.

I've made some progress!

Based on the screen I saw when booted into desktop bios/gpt machine, I simply blindly - the screen is blank - pressed down-arrow and enter and was able to boot from iso.  :)

However, the installer failed at 'grub-install' phase since due to bios error in my machine, in order to properly install new distro I have to  pass
Code: [Select]
efi_no_storage_paranoia to the Grub entry.

I've tried to fix the issue by running chroot-helper, but
Code: [Select]
grub-install /dev/sda reports 'no space on device'.

So, any idea how to install grub post festum?

I've tried to change grub parameters by adding the above parameter and issuing,
Code: [Select]
update-grub which goes well, but the issue is how to install Grub on my HDD's MBR?

So, my conclusion is that the problematic issue is not due to UEFI settings. The problem seems to be with the Grub menu, which is not visible, and therefore I'm not able to properly select an entry and edit it to pass the required parameter.

Any hint?

Offline ro_sid

  • User
  • Posts: 250
Well, one idea I should have thought of much earlier is a totally different one:
Why do you not install "ventoy" on your stick an put any ISO files (e.g. the siduction xfce one) on it. This would clarify your "display" problem, since "ventoy" uses  grub, too. On the other hand, when it works you can than boot the ISO from it.

Offline scholle1

  • User
  • Posts: 98
Very mysterious
Quote
However, the installer failed at 'grub-install' phase since due to bios error in my machine, ...

You know about a BIOS error and we are banging on about UEFI, BIOS, MBR, GPT all the time.
Please fix your UEFI/BIOS first.
Maybe here:
https://pcsupport.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-edge-laptops/thinkpad-edge-e125/
I am out for now.
« Last Edit: 2023/10/17, 21:11:42 by scholle1 »
Je mehr Bürgerinnen und Bürger mit Zivilcourage ein Land hat, desto weniger Helden wird es einmal brauchen.
(Franka Magnani)

Offline gour

  • User
  • Posts: 27
You know about a BIOS error and we are banging on about UEFI, BIOS, MBR, GPT all the time.
Please fix your UEFI/BIOS first.

I'm living with that error since latest BIOS does not fix it and the fix is simple...when installing some distro in UEFI mode (BIOS/GPT combo is also problematic) I just have to pass efi_no_storage_paranoia kernel parameter and everything is fine.

However, the problem is that I do not see Grub's menu in siduction's iso and will try ventoy tomorrow...

btw, I've installed siduction on my main machine and this is written from within it.  8)
« Last Edit: 2023/10/18, 10:09:34 by gour »

Offline gour

  • User
  • Posts: 27
Well, one idea I should have thought of much earlier is a totally different one:
Why do you not install "ventoy" on your stick an put any ISO files (e.g. the siduction xfce one) on it. This would clarify your "display" problem, since "ventoy" uses  grub, too. On the other hand, when it works you can than boot the ISO from it.

That was it! You saved the show.  ;)

I was able to boot siduction iso with ventoy, pass required
Code: [Select]
efi_no_storage_paranoia kernel parameter which enabled installer to properly install grub in hdd's mbr.

The conclusion is that there is (for my machine) some issue with siduction's Grub menu not allowing to properly display splash graphic and showing the menu entries... :D