Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: Fresh install siduction-21.3.0-wintersky-kde-amd64 with btrfs fails  (Read 1219 times)

Offline kiwix

  • Newbie
  • Posts: 2
Hello,

some days ago I tried to install siduction for the first time. I only changed the file system to btrfs.

Installation seams to work, but after a restart it ended up on the console. After some time i recognized that the root file system was mounted read only. I tried this several times on a phyiscal notebook and in a qemu/kvm virtual machine.

After leaving the default file system to ext4 anything works fine.

Any idea or is this a (known) bug?

Regards
Kiwix

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.709
Not a known bug to my knowledge. I will try to replicate the behavior.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.709
Confirmed, For me, it hangs on reboot right after graphical target was reached. A quick glance at auntie google showed no known bugs in that direction. Right now, I don't have time to look further into this.

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.660
Its sure known.
Calamares is making wrong options in fstab of the installed System. It mount's the subvolume read only.
Change that from a live medium and it is working.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.709
Oh right, we even talked about that some time ago. I forgot.

Offline rikudou

  • User
  • Posts: 5
Is there workaround for this?

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.660
Sure, boot from Live, mount the partition and just remove the ro entry in the corresponding line of fstab.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline rikudou

  • User
  • Posts: 5
thanks. Let me try


Ithink eveything looks fine in my fstab but still same error
Code: [Select]

UUID=ad1ee115-f3d0-4a52-bb3a-2d785cde1980 /              btrfs   subvol=/@,defaults,noatime,space_cache,autodefrag 0 0
UUID=f9f45338-3295-4dc5-9165-e20a12a53b48 /tmp           btrfs   defaults,noatime,space_cache,autodefrag 0 0
UUID=0c05e513-8dd7-41e8-9868-ac2653a2abe3 /opt           btrfs   defaults,noatime,space_cache,autodefrag 0 0
UUID=4B9A-087C                            /boot/efi      vfat    umask=0077 0 2
UUID=f4e6c3ee-fe4e-4119-83fd-742279c72f23 /home          btrfs   defaults,noatime,space_cache,autodefrag 0 0
« Last Edit: 2022/02/18, 17:22:58 by rikudou »

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.660
You have to change

Code: [Select]
space_cache
to

Code: [Select]
space_cache=v2
Then it should work.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline rikudou

  • User
  • Posts: 5
Yeah that worked. Thanks!