Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: Problem beim Aufruf einer Domain via Browser ("handshake failed")  (Read 286 times)

Offline pit

  • User
  • Posts: 222
Egal welchen Browser ich nutze (beobachtet mit Chrome + Firefox): Wenn ich www.spiegel.de aufrufe, erscheint die Seite ohne css und ohne Bilder, also quasi text only (komplett verstümmelt). Das geht mir aktuell nur mit spiegel.de so.
Da scheinen u.a. Inhalte des Content Delivery Networks (cdn) geblockt zu werden. Wenn ich testweise z.B. https://cdn.prod.www.spiegel.de/public/spon/images/icons/touch-icon.png aufrufe (eine URL, die ich im Quellcode der Startseite von SPON finde), heißt's im Browser:

Diese Website kann keine sichere Verbindung bereitstellencdn.prod.www.spiegel.de hat eine ungültige Antwort gesendet.
ERR_SSL_PROTOCOL_ERROR

Ich habe mal einen Ausschnitt aus journalctl -f angehängt.
Da hagelt es plasmashell-Meldungen wie diese:
Code: [Select]
ERROR:ssl_client_socket_impl.cc(996)] handshake failed; returned -1, SSL error code 1, net_error -107
Wird da jmd. von euch schlau daraus?

https://paste.debian.net/1248601/

Offline charlyheinz

  • User
  • Posts: 66
Hallo Pit- Kann ich nicht bestätigen. "Spiegel.de" läuft bei mir auf "Firefox" einwandfrei, trotz Script-blocker, AdBlocker- und Pihole oder vielleicht auch deshalb?? Das hört sich für mich Laien nach einem Zertifikats- Problem an.
Unter Konqueror öffnet sich nach dem Aufruf der URL gleich eine Abfrage ob man die Seite als bezahlte werbefreie Darstellung betrachten will oder kostenfrei mit Werbung. Läuft aber auch hier!

Offline edlin

  • User
  • Posts: 171
Auch hier keine Probleme (KDE/Plasma), egal ob Firefox oder links, mit und ohne Adblocker etc.
https://www.spiegel.de/ liefert sauberen Content, ohne Murren (und mit Adblocker sogar ohne Werbung).
Der Spiegel-Server scheint es wohl nicht zu sein, ein aktuelles System, sauber aufgesetzt, aber auch nicht.

edlin 
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline pit

  • User
  • Posts: 222
> Das hört sich für mich Laien nach einem Zertifikats- Problem an.

Für mich auch. Aber wer da wem nicht mehr vertraut, verstehe ich nicht. Meine Kiste einem der SPON-Zertifikate nicht mehr? SPON mir nicht mehr? Hat denn ein user auf einem Standard Siduction (bzw. Debian Sid) überhaupt ein persönliches Zertifikat, mit dem sich ein Browser der Gegenstelle gegenüber als vertrauenswürdig ausweist? Alles böhmische Dörfer für mich  :'(

Offline pit

  • User
  • Posts: 222
Ich habe mal testweise einen neuen User angelegt, mich als solcher angemeldet (KDE/Plasma) u. via Firefox spiegel.de aufgerufen. Gleicher Effekt mit jungfräulichem Profil. Strange ...