Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic:  du entfernt plasma-desktop ...  (Read 613 times)

Offline jure

  • User
  • Posts: 635
du entfernt plasma-desktop ...
« on: 2022/07/25, 10:30:02 »
Hallo

seit ein paar Tagen will apt beim du "plasma-desktop" entfernen und polkit-kde-agent-1 wird zurück gehalten, ich frage mich warum ... ggf übersehe ich etwas

Code: [Select]
inxi -S
System:
  Host: siductionbox Kernel: 5.18.12-1-siduction-amd64 arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.25.3 Distro: Debian GNU/Linux bookworm/sid


Code: [Select]
apt policy plasma-desktop plasma-desktop-data
plasma-desktop:
  Installiert:           4:5.24.5-1
  Installationskandidat: 4:5.25.3-1
  Versionstabelle:
     4:5.25.3-1 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian unstable/main amd64 Packages
 *** 4:5.24.5-1 100
        100 /var/lib/dpkg/status
plasma-desktop-data:
  Installiert:           4:5.24.5-1
  Installationskandidat: 4:5.25.3-1
  Versionstabelle:
     4:5.25.3-1 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        500 http://httpredir.debian.org/debian unstable/main i386 Packages
        500 http://ftp.de.debian.org/debian unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian unstable/main i386 Packages
 *** 4:5.24.5-1 100
        100 /var/lib/dpkg/status

Code: [Select]
apt policy polkit-kde-agent-1
polkit-kde-agent-1:
  Installiert:           4:5.24.4-1
  Installationskandidat: 4:5.25.3-1
  Versionstabelle:
     4:5.25.3-1 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian unstable/main amd64 Packages
 *** 4:5.24.4-1 100
        100 /var/lib/dpkg/status
Gruss Juergen

Offline edlin

  • User
  • Posts: 234
Re: du entfernt plasma-desktop ...
« Reply #1 on: 2022/07/25, 11:22:19 »
Also bei mir ist die Welt noch in Ordnung und ich aktualisiere normalerweise täglich.
Code: [Select]
inxi -S
System:
  Host: Devil Kernel: 5.18.14-1-siduction-amd64 arch: x86_64 bits: 64
    Console: pty pts/3
    Distro: siduction 21.3.0 Wintersky - kde - (202112231751)
Code: [Select]
apt policy plasma-desktop plasma-desktop-data
plasma-desktop:
  Installiert:           4:5.25.3-1
  Installationskandidat: 4:5.25.3-1
  Versionstabelle:
 *** 4:5.25.3-1 500
        500 https://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     4:5.24.5-1 500
        500 https://deb.debian.org/debian testing/main amd64 Packages
plasma-desktop-data:
  Installiert:           4:5.25.3-1
  Installationskandidat: 4:5.25.3-1
  Versionstabelle:
 *** 4:5.25.3-1 500
        500 https://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     4:5.24.5-1 500
        500 https://deb.debian.org/debian testing/main amd64 Packages
Code: [Select]
apt policy polkit-kde-agent-1
polkit-kde-agent-1:
  Installiert:           4:5.25.3-1
  Installationskandidat: 4:5.25.3-1
  Versionstabelle:
 *** 4:5.25.3-1 500
        500 https://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     4:5.24.5-1 500
        500 https://deb.debian.org/debian testing/main amd64 Packages

Hast du ein full-upgrade gemacht? Generell sollte aktuell Plasma (KDE Plasma - das Plasma der Sonne schon eher) kein Problem machen.

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline jure

  • User
  • Posts: 635
Re: du entfernt plasma-desktop ...
« Reply #2 on: 2022/07/25, 12:52:28 »
Danke für die Rückmeldung

das Problem scheint die Abhängigkeit von polkit-kde-agent-1 zu sein, was aber zurückgehalten wird

Code: [Select]
apt depends plasma-desktop
...
Hängt ab von: polkit-kde-agent-1 (>= 4:5.25~)"
...

Code: [Select]
apt policy polkit-kde-agent-1
polkit-kde-agent-1:
  Installiert:           4:5.24.4-1
  Installationskandidat: 4:5.25.3-1
  Versionstabelle:
     4:5.25.3-1 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian unstable/main amd64 Packages
 *** 4:5.24.4-1 100
        100 /var/lib/dpkg/status

Code: [Select]
apt full-upgrade
....
Die folgenden Pakete werden ENTFERNT:
  plasma-desktop
Die folgenden NEUEN Pakete werden installiert:
  linux-headers-5.18.14-1-siduction-amd64 linux-image-5.18.14-1-siduction-amd64 qml-module-org-kde-kcmutils
Die folgenden Pakete sind zurückgehalten worden:
  polkit-kde-agent-1
Die folgenden Pakete werden aktualisiert (Upgrade):
  kde-cli-tools kde-cli-tools-data khotkeys khotkeys-data linux-headers-siduction-amd64 linux-image-siduction-amd64 plasma-desktop-data systemsettings
8 aktualisiert, 3 neu installiert, 1 zu entfernen und 1 nicht aktualisiert
Gruss Juergen

Offline Geier0815

  • User
  • Posts: 568
Re: du entfernt plasma-desktop ...
« Reply #3 on: 2022/07/25, 13:07:50 »
Was passiert denn wenn Du polkit-kde-agent-1 "per Hand" auf die aktuelle Version ziehen willst?
Code: [Select]
apt install polkit-kde-agent-1=5.25.3-1
Achso: Meldungen sinnentnehmend lesen hilft ein gesundes System zu erhalten ;-)
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Offline jure

  • User
  • Posts: 635
Re: du entfernt plasma-desktop ...
« Reply #4 on: 2022/07/25, 14:03:32 »
Hi

das sieht dann so aus - diverse Abhängigkeitsprobleme ...

Code: [Select]
apt install polkit-kde-agent-1=4:5.25.3-1
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 polkit-kde-agent-1 : Hängt ab von: polkitd
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.


[root@siductionbox juergen]$ apt policy polkitd
polkitd:
  Installiert:           (keine)
  Installationskandidat: 0.105-33
  Versionstabelle:
     0.105-33 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian unstable/main amd64 Packages


[root@siductionbox juergen]$ apt install polkit-kde-agent-1=4:5.25.3-1 polkitd
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 polkitd : Hängt ab von: libpolkit-agent-1-0 (= 0.105-33) aber 0.112-5.3.1~really-0.105-8 soll installiert werden
           Hängt ab von: libpolkit-gobject-1-0 (= 0.105-33) aber 0.112-5.3.1~really-0.105-8 soll installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
Gruss Juergen

Offline hendrikL

  • Administrator
  • User
  • *****
  • Gravatar
  • Posts: 654
Re: du entfernt plasma-desktop ...
« Reply #5 on: 2022/07/25, 14:25:17 »
Code: [Select]
apt policy polkitd
EDIT: Sorry, gerade gesehen, ist schon da!

EDIT 2: apt policy libpolkit-agent-1-0
« Last Edit: 2022/07/25, 14:29:37 by hendrikL »

Offline jure

  • User
  • Posts: 635
Re: du entfernt plasma-desktop ...
« Reply #6 on: 2022/07/25, 14:49:48 »
Code: [Select]
apt policy libpolkit-agent-1-0
libpolkit-agent-1-0:
  Installiert:           0.112-5.3.1~really-0.105-8
  Installationskandidat: 0.112-5.3.1~really-0.105-8
  Versionstabelle:
 *** 0.112-5.3.1~really-0.105-8 100
        100 /var/lib/dpkg/status
     0.105-33 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian unstable/main amd64 Packages

dazu gibt es ja ein Thema mit der Lösung (?)

Code: [Select]
sudo apt -V install policykit-1=0.105-33 pkexec polkitd --reinstall
edit:
weil hier 0.112-5.3.1~really-0.105-8 installiert ist, aber policykit-1 0.105-33 in sid aktuell ist (!?)

« Last Edit: 2022/07/25, 14:57:11 by jure »
Gruss Juergen

Offline der_bud

  • User
  • Posts: 1.048
  • member
Re: du entfernt plasma-desktop ...
« Reply #7 on: 2022/07/25, 18:10:26 »
Sieht ähnlich aus wie bei orinoco dort :  https://forum.siduction.org/index.php?topic=8650.msg69103#msg69103
Auch der "really"-Kram, installier mal explizit die 0.105er
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline jure

  • User
  • Posts: 635
Re: du entfernt plasma-desktop ...
« Reply #8 on: 2022/07/25, 18:25:07 »
das sieht nicht gut aus ;-)
Quote
apt -V install policykit-1=0.105-33
......
Die folgenden Pakete werden aktualisiert (Upgrade):
   kde-cli-tools-data (4:5.24.5-1 => 4:5.25.3-1)
   khotkeys-data (4:5.24.5-1 => 4:5.25.3-1)
Die folgenden Pakete werden durch eine ÄLTERE VERSION ERSETZT (Downgrade):
   policykit-1 (0.112-5.3.1~really-0.105-8 => 0.105-33)
2 aktualisiert, 8 neu installiert, 1 durch eine ältere Version ersetzt, 332 zu entfernen und 3 nicht aktualisiert.

und das auch nicht

Code: [Select]
apt -V install policykit-1=0.105-33 pkexec polkitd --reinstall
....
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 pkexec : Hängt ab von: libpolkit-agent-1-0 (= 0.105-33) aber 0.112-5.3.1~really-0.105-8 soll installiert werden
          Hängt ab von: libpolkit-gobject-1-0 (= 0.105-33) aber 0.112-5.3.1~really-0.105-8 soll installiert werden
 polkitd : Hängt ab von: libpolkit-agent-1-0 (= 0.105-33) aber 0.112-5.3.1~really-0.105-8 soll installiert werden
           Hängt ab von: libpolkit-gobject-1-0 (= 0.105-33) aber 0.112-5.3.1~really-0.105-8 soll installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
Gruss Juergen

Offline der_bud

  • User
  • Posts: 1.048
  • member
Re: du entfernt plasma-desktop ...
« Reply #9 on: 2022/07/25, 19:34:20 »
Hatte oben überlesen dass Du den Thread schon gefunden hattest ;) - vor dem letzten Beitrag dort wurde auch libpolkit-agent in der passenden Version reinstalliert, ein paar Posts weiter oben, wird in Deiner Ausgabe ja auch angemeckert dass er in der 105er Version fehlt. Das wäre dann
Code: [Select]
apt install libpolkit-agent-1-0=0.105-33 libpolkit-gobject-1-0=0.105-33 --reinstall .
Ich kann nur nix dazu sagen was es bei Dir mit den 332 zu entfernenden Paketen auf sich hat, keine Ahnung...
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline jure

  • User
  • Posts: 635
Re: du entfernt plasma-desktop ...
« Reply #10 on: 2022/07/25, 19:54:46 »
wenn ich aktuell ein apt dist-upgrade aufrufe, wird nur plasma-desktop entfernt (s.o.) und polkit-kde-agent-1 zurückgehalten.

ein
Code: [Select]
apt install libpolkit-agent-1-0=0.105-33 libpolkit-gobject-1-0=0.105-33 --reinstall
würde funktionieren

Code: [Select]
Die folgenden Pakete werden durch eine ÄLTERE VERSION ERSETZT (Downgrade):
  libpolkit-agent-1-0 libpolkit-gobject-1-0
0 aktualisiert, 0 neu installiert, 2 durch eine ältere Version ersetzt, 0 zu entfernen und 10 nicht aktualisiert

edit
das scheint soweit zu funktionieren, ein "du" nach "apt install libpolkit-agent-1-0=0.105-33 libpolkit-gobject-1-0=0.105-33 --reinstall"
läuft ohne Entfernen von plasma-desktop o.ä. durch

Code: [Select]
...
Die folgenden NEUEN Pakete werden installiert:
  cryfs encfs libboost-chrono1.74.0 libfmt8 libspdlog1 libtinyxml2-9 linux-headers-5.18.14-1-siduction-amd64 linux-image-5.18.14-1-siduction-amd64
  plasma-thunderbolt plasma-vault polkitd qml-module-org-kde-kcmutils
Die folgenden Pakete werden aktualisiert (Upgrade):
  clonezilla kde-cli-tools kde-cli-tools-data kde-thumbnailer-deb khotkeys khotkeys-data libqapt3 libqt5webkit5 libxcvt0 libxkbcommon-x11-0
  libxkbcommon0 libxkbregistry0 linux-headers-siduction-amd64 linux-image-siduction-amd64 plasma-desktop plasma-desktop-data polkit-kde-agent-1 psmisc
  systemsettings xcvt xserver-common xserver-xorg-core
22 aktualisiert, 12 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

Danke an alle Helfer  :)
Gruss Juergen

Offline jure

  • User
  • Posts: 635
Re: du entfernt plasma-desktop ...
« Reply #11 on: 2022/08/07, 21:57:26 »
es ist doch noch nicht ausgestanden, nachdem ein du wie geschrieben problemlos verlief, gibt es unerfüllte Abhängigkeiten für  polkit-kde-agent-1

wie bekomme ich den "Knoten" gelöst ...?

Code: [Select]
apt policy libpolkit-agent-1-0 libpolkit-gobject-1-0 polkit-kde-agent-1 polkitd
polkitd:
  Installiert:           (keine) >> lässt sich nicht installieren, siehe unten**
  Installationskandidat: 0.105-33
  Versionstabelle:
     0.105-33 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian unstable/main amd64 Packages

polkit-kde-agent-1
polkit-kde-agent-1:
  Installiert:           4:5.25.3-1
  Installationskandidat: 4:5.25.4-1
  Versionstabelle:
     4:5.25.4-1 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian unstable/main amd64 Packages
 *** 4:5.25.3-1 100
        100 /var/lib/dpkg/status

libpolkit-agent-1-0:
  Installiert:           0.105-33
  Installationskandidat: 0.105-33
  Versionstabelle:
 *** 0.105-33 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
libpolkit-gobject-1-0:
  Installiert:           0.105-33
  Installationskandidat: 0.105-33
  Versionstabelle:
 *** 0.105-33 500
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages
        500 http://ftp.de.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status

Code: [Select]
apt dist-upgrade
....
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
Probieren Sie »apt --fix-broken install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 polkit-kde-agent-1 : Hängt ab von: polkitd
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt --fix-broken install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).

[root@siductionbox juergen]$ apt --fix-broken install
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
Abhängigkeiten werden korrigiert … Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  libarmadillo10 libgdal29 libkf5alarmcalendar-data libodbc1 libodbccr2 libopencv-calib3d4.5 libopencv-contrib4.5 libopencv-core4.5 libopencv-dnn4.5
  libopencv-features2d4.5 libopencv-flann4.5 libopencv-highgui4.5 libopencv-imgcodecs4.5 libopencv-imgproc4.5 libopencv-ml4.5 libopencv-objdetect4.5
  libopencv-video4.5 liborcus-0.16-0 liborcus-parser-0.16-0 libplacebo120 libplacebo157 libpoppler102 libproj22 libqhull8.0 libtesseract4 libwireshark14
  libwiretap11 libwsutil12 libx264-160 nvidia-settings
Verwenden Sie »apt autoremove«, um sie zu entfernen.
Die folgenden zusätzlichen Pakete werden installiert:
  polkitd
Die folgenden NEUEN Pakete werden installiert:
  polkitd
0 aktualisiert, 1 neu installiert, 0 zu entfernen und 551 nicht aktualisiert.
2 nicht vollständig installiert oder entfernt.
Es müssen noch 0 B von 88,9 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 308 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n]
(Lese Datenbank ... 435248 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../polkitd_0.105-33_amd64.deb ...
Entpacken von polkitd (0.105-33) ...
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/polkitd_0.105-33_amd64.deb (--unpack):
 Versuch, »/etc/pam.d/polkit-1« zu überschreiben, welches auch in Paket policykit-1 0.112-5.3.1~really-0.105-8 ist
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/polkitd_0.105-33_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


**
Code: [Select]
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/polkitd_0.105-33_amd64.deb (--unpack):
 Versuch, »/etc/pam.d/polkit-1« zu überschreiben, welches auch in Paket policykit-1 0.112-5.3.1~really-0.105-8 ist
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/polkitd_0.105-33_amd64.deb
Gruss Juergen