Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic:  dist-upgrade fails because of libpam-modules-bin  (Read 585 times)

Offline Mister00X

  • User
  • Posts: 144
dist-upgrade fails because of libpam-modules-bin
« on: 2022/10/06, 11:40:30 »
Hi everyone,

today upgrading failed for me with an error.

I did some research and apparently https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1021336 is the culprit. I guess its wise to wait with upgrading until that bug is fixed.

Here is the complete apt output:
Code: [Select]
# LANG=C apt dist-upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  encfs guile-2.2-libs libabsl20210324 libappstream-glib8 libatk1.0-data libavdevice58 libavfilter7 libcmark-gfm-extensions0.29.0.gfm.3 libcmark-gfm0.29.0.gfm.3 libfmt8 libgit2-1.3 libgraphblas6 libilmbase25 libnautilus-extension1a libopencolorio1v5 libopenexr25
  libopenh264-6 libopenvdb8.1 libpcre3:i386 libplacebo192 libplacebo192:i386 libpoppler118 libpython3.9-minimal libpython3.9-stdlib libqpdf28 libtinyxml2.6.2v5 libvkd3d-shader1 libvkd3d-shader1:i386 libvkd3d1 libvkd3d1:i386 libwrap0:i386
  linux-headers-5.18.15-1-siduction-amd64 linux-headers-5.18.16-1-siduction-amd64 linux-headers-5.19.3-1-siduction-amd64 linux-headers-5.19.4-1-siduction-amd64 linux-headers-5.19.6-2-siduction-amd64 linux-headers-5.19.8-1-siduction-amd64
  linux-headers-5.19.9-1-siduction-amd64 linux-image-5.18.15-1-siduction-amd64 linux-image-5.18.16-1-siduction-amd64 linux-image-5.19.3-1-siduction-amd64 linux-image-5.19.4-1-siduction-amd64 linux-image-5.19.6-2-siduction-amd64 linux-image-5.19.8-1-siduction-amd64
  linux-image-5.19.9-1-siduction-amd64 python3-testpath python3.9 python3.9-minimal vkd3d-compiler:i386
Use 'apt autoremove' to remove them.
The following packages have been kept back:
  emacs-bin-common emacs-el
The following packages will be upgraded:
  dbus dbus-bin dbus-daemon dbus-session-bus-common dbus-system-bus-common dbus-user-session dragonplayer hwdata kde-config-cddb kio-audiocd libbsd-dev libbsd0 libbsd0:i386 libdbus-1-3 libdbus-1-3:i386 libdbus-1-dev libkf5baloowidgets-bin libkf5baloowidgets5 libkf5cddb5
  libkf5guiaddons-bin libkf5guiaddons-data libkf5guiaddons5 libpam-modules libpam-modules-bin libpam-runtime libsdl2-2.0-0 libsdl2-2.0-0:i386 libxnvctrl0 ocl-icd-libopencl1 ocl-icd-libopencl1:i386 sbcl sbcl-doc sbcl-source
33 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
Need to get 0 B/22,6 MB of archives.
After this operation, 404 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
Reading changelogs... Done
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 988521 files and directories currently installed.)
Preparing to unpack .../libpam-modules-bin_1.5.2-3_amd64.deb ...
Unpacking libpam-modules-bin (1.5.2-3) over (1.5.2-2) ...
dpkg: error processing archive /var/cache/apt/archives/libpam-modules-bin_1.5.2-3_amd64.deb (--unpack):
 trying to overwrite '/usr/share/man/man5/namespace.conf.5.gz', which is also in package libpam-modules:amd64 1.5.2-2
Errors were encountered while processing:
 /var/cache/apt/archives/libpam-modules-bin_1.5.2-3_amd64.deb
needrestart is being skipped since dpkg has failed
E: Sub-process /usr/bin/dpkg returned an error code (1)

Arguing that you don't care about the right to privacy because you have nothing to hide is no different than saying you don't care about free speech because you have nothing to say. – Edward Snowden

Offline charlyheinz

  • User
  • Posts: 69
Re: dist-upgrade fails because of libpam-modules-bin
« Reply #1 on: 2022/10/06, 12:54:06 »
Same here. A fresh DU quits with the following error- message:


dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/libpam-modules-bin_1.5.2-3_amd64.deb (--unpack):
 Versuch, »/usr/share/man/man5/namespace.conf.5.gz« zu überschreiben, welches auch in Paket libpam-modules:amd64 1.5.2-2 ist

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.227
    • Land of the Buckeye
Re: dist-upgrade fails because of libpam-modules-bin
« Reply #2 on: 2022/10/06, 13:47:32 »
Thanks guys.
System76 Oryx Pro, Intel Core i7-11800H, SSD 970 EVO Plus;  Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO

Offline hschn

  • User
  • Posts: 112
Re: dist-upgrade fails because of libpam-modules-bin
« Reply #3 on: 2022/10/07, 07:41:50 »
Today fixed with Version

libpam-modules amd64 1.5.2-5 and libpam-modules-bin amd64 1.5
Mögen hätt' ich schon wollen, aber dürfen habe ich mich nicht getraut (Karl Valentin)