Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic:  (partly solved) after today d-u (kernel + qt) no image in vlc,  (Read 1342 times)

Offline michaa7

  • User
  • Posts: 2.219
Hi

system boots, I have X and normal progs working so far.

But when I open a video with vlc, I have *almost ever* no image, only sound, i.e. videos from HD sometimes show the videopart, sometimes not. Videostrems from my usb-tv-card, which I used here for years now, only play sound, no video. But when closing the file a still of the video appeears for a fraction of a second.

As smplayer works (although problems with subtitel, but different story) and as I tried different kernels to no avail, it seems somehow related to vlc. Infortunatly my TV-adapter works with VLC only ;-).

I think the relevant part in console is the following:
Quote
~$ vlc
VLC media player 3.0.17.4 Vetinari (revision 3.0.13-8-g41878ff4f2)
[000055b70ef55580] main libvlc: VLC wird mit dem Standard-Interface ausgeführt. Benutzen Sie 'cvlc', um VLC ohne Interface zu verwenden.
[000055b70eff5e60] main playlist: playlist is empty
[00007f7b94344e50] mpeg4audio packetizer: AAC channels: 2 samplerate: 48000
[00007f7b800048e0] gl gl: Initialized libplacebo v4.208.0 (API v208)
[00007f7b800a9ac0] chain filter error: Too high level of recursion (3)

[00007f7b800aa3a0] main filter error: Failed to create video converter
[00007f7b800013c0] main vout display error: Failed to create video converter
[00007f7b800013c0] main vout display error: Failed to adapt decoder format to display
[00007f7b8814a1a0] main video output error: video output creation failed
[00007f7b94013cc0] main decoder error: failed to create video output
[00007f7b800aa1b0] gl gl: Initialized libplacebo v4.208.0 (API v208)
[00007f7b94013cc0] avcodec decoder: Using NVIDIA VDPAU Driver Shared Library  470.141.03  Thu Jun 30 18:33:34 UTC 2022 for hardware decoding
[hevc @ 0x7f7b9cc13c40] Failed setup for format vdpau: hwaccel initialisation returned error.
[00007f7b94013cc0] avcodec decoder error: existing hardware acceleration cannot be reused     
[00007f7b800aa1b0] gl gl: Initialized libplacebo v4.208.0 (API v208)
[00007f7b80308fa0] chain filter error: Too high level of recursion (3)
[00007f7b80307d80] main filter error: Failed to create video converter
[00007f7b80308fa0] chain filter error: Too high level of recursion (3)

...

[00007f7b800a9a80] main vout display error: Failed to create video converter
[00007f7b800a9a80] main vout display error: Failed to adapt decoder format to display
[00007f7b8815ba20] main video output error: video output creation failed
[00007f7b94013cc0] main decoder error: failed to create video output
[00007f7b80008b60] gl gl: Initialized libplacebo v4.208.0 (API v208)
[00007f7b94013cc0] main decoder error: buffer deadlock prevented
[hevc @ 0x7f7b9c186b80] Could not find ref with POC 14244
[hevc @ 0x7f7b9c186b80] Could not find ref with POC 14248                                     
[hevc @ 0x7f7b9c186b80] Could not find ref with POC 14252                                     
[hevc @ 0x7f7b9c186b80] Could not find ref with POC 14256                                     
[hevc @ 0x7f7b9c186b80] Could not find ref with POC 14260                                     
[hevc @ 0x7f7b9c186b80] Could not find ref with POC 14264                                     
[hevc @ 0x7f7b9c186b80] Could not find ref with POC 14268                                     
[hevc @ 0x7f7b9c186b80] Could not find ref with POC 14272                                     
[hevc @ 0x7f7b9c186b80] Could not find ref with POC 14276                                     
[hevc @ 0x7f7b9c186b80] Could not find ref with POC 14280                                     
[hevc @ 0x7f7b9c186b80] Could not find ref with POC 14284                                     
[hevc @ 0x7f7b9c186b80] Could not find ref with POC 14288                                     
[hevc @ 0x7f7b9c186b80] Could not find ref with POC 14292                                     


Any help appreciated

« Last Edit: 2022/10/14, 16:07:50 by towo »
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline NochEinNeuer

  • User
  • Posts: 159
Re: after today d-u (kernel + qt) no image in vlc,
« Reply #1 on: 2022/10/02, 19:55:36 »
Geht mir auch so....mit vlc ist alles schwarz. SMPlayer geht problemlos


Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.663
Re: after today d-u (kernel + qt) no image in vlc,
« Reply #3 on: 2022/10/02, 23:40:38 »
Den Bugreport kann ich nicht nachvollziehem dort steht, es benötigt 3.0.18, was absoluter Unsinn ist.
Ein simpler lokaler Rebuild von VLC hat hier ausgereicht, um VLC wieder ein Bild zu entlocken.
Allerdings benutze ich VLC von Debian-Multimedia.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.663
Re: after today d-u (kernel + qt) no image in vlc,
« Reply #4 on: 2022/10/03, 00:17:00 »
Hm, oder auch nicht, mal gehts, mal nicht.
Wenn ich Video und Codecs auf automatisch stelle, gehts komischer Weise genau 1 mal.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline michaa7

  • User
  • Posts: 2.219
Re: after today d-u (kernel + qt) no image in vlc,
« Reply #5 on: 2022/10/03, 00:48:25 »
Aber liegt denn der Fehler überhaupt an VLC. Ich bezweifle das.

Die letzte Version 3.0.17.4-4+b2 ist vom 2022-09-21, ich habe die am 23.09. installiert und das hat hier seitdem ohne Probleme funktioniert, bis zum heutigen d-u. Erst seitdem gibt es den Fehler.

EDIT:

nvidia kam aber heut. Meiner erinnerung nachwurde das Kernel Modul erfolgreich gebaut, dennoch folgende Meldung im log:
Quote
# cat /var/log/Xorg.0.log | grep "(EE)"
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    26.980] (EE) Failed to load module "nv" (module does not exist, 0)


Wie erzwinge ich eine erneute Erstellung des Moduls?
« Last Edit: 2022/10/03, 01:40:45 by michaa7 »
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline edlin

  • User
  • Posts: 171
Re: after today d-u (kernel + qt) no image in vlc,
« Reply #6 on: 2022/10/03, 11:50:12 »
@michaa7: An nvidea sollte es aber auch nicht liegen. Hier werkelt eine AMD GPU und vlc verweigert auch hier seinen Dienst.

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline michaa7

  • User
  • Posts: 2.219
Re: after today d-u (kernel + qt) no image in vlc,
« Reply #7 on: 2022/10/03, 12:00:08 »
@michaa7: An nvidea sollte es aber auch nicht liegen. Hier werkelt eine AMD GPU und vlc verweigert auch hier seinen Dienst.

edlin

Ja, ich denke du hast recht zumal towo meines Wissens auch auf nvidia hardware verzichtet.
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline harley-peter

  • User
  • Posts: 960
Re: after today d-u (kernel + qt) no image in vlc,
« Reply #8 on: 2022/10/03, 12:09:38 »
Auch hier funktioniert's wie bei towo genau einmal, dann muss ich VLC wieder neu starten.
Ich hatte beim letzten update ein Abhängigkeitsproblem, das sich aber mit einem "apt fix-broken install" beheben ließ.

Offline michaa7

  • User
  • Posts: 2.219
Re: after today d-u (kernel + qt) no image in vlc,
« Reply #9 on: 2022/10/03, 13:11:27 »
komisch, hier funktioniert es (meistens) mit sooft ich will, d.h. ich kann verschiedene Videos von HD abspielen. Aber beim Abspielen eines TV Senders habe ich schon beim ersten mal kein Bild (aber Ton), danach geht auch kein Video von HD mehr.
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline michaa7

  • User
  • Posts: 2.219
Re: after today d-u (kernel + qt) no image in vlc,
« Reply #10 on: 2022/10/03, 20:44:59 »
The problem goes away when vlc ist started with --no-embedded-video
Code: [Select]
vlc --no-embedded-video as suggested in the bug report.

And I agree that it seem related to yesterdays QT update as this fits my update timeline.
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline edlin

  • User
  • Posts: 171
Re: after today d-u (kernel + qt) no image in vlc,
« Reply #11 on: 2022/10/04, 13:38:58 »
The problem goes away when vlc ist started with --no-embedded-video
Code: [Select]
vlc --no-embedded-video as suggested in the bug report.

And I agree that it seem related to yesterdays QT update as this fits my update timeline.

It looks like this will work.
The same should be achieved in the settings by unchecking "Integrate video in interface".
---
Es sieht so aus, als ob dies funktioniert.
Das Gleiche sollte in den Einstellungen erreicht werden, wenn man das Häkchen bei "Video ins Interface einbinden" entfernt.

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates

Offline michaa7

  • User
  • Posts: 2.219
Re: after today d-u (kernel + qt) no image in vlc,
« Reply #12 on: 2022/10/04, 15:17:32 »
Mit der neuesten vlc version 3.0.17.4-5 von heute funktioniert alles wieder ganz normal.

With todays vlc version 3.0.17.4-5 all works as it should.
Ok, you can't code, but you still might be able to write a bug report for Debian's sake

Offline Mte90

  • User
  • Posts: 181
  • KDE & Debian lover
    • http://www.mte90.net
Re: (solved) after today d-u (kernel + qt) no image in vlc,
« Reply #13 on: 2022/10/12, 17:41:04 »
On my tests doesn't works with all the codec also if the format is AVI as example.

Offline edlin

  • User
  • Posts: 171
Re: (solved) after today d-u (kernel + qt) no image in vlc,
« Reply #14 on: 2022/10/12, 19:38:59 »
Welche Version verwendest du?
1:3.0.17.4-dmo5 (deb-multimedia.org) oder
3.0.18-rc2-1 (unstable)?

Die Version 1:3.0.17.4-dmo5 läuft bei mir noch nicht rund.
---
Which version are you using?
1:3.0.17.4-dmo5 (deb-multimedia.org) or
3.0.18-rc2-1 (unstable)?

Version 1:3.0.17.4-dmo5 does not run smoothly for me yet.

edlin
Der Kluge lernt aus allem und von jedem,
der Normale aus seinen Erfahrungen
und der Dumme weiß alles besser.

Sokrates