Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] [SOLVED] Updating/Aktualisierung gstreamer-plugins failed/gescheitert  (Read 531 times)

Offline samoht

  • User
  • Posts: 451
Code: [Select]
# LANG=C apt full-upgrade -V
...
Code: [Select]
The following packages will be upgraded:
   gstreamer1.0-plugins-bad (1.20.5-1 => 1.22.0-3)
   gstreamer1.0-plugins-good (1.20.5-2 => 1.22.0-3)
   libgstreamer-plugins-bad1.0-0 (1.20.5-1 => 1.22.0-3)
...
Code: [Select]
Preparing to unpack .../gstreamer1.0-plugins-bad_1.22.0-3_amd64.deb ...
Unpacking gstreamer1.0-plugins-bad:amd64 (1.22.0-3) over (1.20.5-1) ...
Preparing to unpack .../gstreamer1.0-plugins-good_1.22.0-3_amd64.deb ...
Unpacking gstreamer1.0-plugins-good:amd64 (1.22.0-3) over (1.20.5-2) ...
dpkg: error processing archive /var/cache/apt/archives/gstreamer1.0-plugins-good_1.22.0-3_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstxingmux.so', which is also in package gstreamer1.0-plugins-ugly:amd64 1.20.5-1
Preparing to unpack .../libgstreamer-plugins-bad1.0-0_1.22.0-3_amd64.deb ...
Unpacking libgstreamer-plugins-bad1.0-0:amd64 (1.22.0-3) over (1.20.5-1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/gstreamer1.0-plugins-good_1.22.0-3_amd64.deb
needrestart is being skipped since dpkg has failed
E: Sub-process /usr/bin/dpkg returned an error code (1)

[UPDATE]:
Solved by recent update and subsequent
Code: [Select]
apt -f install
« Last Edit: 2023/01/29, 10:07:24 by samoht »

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.752
Does
Code: [Select]
apt -f install help?

Online pjnsmb

  • User
  • Posts: 88
gstreamer1.0-plugins-good 

Debian bug 1029923

submitted earlier today
regards
pjnsmb

Offline unklarer

  • User
  • Posts: 723
hier auch ok

Code: [Select]
[font=monospace][color=#000000]apt -f install [/color]
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
Abhängigkeiten werden korrigiert … Fertig
Die folgenden zusätzlichen Pakete werden installiert:
  gstreamer1.0-plugins-good
Die folgenden Pakete werden aktualisiert (Upgrade):
  gstreamer1.0-plugins-good
1 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
51 nicht vollständig installiert oder entfernt.
Es müssen noch 0 B von 2.220 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 627 kB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n]
Laden der Fehlerberichte … Erledigt
»Found/Fixed«-Informationen werden ausgewertet … Erledigt
serious Fehler von gstreamer1.0-plugins-good (1.20.5-2 → 1.22.0-3) <Ausstehend>
 b1 - #1029923 - gstreamer1.0-plugins-good: trying to overwrite libgstxingmux.so, which is also in package gstreamer1.0-plugins-ugly
Zusammenfassung:
 gstreamer1.0-plugins-good(1 Fehler)
Sind Sie sicher, dass Sie die oben genannten Pakete installieren bzw. ein Upgrade von ihnen durchführen wollen? [Y/n/?/...]
Changelogs werden gelesen... Fertig
(Lese Datenbank ... 231350 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../gstreamer1.0-plugins-good_1.22.0-3_amd64.deb ...
Entpacken von gstreamer1.0-plugins-good:amd64 (1.22.0-3) über (1.20.5-2) ...
mesa-vulkan-drivers:amd64 (22.3.4-1) wird eingerichtet ...[/font]
[font=monospace]...[/font]
[font=monospace]
[/font]

Danke @devil

Offline harley-peter

  • User
  • Posts: 977
Hier gibt es nach wie vor ein Problem:
Code: [Select]
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von gstreamer1.0-pulseaudio:amd64:
gstreamer1.0-pulseaudio:amd64 hängt ab von gstreamer1.0-plugins-good (>= 1.22.0); aber:
  Version von gstreamer1.0-plugins-good:amd64 auf dem System ist 1.20.5-2.

dpkg: Fehler beim Bearbeiten des Paketes gstreamer1.0-pulseaudio:amd64 (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
gstreamer1.0-pulseaudio:amd64


Der Versuch gstreamer1.0-plugins-good neu zu installieren endet mit
Code: [Select]
Die folgenden Pakete werden aktualisiert (Upgrade):
  gstreamer1.0-plugins-good
1 aktualisiert, 0 neu installiert, 0 zu entfernen und 194 nicht aktualisiert.
1 nicht vollständig installiert oder entfernt.
Es müssen noch 0 B von 2.219 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 627 kB Plattenplatz freigegeben.
(Lese Datenbank ... 438055 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../gstreamer1.0-plugins-good_1.22.0-4_amd64.deb ...
Entpacken von gstreamer1.0-plugins-good:amd64 (1.22.0-4) über (1.20.5-2) ...
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/gstreamer1.0-plugins-good_1.22.0-4_amd64.deb (--unpack):
Versuch, »/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstxingmux.so« zu überschreiben, welches auch in Paket gstreamer1.0-plugins-ugly:amd64 1:1.20.3-dmo1 ist
Fehler traten auf beim Bearbeiten von:
/var/cache/apt/archives/gstreamer1.0-plugins-good_1.22.0-4_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Offline Geier0815

  • User
  • Posts: 570
Doofe Frage: Soll gstreamer1.0-plugins-good auch aus deb-multimedia.org installiert werden wie gstreamer1.0-plugins-ugly? apt policy gibt Auskunft.



Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Offline samoht

  • User
  • Posts: 451
Code: [Select]
# LANG=C apt show gstreamer1.0-pulseaudio

Package: gstreamer1.0-pulseaudio
Version: 1.22.0-4

This is a transitional package.







Offline harley-peter

  • User
  • Posts: 977
@Geier0815:
Code: [Select]
gstreamer1.0-plugins-good:
  Installiert:          1.20.5-2
  Installationskandidat: 1.22.0-4
  Versionstabelle:
    1.22.0-4 500
        500 http://ftp.de.debian.org/debian unstable/main amd64 Packages
*** 1.20.5-2 100
        100 /var/lib/dpkg/status


gstreamer1.0-plugins-ugly:
  Installiert:          1:1.20.3-dmo1
  Installationskandidat: 1:1.20.3-dmo1
  Versionstabelle:
*** 1:1.20.3-dmo1 100
        100 /var/lib/dpkg/status
    1.22.0-2 500
        500 http://ftp.de.debian.org/debian unstable/main amd64 Packages

Wie bekomme ich dieses Paket gstreamer1.0-plugins-good installiert? Es blockiert das komplette Update.
weder ein apt --fix-broken install noch ein apt -f install hilft.
« Last Edit: 2023/02/06, 14:55:09 by harley-peter »

Offline Geier0815

  • User
  • Posts: 570
Entweder aktivierst Du wieder dmo (deb-multimedia.org) als Repo und installierst es auch daraus oder Du deinstallierst das ugly-Paket und installierst auch das aus dem unstable-Repo. Aber das Eine aus dem einen Repo und das Andere aus dem andern Repo, ist eine schlechte Idee
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Offline harley-peter

  • User
  • Posts: 977
Danke für den Tip!
Ein Aktivieren des dmo und nach dem Update ein apt --fix-broken install haben das Problem gelöst.

Offline charlyheinz

  • User
  • Posts: 74
Bei mir lag es an dem Übergangspaket von gstreamer1.0-pulseaudio. Nach einer Deinstallation des Selbigen funktionierte ein DU ohne Multimedia-Quellen anstandslos


Quote
gstreamer1.0-plugins-good:
  Installiert:          1.22.0-dmo2
  Installationskandidat: 1.22.0-dmo2
  Versionstabelle:
*** 1.22.0-dmo2 100
        100 /var/lib/dpkg/status
    1.22.0-4 500
        500 https://deb.debian.org/debian unstable/main amd64 Packages


Quote
gstreamer1.0-plugins-bad:
  Installiert:           1:1.22.0-dmo1
  Installationskandidat: 1:1.22.0-dmo1
  Versionstabelle:
 *** 1:1.22.0-dmo1 100
        100 /var/lib/dpkg/status
     1.22.0-3 500
        500 https://deb.debian.org/debian unstable/main amd64 Packages
Quote
gstreamer1.0-plugins-ugly:
  Installiert:           1:1.22.0-dmo1
  Installationskandidat: 1:1.22.0-dmo1
  Versionstabelle:
 *** 1:1.22.0-dmo1 100
        100 /var/lib/dpkg/status
     1.22.0-2 500
        500 https://deb.debian.org/debian unstable/main amd64 Packages


Offline hendrikL

  • Administrator
  • User
  • *****
  • Gravatar
  • Posts: 656

Code: [Select]
:~$ dpkg -l gstreamer* | grep ii
ii  gstreamer1.0-alsa:amd64               1.22.0-3     amd64        GStreamer plugin for ALSA
ii  gstreamer1.0-clutter-3.0:amd64        3.0.27-3     amd64        Clutter PLugin for GStreamer 1.0
ii  gstreamer1.0-gl:amd64                 1.22.0-3     amd64        GStreamer plugins for GL
ii  gstreamer1.0-gtk3:amd64               1.22.0-4     amd64        GStreamer plugin for GTK+3
ii  gstreamer1.0-libav:amd64              1.22.0-2     amd64        ffmpeg plugin for GStreamer
ii  gstreamer1.0-nice:amd64               0.1.21-1     amd64        ICE library (GStreamer plugin)
ii  gstreamer1.0-pipewire:amd64           0.3.65-1     amd64        GStreamer 1.0 plugin for the PipeWire multimedia server
ii  gstreamer1.0-plugins-bad:amd64        1.22.0-3     amd64        GStreamer plugins from the "bad" set
ii  gstreamer1.0-plugins-base:amd64       1.22.0-3     amd64        GStreamer plugins from the "base" set
ii  gstreamer1.0-plugins-good:amd64       1.22.0-4     amd64        GStreamer plugins from the "good" set
ii  gstreamer1.0-plugins-ugly:amd64       1.22.0-2     amd64        GStreamer plugins from the "ugly" set
ii  gstreamer1.0-qt5:amd64                1.22.0-4     amd64        GStreamer plugin for Qt5
ii  gstreamer1.0-tools                    1.22.0-2     amd64        Tools for use with GStreamer
ii  gstreamer1.0-vaapi:amd64              1.22.0-2     amd64        VA-API plugins for GStreamer
ii  gstreamer1.0-x:amd64                  1.22.0-3     amd64        GStreamer plugins for X11 and Pango

:~$ dpkg -l | awk '/dmo/{print $2}'