Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] GoogleEarth  (Read 8824 times)

mac-cloud

  • Guest
[DE] GoogleEarth
« on: 2010/09/19, 12:45:30 »
Hi,
ich bins wider-kann mir mal jemand auf die sprünge helfen,wie ich Google Earth unter Aptosid zu installieren schaffe?In sidux hatte ich damals das paket kompilieren müssen-hier bekomme ich das leider nicht so hin ... oder gibt es inzwischen fertige debinpakete dafür ?
gruß
mc

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.941
GoogleEarth
« Reply #1 on: 2010/09/19, 13:01:29 »
als root:
apt-get install googleearth-package

als User:
make-googleearth-package

Wo ist das Problem?
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline phen

  • User
  • Posts: 85
GoogleEarth
« Reply #2 on: 2010/09/19, 14:35:41 »
Hatte das vorgestern so gemacht (64bit), allerdings kam dabei ne bin-Datein raus, und kein deb-Paket, was mich etwas stutzig gemacht hatte. Schätze mal ne Installation würde das Paketmanagement umgehn, weswegen ich erstmal die Finger von ließ (davon abgesehn las ich irgendwo was von derzeit defektem libcairo).

Die bin-Datei ist also tatsächlich der empfohlene Weg?

mac-cloud

  • Guest
re:GE
« Reply #3 on: 2010/09/19, 14:39:08 »
Danke towo,
ich war der Meinung,es genauso getan zu haben,aber dabei gibt die Konsole dann folgendes aus:
Quote
mischu@aptosidbox:~$ make-googleearth-package
Google Earth for GNU/Linux 5.2.1.1588
Unrecognized Google Earth version (use --force to build anyway)
mischu@aptosidbox:~$



da stimmt also was ned.

mc

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.941
GoogleEarth
« Reply #4 on: 2010/09/19, 14:41:53 »
Die bin wird runtergeladen, soweit richtig.
Und wenn man die Augen aufgemacht hätte, hätte man gesehen, daß man hier mit

make-ggoogleearth-package --force

arbeiten muß.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline phen

  • User
  • Posts: 85
GoogleEarth
« Reply #5 on: 2010/09/19, 14:45:14 »
Mach einfach mal:
Code: [Select]
make-googleearth-package --force

EDIT:
Jep, danke towo - achja, der Wald..=P

mac-cloud

  • Guest
GoogleEarth
« Reply #6 on: 2010/09/19, 15:27:05 »
ja danke,jetzt wurde zwar in der konsole eine ellenlange liste abgearbeitet - allerdings mit vielen warnungen und fehlenden abhängigkeiten.ich habe den konsolenangaben entsprechend nachinstalliert.nun kann ich über konsole googleEarth starten,aber es läuft sehr instabil. Hm,da haut einiges noch ned so hin ... vielleicht ist bei der ganzen sache jetzt auch vieles durcheinander gekommen ... wie kann ich diese Installation jetzt wider löschen um es nochmal sauber neu zu versuchen ? ... sorry,ich bin ne totale niete auf der konsole,da hab ich noch arg viel zu lernen ...Danke trotzdem für eure geduld

mc

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
GoogleEarth
« Reply #7 on: 2010/09/19, 15:56:17 »
apt-get purge googleearth

greetz
devil

pischuma

  • Guest
GoogleEarth
« Reply #8 on: 2010/09/21, 11:08:19 »
@mac-cloud

welche datei hast du nachinstalliert. ich bekomme auch jede menge fehlermeldungen, werde aber nicht so ganz schlau welche was ich genau nachinstallieren muss.

gruss pischuma

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.941
GoogleEarth
« Reply #9 on: 2010/09/21, 11:10:26 »
Ich weiss echt nicht, was so schwer ist.
Code: [Select]
make-googleearth-package --force
dpkg -i foo
apt-get -f install

Mehr brauchts nicht.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

pischuma

  • Guest
GoogleEarth
« Reply #10 on: 2010/09/21, 11:15:32 »
so einfach ist das nicht. beim erstellen der .deb datei treten fehler auf, da u.a. folgende datei nicht gefunden wird: dpkg-shlibdeps: Fehler: Bibliothek libgcc_s.so.1 konnte nicht gefunden werden. es wird daher auch keine .deb datei erstellt die ich dann installieren kann.


gruss pischuma

Offline phen

  • User
  • Posts: 85
GoogleEarth
« Reply #11 on: 2010/09/21, 12:07:33 »
Code: [Select]
apt-file search libgcc_s.so.1
lib32gcc1: /emul/ia32-linux/usr/lib/libgcc_s.so.1
lib32gcc1: /usr/lib32/libgcc_s.so.1
libgcc1: /lib/libgcc_s.so.1

Beide Pakete sehe ich bei mir installiert - vielleicht einfach mal probieren die nach zu installieren?

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.844
GoogleEarth
« Reply #12 on: 2010/09/21, 12:18:28 »
apt-file search libgcc_s.so.1:
gcc-snapshot: /usr/lib/gcc-snapshot/lib/libgcc_s.so.1
gcc-snapshot: /usr/lib/gcc-snapshot/lib64/libgcc_s.so.1
lib64gcc1: /lib64/libgcc_s.so.1
lib64gcc1-dbg: /usr/lib/debug/lib64/libgcc_s.so.1
libgcc1: /lib/libgcc_s.so.1
libgcc1-dbg: /usr/lib/debug/lib/libgcc_s.so.1

greetz
devil

Offline ralfi

  • User
  • Posts: 389
GoogleEarth
« Reply #13 on: 2010/09/27, 11:48:59 »
Er meint bestimmt diese Meldungen ...

Code: [Select]

mv: Aufruf von stat für »libssl.so.0.9.8« nicht möglich: Datei oder Verzeichnis nicht gefunden
Checking shlib deps: libGLU.so.1
Checking shlib deps: libIGAttrs.so
dpkg-shlibdeps: Warnung: Umleitungen beteiligt - Ausgabe könnte nicht korrekt sein
 diversion by libgl1-nvidia-alternatives from: /usr/lib/libGL.so.1
dpkg-shlibdeps: Warnung: Umleitungen beteiligt - Ausgabe könnte nicht korrekt sein
 diversion by libgl1-nvidia-alternatives to: /usr/lib/nvidia/diversions/libGL.so.1
Checking shlib deps: libIGCore.so
dpkg-shlibdeps: Warnung: Umleitungen beteiligt - Ausgabe könnte nicht korrekt sein
 diversion by libgl1-nvidia-alternatives from: /usr/lib/libGL.so.1
dpkg-shlibdeps: Warnung: Umleitungen beteiligt - Ausgabe könnte nicht korrekt sein
 diversion by libgl1-nvidia-alternatives to: /usr/lib/nvidia/diversions/libGL.so.1
Checking shlib deps: libIGExportCommon.so
dpkg-shlibdeps: Warnung: Umleitungen beteiligt - Ausgabe könnte nicht korrekt sein
 diversion by libgl1-nvidia-alternatives from: /usr/lib/libGL.so.1
dpkg-shlibdeps: Warnung: Umleitungen beteiligt - Ausgabe könnte nicht korrekt sein
 diversion by libgl1-nvidia-alternatives to: /usr/lib/nvidia/diversions/libGL.so.1
Checking shlib deps: libIGGfx.so


Hab ich auch und das Problem auch noch nicht lösen können ...
Die apt-file search Ausgabe sieht genau so aus wie bei devil
Gruss, ralfi

Niveau sieht von unten oft wie Arroganz aus ...

walloac

  • Guest
GoogleEarth
« Reply #14 on: 2010/10/12, 12:06:23 »
Hallo

Hat schon jemand einen Erfolg bei der Installation gehabt?
Bei mir kommt nach Start auf der Konsole (32 Bit Version) als Fehlermeldung:
$ googleearth

(process:2513): GLib-GObject-CRITICAL **: /build/buildd-glib2.0_2.24.2-1-i386-AScyie/glib2.0-2.24.2/gobject/gtype.c:2706: You forgot to call g_type_init()

(process:2513): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(process:2513): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed
Google Earth has caught signal 11.



We apologize for the inconvenience, but Google Earth has crashed.
 This is a bug in the program, and should never happen under normal
 circumstances. A bug report and debugging data have been written
 to this text file:

    /home/mij/.googleearth/crashlogs/crashlog-4cb42e34.txt

Please include this file if you submit a bug report to Google.


Groetjes
WalloAC