seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2019/11/18, 07:13:05


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Kein X nach update  (Read 5109 times)

0 Members and 1 Guest are viewing this topic.

Offline reddark

  • User
  • Posts: 1.047
    • http://www.klangruinen.de/
Kein X nach update
« on: 2010/09/24, 00:32:17 »
Nu is dunkel ;(

Hab grad ein DU gefahren und beim neustart.
meldet er mir irgendwas mit Bugs, Scheduling Atomic und Xorg
Auch ein startx geht nicht.

Beim update kamen unteranderem fglrx vom frickelplatz mitrein.
Keine ahnung obs damit zutun hat.

Sorry für die spärlichen infos, ich schreibe grad aus einem Windows...

Hat trotzdem jemand ne idee?

Offline gerd

  • User
  • Posts: 145
Kein X nach update
« Reply #1 on: 2010/09/24, 00:39:40 »
xorg.conf (in /etc/X11/) löschen (Sicherheitskopie machen) und dann noch mal versuchen.
Und wenn es geht die entsprechenden Logs sichern und posten.

Offline reddark

  • User
  • Posts: 1.047
    • http://www.klangruinen.de/
Kein X nach update
« Reply #2 on: 2010/09/24, 00:42:04 »
werds mal versuchen ;)

danke schonmal

Offline killua

  • User
  • Posts: 51
Kein X nach update
« Reply #3 on: 2010/09/24, 00:44:25 »
Hab das selbe Problem, liegt wohl an fglrx - ohne starte die GUI ohne Problem - Problem kam mit dem neuen fglrx 10.10 pre, das paket lässt sich ohne Probleme erstellen und installieren.

Offline reddark

  • User
  • Posts: 1.047
    • http://www.klangruinen.de/
Kein X nach update
« Reply #4 on: 2010/09/24, 00:57:27 »
So hab wieder ein Bild, aber eine miese auflösung und kein 3d.
Ich werds nochmal mit dem paket von towo (http://forum.siduction.org/index.php?topic=73) versuchen.
« Last Edit: 2013/11/10, 02:21:37 by melmarker »

Offline reddark

  • User
  • Posts: 1.047
    • http://www.klangruinen.de/
Kein X nach update
« Reply #5 on: 2010/09/24, 01:08:45 »
Nö geht nicht, weil der fglrx-driver der falsche ist ;(

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.308
Kein X nach update
« Reply #6 on: 2010/09/24, 07:01:42 »
Könntet ihr mal etwas konkreter werden, was den neuen fglrx angeht?
Ich hab keine ATI-Karte und somit kann ich da nix selber testen.
Also das Mindeste wäre das X-Log, dann kann man weiter sehen.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline reddark

  • User
  • Posts: 1.047
    • http://www.klangruinen.de/
Kein X nach update
« Reply #7 on: 2010/09/24, 09:08:37 »
Hmm, bin jetzt wieder auf dem Treiber von unstable gewechselt, weil - hab dieses Wochenende nicht wirklich Zeit. Werde es am Montag wieder versuchen.

Offline killua

  • User
  • Posts: 51
Kein X nach update
« Reply #8 on: 2010/09/24, 12:29:04 »
Hi

Also hier ein paar nähere Infos

Kurze Beschreibung
Paket lässt sich mittels m-a ohne Probleme bauen wie auch installieren. Nach einem Reboot wird versucht der KDM zu starten, ohne Erfolg (kurz schwarzes Bild) - es tratt vorher kein failed auf beim laden der Module. Nach dem schwarzen Bild bekommt man die Meldung
Quote
BUG: scheduling while atomic: Xorg/2096/0x00000002

angezeigt, dann folgt der Login.

Kernelversion
Quote
Linux aptosid 2.6.35-5.slh.3-aptosid-amd64 #1 SMP PREEMPT Thu Sep 23 20:05:45 UTC 2010 x86_64 GNU/Linux


fglrxversion
Quote
fglrx-kernel-2.6.35-5.slh.3-aptosid-amd64_10-10-0~pre+2.6.35-35_amd64


Xorg Log (var/log/Xorg.0.log)
http://pastesite.com/18913


Gruß Killua

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.308
Kein X nach update
« Reply #9 on: 2010/09/24, 13:10:10 »
Zeig mir mal bitte noch deine xorg.conf
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline killua

  • User
  • Posts: 51
Kein X nach update
« Reply #10 on: 2010/09/24, 14:51:04 »
Bitte schön

xorg.conf (/etc/X11/xorg.conf)
http://pastesite.com/18918

Offline killua

  • User
  • Posts: 51
Kein X nach update
« Reply #11 on: 2010/09/26, 18:38:00 »
Gibt es aktuell keine Lösung ? -würde gerne wieder spielen^^

Gruß Killua

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.308
Kein X nach update
« Reply #12 on: 2010/09/27, 14:33:55 »
Ich habe die 10-10~pre Version wieder aus dem Repo genommen, da sie anscheinend in Debian nicht fehlerfrei läuft.
Das Ding wurde von AMD auch nur für Ubuntu zu Verfügung gestellt, es kann also sein, daß hier nicht alles vollständig ist.
Weiterhin habe ich keine Möglichkeit fglrx selbst zu testen, da mir die Hardware fehlt. Ferndiagnosen sind in solch einem Fall eher suboptimal, wenn man nicht selbst an der Kiste sitzt.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline killua

  • User
  • Posts: 51
Kein X nach update
« Reply #13 on: 2010/09/27, 15:05:29 »
Ok danke ;) - läuft wieder mit dem aktuellen Kernel (Linux 2.6.35-6.slh.1-aptosid-amd64 x86_64)

Gruß Killua

Offline reddark

  • User
  • Posts: 1.047
    • http://www.klangruinen.de/
Kein X nach update
« Reply #14 on: 2010/09/27, 16:22:02 »
Quote
läuft wieder mit dem aktuellen Kernel (Linux 2.6.35-6.slh.1-aptosid-amd64 x86_64)

Wie? die pre von towo läuft mit dem aktuellen kernel?