seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2021/01/19, 03:03:18


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: perl-transition!!  (Read 2617 times)

0 Members and 1 Guest are viewing this topic.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.481
perl-transition!!
« on: 2011/11/13, 23:45:32 »
Bitte Vorsicht, eine perl-transition ist im Gange.
Code: [Select]
33 upgraded, 7 newly installed, 154 to remove and 2 not upgraded.


greetz
devil

Offline ralul

  • User
  • Posts: 1.809
perl-transition!!
« Reply #1 on: 2011/11/14, 17:25:25 »
Geht vielleicht einfacher, wenn man die Priorität auf testing setzt:
Code: [Select]

cd /etc/apt&&mkdir -p preferences.d&&echo -n -e 'Package: perl*\nPin: release a=testing\nPin-Priority: 603\n'>preferences.d/perlfromtesting

Irgendwann dann die Datei /etc/preferences.d/perlfromtesting
einfach mal löschen. Das merkt man spätestens, wenn testing ein perl upgrade bekommt.

Dieser Workaround geht davon aus, dass /etc/apt/preferences:
Code: [Select]
Package: *
Pin: release a=testing
Pin-Priority: 101

Package: *
Pin: release a=sid
Pin-Priority: 502

Package: *
Pin: release a=experimental
Pin-Priority: 103
experiencing siduction runs better than my gentoo makes me know I know nothing

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.481
perl-transition!!
« Reply #2 on: 2011/11/14, 17:40:19 »
Dieser Workaround ist ziemlich überflüssig. 2-3 Tage Füsse stillhalten wird ja wohl noch gehen. Wenn es wirklich sein muss, kann man 3 perl-Pakete auf hold setzen oder einach selektiv upgraden, was man braucht und hoffen, es ist nicht von der Transition betroffen.

greetz
devil

Offline ralul

  • User
  • Posts: 1.809
perl-transition!!
« Reply #3 on: 2011/11/14, 17:49:21 »
Der Workaround ist nicht überflüssig,
- wenn man ein System neu aufsetzen will
- wenn man ein DU auf einfache Weise braucht, weil man zusätzliche Software Pakete einspielen will.

Mein Workaround hat den Vorteil gegenüber hold, dass er
- auch mit aptitude funktioniert
- einfach ist
- einfach überspielt wird, wenn perl-5.14 soweit ist, weil es dann nach testing kommt.

Ich würde ja gerne, dass siduction als Distri für Debian sid viel Einsteiger freundlicher wird. Und in der Wartung viel weniger Aufmerksamkeit von unseren Benutzern erfordert. Dafür könnte man solche Prioritätensetzung per siduction-repo fix Paket anbieten...

Diese Transition perl-5.12 nach 5.14 brauchte bei Gentoo vor ein paar Monaten sehr lange bis perl wieder stabil war. Ich bin gespannt wie schnell es für Debian geht....
experiencing siduction runs better than my gentoo makes me know I know nothing

Offline sidlix

  • User
  • Posts: 110
perl-transition!!
« Reply #4 on: 2011/11/14, 22:10:18 »
Hm, schätze, dass passt dazu:

Code: [Select]

Die folgenden Pakete werden ENTFERNT:
  abiword anjuta anjuta-dbg apt-file aspell banshee banshee-extension-alarm
  banshee-extension-ampache banshee-extension-awn banshee-extension-clutterflow
  banshee-extension-coverwallpaper banshee-extension-jamendo banshee-extension-karaoke
  banshee-extension-lastfmfingerprint banshee-extension-lcd banshee-extension-liveradio
  banshee-extension-lyrics banshee-extension-magnatune banshee-extension-mirage
  banshee-extension-openvp banshee-extension-radiostationfetcher banshee-extension-randombylastfm
  banshee-extension-streamrecorder banshee-extension-telepathy
  banshee-extension-zeitgeistdataprovider banshee-extensions-common bluefish bluefish-plugins ceni
  chromium-codecs-ffmpeg claws-mail claws-mail-bogofilter claws-mail-doc claws-mail-html2-viewer
  claws-mail-i18n claws-mail-pgpinline claws-mail-pgpmime claws-mail-plugins
  claws-mail-smime-plugin claws-mail-spamassassin claws-mail-tools claws-mail-trayicon clawsker
  debconf-i18n dictionaries-common digikam digikam-doc dmakms empathy eog epiphany-browser
  epiphany-extensions evolution evolution-plugins geany-plugin-spellcheck geany-plugin-vc
  geany-plugin-webhelper geany-plugins gimp gimp-gutenprint gimp-texturize gimp-ufraw
  gir1.2-epiphany-2.29 gir1.2-javascriptcoregtk-1.0 gir1.2-peas-1.0 gir1.2-webkit-1.0
  gnumeric-plugins-extra gtkam-gimp gtkorphan guake gwenview hpijs hplip-cups hyphen-de
  hyphen-en-us inkscape intltool irssi k9copy kdebase-runtime kdelibs5-plugins kdepim-runtime
  khelpcenter4 kmail libabiword-2.8 libabiword-2.9 libapt-pkg-perl libaudio-scrobbler-perl
  libcairo-perl libcurses-perl libcurses-ui-perl libdevhelp-3-0 libdigest-sha1-perl libenchant-dev
  libenchant1c2a libevolution libexpect-perl libglib-perl libgtk2-gladexml-perl libgtk2-perl
  libgtkhtml-4.0-0 libgtkhtml-4.0-dev libgtkhtml-editor-3.14-0 libgtkhtml-editor-3.14-dev
  libgtkhtml-editor-4.0-0 libgtkhtml-editor-4.0-dev libgtkhtml3.14-19 libgtkhtml3.14-dev
  libgtkspell0 libhpmud0 libhtml-parser-perl libhtml-tree-perl libhttp-cookies-perl
  libhttp-message-perl libhttp-negotiate-perl libio-pty-perl libio-socket-ssl-perl libkdepim4
  liblist-moreutils-perl liblocale-gettext-perl liblwp-protocol-https-perl libmessagelist4
  libnet-dns-perl libnet-ssleay-perl libnetaddr-ip-perl libpango-perl libpeas-1.0-0 libperl5.12
  libproc-processtable-perl libpurple0 libseed-gtk3-0 libseed0 libsexy2 libsnmp15 libsocket6-perl
  libterm-readkey-perl libtext-charwidth-perl libtext-iconv-perl libtext-wrapi18n-perl libtotem0
  libwebkit-1.0-2 libwebkitgtk-1.0-0 libwebkitgtk-3.0-0 libwww-perl libxml-parser-perl libyelp0
  lyx metacity midori module-assistant myspell-de-de myspell-en-us notification-daemon-xfce
  nvidia-cg-toolkit pidgin pidgin-audacious pidgin-awayonlock pidgin-encryption pidgin-extprefs
  pidgin-festival pidgin-hotkeys pidgin-plugin-pack pidgin-privacy-please pidgin-sipe pidgin-skype
  pidgin-themes pidgin-twitter shotwell siduxcc siduxcc-gtk2 spamassassin telepathy-haze totem
  totem-mozilla totem-xine xchat yelp zenity


Also, Füße stillhalten...., oder??

Grüße aus dem Deltaquadranten.....
s i d l i x
... .. -.. .-.. .. -..-
debian s i d +  nee l i x

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.481
perl-transition!!
« Reply #5 on: 2011/11/14, 22:29:01 »
so ist es

greetz
devil

Offline ralul

  • User
  • Posts: 1.809
perl-transition!!
« Reply #6 on: 2011/11/15, 11:09:52 »
Uuih, das ging schnell. Wenn man auf ein paar Perl-Modul Pakete verzichtet, die für Gnome2 wichtig sind, kann man perl-5.14.2 installieren.

Aber man muss auch verzichten auf:
module-assistent
debconf-i18n
Was vielleicht nicht so eine gute Idee ist ...

PS: Wenn perl-5.14.2 jetzt, dann muss man meine oben genannte Prioritätensetzung wieder löschen (wenn man sie verwendet hat), weil perl-5.14 in unstable und noch nicht in testing ist.
experiencing siduction runs better than my gentoo makes me know I know nothing

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.481
perl-transition!!
« Reply #7 on: 2011/11/15, 11:19:24 »
Von gestern noch 150 zu entfernenden Paketen sind heute nur noch 15 zu entfernen. Es geht voran: http://release.debian.org/transitions/html/perl5.14.html

greetz
devil

Offline ralul

  • User
  • Posts: 1.809
perl-transition!!
« Reply #8 on: 2011/11/15, 12:00:39 »
@devil, weisst Du was über debconf-i18n?
- Heisst die neuere Sprachanpassung nicht heute l10n ?
- Brauch man debconf-18n fürs Deutsche. (Ich würde gerne auf deutsche man verzichten)

Für Gnomeler: Werden die Gnome2 perl module angepasst, oder wird gleich auf Gnome3 umgestiegen. Ich hatte die Tage zuvor gesehen, dass Gnome3 voranschreitet ....
experiencing siduction runs better than my gentoo makes me know I know nothing

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.481
perl-transition!!
« Reply #9 on: 2011/11/15, 13:28:40 »
debconf-18n ist die generelle Sprachunterstützung zur Internationalisierung von debconf. Das will man behalten. Warum das noch nicht an l10n angepasst ist, weiss ich nicht.

greetz
devil

Offline reddark

  • User
  • Posts: 1.047
    • http://www.klangruinen.de/
perl-transition!!
« Reply #10 on: 2011/11/16, 14:12:54 »
perl-transition scheint sich erledigt zu haben .. zumindest bei mir lief DU durch ohne das was entfernt werden sollte ...

Offline ralul

  • User
  • Posts: 1.809
perl-transition!!
« Reply #11 on: 2011/11/16, 14:17:01 »
Jo, debconf-i18n geht, alles ist jetzt perlapi-5.14.2.
Ging ja rasend schnell!
experiencing siduction runs better than my gentoo makes me know I know nothing

Offline hefee

  • User
  • Posts: 392
RE: perl-transition!!
« Reply #12 on: 2011/11/16, 14:27:44 »
Das einzige Paket was bei mir entfernt wird ist: libperl5.12 - aber das sollte ja ok sein :)

Offline reddark

  • User
  • Posts: 1.047
    • http://www.klangruinen.de/
RE: perl-transition!!
« Reply #13 on: 2011/11/16, 14:34:53 »
ja, wird duch 5.14. ersetzt ;)