Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] ldap-client  (Read 4111 times)

wenger

  • Guest
[DE] ldap-client
« on: 2010/10/06, 10:16:52 »
Ich benutze seit 2 Jahren Sidux und jetzt aptosid als clients an der Linuxmusterserver des Landes BW lml  beruht auf Debian. Bis jetzt völlig problemlos. Jetzt wurde in einem update der Server von ldap auf slapd umgestellt und der passworthash steht auf crypt. Dadurch kann sich keiner mehr an einem Client anmelden. Da der ldap-client irgendwie das Passwort nicht mehr lesen kann. Bis jetzt konnte ich mit libnss-ldap und libpam-ldap und einfügen des ldaps in die nsswitch.conf alles lösen aber dies geht jetzt nicht mehr. Das Land bietet eine Lösung an mit einem packet aber das funktioniert nicht in aptosid. die installation bricht ab mit der Meldung, dass dies Version nicht unterstützt wird.
Ich brauche eine Lösung recht dringend, da die user jetzt schon ein paar Tage nicht mehr in die Clients kommen.
Peter

Offline bluelupo

  • User
  • Posts: 2.068
    • BluelupoMe
ldap-client
« Reply #1 on: 2010/10/06, 11:08:59 »
Hi wenger,
erst mal herzlich Willkommen hier im deutschen aptosid Forum. Um dir helfen zu können brauchen wir Infos zu deinen Problem, z.B. genaue Fehlermeldung, welche Pakete von welcher Quelle hast du installiert?

Bitte möglichst genau den Fehler beschreiben. Danke!

wenger

  • Guest
ldap-client
« Reply #2 on: 2010/10/06, 11:38:30 »
Also da ist leider weng zu sagen.
Der Server wurde von ldap auf slapd upgedatet.
auf den clients ist installiert:
libnss-ldap libnet-ldap-perl libpam-ldap nscd

und in der Datei /etc/nsswitch wurden die zeilen passwd und group und shadow mit ldap ergänzt.
dies lief 2 Jahre völlig problemlos.
Nach dem Update auf dem server auf slapd
alle user werden per ldap verteilt und sind in kdm und auch mit ldapsearch sichtbar, aber die passwörter werden nicht mehr erkannt. (login incorrect) Auch die homeverzeichnisse welche per NFS4 verteilt werden, sind alle korrekt da. Es sind also die passwörter vom server verschlüsselt worden und ich weiss nicht wie ich das an den Clients einstelle.
Andere Meldungen habe ich leider nicht.
Peter

Offline bluelupo

  • User
  • Posts: 2.068
    • BluelupoMe
ldap-client
« Reply #3 on: 2010/10/06, 12:37:43 »
Hi Peter,
sind auf dem LDAP-Server bzw. an den Clients in der /var/log/auth.log Fehlermeldungen? Vielleicht gibt's auch ein spezielles Logfile für SLDAP, du musst mal unter /var/log nachsehen.

wenger

  • Guest
ldap-client
« Reply #4 on: 2010/10/06, 12:48:33 »
Also auf einem Client finde ich in der auth.log:

Oct  5 19:55:44 siduxbox nscd: nss_ldap: reconnected to LDAP server ldap://10.16.1.1 after 1 attempt
Oct  5 19:55:44 siduxbox rpc.idmapd[1477]: nss_ldap: reconnecting to LDAP server...
Oct  5 19:55:44 siduxbox rpc.idmapd[1477]: nss_ldap: reconnected to LDAP server ldap://10.16.1.1 after 1 attempt
Oct  5 19:55:47 siduxbox kdm: :0[3110]: pam_unix(kdm:auth): authentication failure; logname= uid=0 euid=0 tty=:0 ruser= rhost=  user=wengpe
Oct  5 19:56:48 siduxbox kdm: :0[2132]: pam_unix(kdm:auth): authentication failure; logname= uid=0 euid=0 tty=:0 ruser= rhost=  user=wengpe
Oct  5 19:56:56 siduxbox kdm: :0[2132]: pam_unix(kdm:session): session opened for user root by (uid=0)

Offline bluelupo

  • User
  • Posts: 2.068
    • BluelupoMe
ldap-client
« Reply #5 on: 2010/10/06, 13:14:41 »
Hi Peter,
hmm, da läuft was schief :-(
Ich bin leider kein LDAP Spezialist aber da scheint vermutlich an der Konfiguration etwas nicht zu passen (beim PAM-Modul).

Frag doch mal im IRC-Kanal #frickelplatz nach, vielleicht befindet sich dort ein LDAP-Profi ;-)

grefabu

  • Guest
ldap-client
« Reply #6 on: 2010/10/06, 14:56:47 »
Ich benutze das mysql_pam modul.
In der DB steht das Passwort als MD5.

Da muss ich in die entsprechende Zeile der pam-Datei noch crypt=3 eintragen.

Evtl. fehlt ähnliches bei Dir?