seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/12/01, 04:12:29


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: foreign characters with accents not displaying in newsbeuter  (Read 2704 times)

0 Members and 1 Guest are viewing this topic.

Offline catalinsb

  • User
  • Posts: 10
Hello.

Actually I have more problems.

1. Foreign characters with accents are not displaying in newsbeuter. Instead I got a "?" (French, Romanian, Russian characters like âîșțé, u.s.w.)
2. Same behavior in gmail opened from midori or iceweasel;
3. Fonts on certain sites (like gmail) are displaying very small;
(4. the local time was not set properly, but I managed this with dpkg-reconfigure tzdata, so this is no more a problem);
(5. in pcmanfm the files are not sorted even if I try to manually sort them, but I don't care much about this, I tend to use mc and tuxcmd).

I checked the installed fonts, I have droid, freefont, liberation, openoffice, ttf-dejavu.

I am using siduction lxde.

Offline coruja

  • User
  • Posts: 74
RE: foreign characters with accents not displaying in newsbe
« Reply #1 on: 2012/01/04, 20:27:50 »
Hi catalinsb! :)

Could you please give us some more details about booting the live media (especially which language and time zone you chose) and installing (if any strange incidents happened)? I have no clue yet, but it seems that there even several things went wrong, so we need more information.

Concerning the pcmanfm issue (5.), have you tried to sort files by something other than name and then switched back to sorting by name?

Offline catalinsb

  • User
  • Posts: 10
RE: foreign characters with accents not displaying in newsbe
« Reply #2 on: 2012/01/04, 22:22:15 »
Hi!

Sure. When booting the live media I haven't chose any language or time zone, I let the defaults. When installing I set the location to Bucharest (I was expecting to set automatically my local timezone). I haven't noticed any incident.

The problem with pcmanfm seems to be gone, but sorry I have no idea what happened, now the items are displayed alphabetically.

I was wondering, maybe there is a command to reinitialize the fonts?

I also tried dpkg-reconfigure locales, but this didn't solved my problem with the fonts.

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.452
RE: foreign characters with accents not displaying in newsbe
« Reply #3 on: 2012/01/04, 22:30:52 »
what does the command locale output?

greetz
devil

Offline catalinsb

  • User
  • Posts: 10
foreign characters with accents not displaying in newsbeuter
« Reply #4 on: 2012/01/04, 22:36:19 »
Code: [Select]
$ locale
LANG=
LANGUAGE=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=


Something is really wrong, isn't it?

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.452
foreign characters with accents not displaying in newsbeuter
« Reply #5 on: 2012/01/04, 22:45:58 »
yep, seems like no locale set at all.
dpkg-reconfigure locale, where you set your default, should fix that. Does locale still output the same as above after that?

greetz
devil

Offline catalinsb

  • User
  • Posts: 10
foreign characters with accents not displaying in newsbeuter
« Reply #6 on: 2012/01/04, 23:24:01 »
Many thanks, devil!

dpkg-reconfigure locales, setting en_US.UTF-8 as default language for entire system (previously I had no default language) (and also selecting some ISO-8859-* for Russian and Romanian, but not sure if this counts) solved my problem with characters displayed in newsbeuter.

Code: [Select]
$ locale
LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=