seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/11/27, 04:20:28


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: NTFS3G  (Read 4210 times)

0 Members and 1 Guest are viewing this topic.

Offline Taliesin

  • User
  • Posts: 67
NTFS3G
« on: 2012/04/01, 10:39:07 »
Firstly is it legal to post questions about NTFS3G?

Secondly, if so is it possible to enable write access?

If not please feel free to moderate this post accordingly.

Offline ayla

  • User
  • Posts: 1.706
NTFS3G
« Reply #1 on: 2012/04/01, 10:52:38 »
Hi Taliesin,

found this in the arch wiki:

Quote
Configuring

Your NTFS partition(s) can be setup to mount automatically, or pre-configured to be able to mount in a certain way when you would like them to be mounted. This configuration can be done in the static filesystem configuration (fstab) or by the use of udev rules.
Default settings

Using the default settings will mount the NTFS partition(s) at boot. With this method, if the parent folder that it is mounted upon has the proper user or group permissions, then that user or group will be able to read and write on that partition(s).

Put this in /etc/fstab:

# <file>   <dir>      <type>    <options>             <dump>  <pass>
/dev/<NTFS>  /mnt/windows  ntfs-3g   defaults        0       0

Allowing Group/User

You can also tell /etc/fstab (the NTFS-3G driver) other options like those who are allowed to access (read) the partition. For example, for you to allow people in the users group to have access:

/dev/<NTFS>  /mnt/windows  ntfs-3g   gid=users,umask=0022    0       0

By default, the ntfs-3g driver enable write support for root only. To enable user writing, use the dmask parameter to enable user writing:

/dev/<NTFS>  /mnt/windows  ntfs-3g   gid=users,fmask=113,dmask=002    0       0

If you are running on a single user machine, you may like to own the file system yourself:

/dev/<NTFS>  /mnt/windows  ntfs-3g   uid=USERNAME,gid=users    0       0

Basic NTFS-3G options

For most, the above settings should suffice. Here are a few other options that are general common options for various Linux filesystems. For a complete list, see this

umask
    umask is a built-in shell command which automatically sets file permissions on newly created files. For Arch Linux, the default umask for root and user is 0022. With 0022 new folders have the directory permissions of 755 and new files have permissions of 644. You can read more about umask permissions here.
noauto
    If noauto is set, NTFS entries in /etc/fstab do not get mounted automatically at boot.
uid
    The user id number. This allows a specific user to have full access to the partition. Your uid can be found with the id command.
fmask and dmask
    Like umask but defining file and directory respectively individually.


hth
ayla

EDIT: testet with this line in /etc/fstab:
Quote
/dev/sdb1  /mnt/windows  ntfs-3g   gid=users,fmask=113,dmask=002    0       0

-and a created folder "windows" in /mnt of course-
works.
Kernel: 4.18.11-towo.1-siduction-amd64 x86_64
Desktop: KDE Plasma 5.13.5
(mostly) kept current siduction "18.3.0 Patience"
HP EliteBook 8570p; MoBo: HP model: 17A7 v: KBC Version 42.35
Dual core  i5-3320M (-MT-MCP-)
Intel 3. Gen Graphics (Ivybridge) Driver:i915/ intel
 Wifi Intel Centrino N6205

Offline towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.415
NTFS3G
« Reply #2 on: 2012/04/01, 11:48:02 »
Code: [Select]

towo:Defiant> ls -ld /sbin/mount.ntfs
lrwxrwxrwx 1 root root 13 Mär  5 02:04 /sbin/mount.ntfs -> mount.ntfs-3g

So a special entry with ntfs-3g is not needed in fstab.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline ayla

  • User
  • Posts: 1.706
NTFS3G
« Reply #3 on: 2012/04/01, 13:15:55 »
you're right towo, but then root-password is needed to mount.
Kernel: 4.18.11-towo.1-siduction-amd64 x86_64
Desktop: KDE Plasma 5.13.5
(mostly) kept current siduction "18.3.0 Patience"
HP EliteBook 8570p; MoBo: HP model: 17A7 v: KBC Version 42.35
Dual core  i5-3320M (-MT-MCP-)
Intel 3. Gen Graphics (Ivybridge) Driver:i915/ intel
 Wifi Intel Centrino N6205

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.787
  • we are the priests ... of the temples of syrinx
NTFS3G
« Reply #4 on: 2012/04/01, 20:08:50 »
I have zero problems with (in fstab)

Code: [Select]
UUID=78710D782AD1A7D3   /media/disk1part1 ntfs-3g defaults,auto,users,locale=en_US.UTF-8  0 0

can read and write and do whatever (no password needed)
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck

Offline Geier0815

  • User
  • Posts: 496
NTFS3G
« Reply #5 on: 2012/04/02, 10:02:38 »
@ayla,
please check the rights of the folder you mount your windows-partition on. If it is writeable for your users, there should be no problem with only "ntfs-3g defaults" or "ntfs defaults". Same for you piper. I've never had trouble without "users, auto or any other entries"
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Offline ralul

  • User
  • Posts: 1.809
NTFS3G
« Reply #6 on: 2012/04/02, 13:19:55 »
Doesn't it depend on the Ms-Win Version if you need password or not?
experiencing siduction runs better than my gentoo makes me know I know nothing

Offline ayla

  • User
  • Posts: 1.706
NTFS3G
« Reply #7 on: 2012/04/02, 19:28:16 »
@Geier0815

ahmm, that will get a little difficult to tell in englisch, but I'll try, so: sorry for maybe incompletions or so.

The "folder" I mounted when I was asked for the root-password was the one the system has given.
Which shows "55GB harddisk" in Dolphin. Or /media/disk2part1 when mounted.
The only way I know to mount it at boot-time with user rights is a corresponding line in /etc/fstab which may look like the one piper or I posted -where pipers, of course, is the simpler one and so to prefer.

AFAIK at least "users" needs to be given their.

So I guess I don't get it what you (or towo) mean, would you kindly give an example?

Greets
ayla
Kernel: 4.18.11-towo.1-siduction-amd64 x86_64
Desktop: KDE Plasma 5.13.5
(mostly) kept current siduction "18.3.0 Patience"
HP EliteBook 8570p; MoBo: HP model: 17A7 v: KBC Version 42.35
Dual core  i5-3320M (-MT-MCP-)
Intel 3. Gen Graphics (Ivybridge) Driver:i915/ intel
 Wifi Intel Centrino N6205

Offline Geier0815

  • User
  • Posts: 496
NTFS3G
« Reply #8 on: 2012/04/03, 11:55:05 »
towo show you that if you use ntfs (in fstab or mount-command) it will be internal point to ntfs-3g so that the entries "ntfs" and "ntfs-3g" are the same.

My point was that if you mount your windows-partition (within the fstab) on an folder with 777-rights or 75something and owner-group "users" you don't need to give the options. "defaults" should include "auto" and "users".
But I think you want to use KDE or other DM tools for mounting without an fstab-entry? Hope that it's not a misunderstanding... For this an other helper must have a look.

@ralul,
that's possible. I only use XP-Partitions so I can't check this out.
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Offline ayla

  • User
  • Posts: 1.706
NTFS3G
« Reply #9 on: 2012/04/03, 18:52:28 »
Think I got it now.

Thanks for explaining.

Greets
ayla
Kernel: 4.18.11-towo.1-siduction-amd64 x86_64
Desktop: KDE Plasma 5.13.5
(mostly) kept current siduction "18.3.0 Patience"
HP EliteBook 8570p; MoBo: HP model: 17A7 v: KBC Version 42.35
Dual core  i5-3320M (-MT-MCP-)
Intel 3. Gen Graphics (Ivybridge) Driver:i915/ intel
 Wifi Intel Centrino N6205

Offline piper

  • Global Moderator
  • User
  • *****
  • Posts: 1.787
  • we are the priests ... of the temples of syrinx
NTFS3G
« Reply #10 on: 2012/04/07, 14:44:05 »
ntfs-3g defaults

has not worked with debian, aptosid, nor siduction on my network, why I use what I wrote above, it just works and well .... YMMV
Free speech isn't just fucking saying what you want to say, it's also hearing what you don't want to fucking hear

I either give too many fucks or no fucks at all, it's like I cannot find a middle ground for a moderate fuck distribution, it's like what the fuck