Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [EN] (solved)how to get work a scanner with firewire?  (Read 4290 times)

Offline dieres

  • User
  • Posts: 787
[EN] (solved)how to get work a scanner with firewire?
« on: 2012/05/09, 07:42:59 »
my epson perfection 2450 photo is connected with firewire.

from /var/log/messages:
Code: [Select]

May  9 07:31:50 amd64box kernel: [  457.256193] firewire_core: phy config: card 0, new root=ffc1, gap_count=5
May  9 07:31:53 amd64box kernel: [  460.265709] scsi11 : SBP-2 IEEE-1394
May  9 07:31:53 amd64box kernel: [  460.265918] firewire_sbp2: fw1.0: 127s mgt_ORB_timeout limited to 40s
May  9 07:31:53 amd64box kernel: [  460.265935] firewire_core: created device fw1: GUID 00004800001c52e2, S400, 1 config ROM retries
May  9 07:31:54 amd64box kernel: [  460.467730] firewire_sbp2: fw1.0: logged in to LUN 0000 (0 retries)
May  9 07:31:54 amd64box kernel: [  460.474588] scsi 11:0:0:0: Processor          EPSON    GT-9700          1.05 PQ: 0 ANSI: 4


sane-find-scanner:


Code: [Select]
# sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.
  # Also you need support for SCSI Generic (sg) in your operating system.
  # If using Linux, try "modprobe sg".

found USB scanner (vendor=0x0cf3, product=0x1002) at libusb:003:003
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

  # You may want to run this program as root to find all devices. Once you
  # found the scanner devices, be sure to adjust access permissions as
  # necessary.


vendor=0x0cf3, product=0x1002 is my tp-link wireless nic!

scanimage -L:
Code: [Select]
device `hpaio:/net/Officejet_Pro_8500_A910?ip=192.168.3.223' is a Hewlett-Packard Officejet_Pro_8500_A910 all-in-one


who can help me to get my epson working?

Offline hendrikL

  • Administrator
  • User
  • *****
  • Gravatar
  • Posts: 986
how to get work a scanner with firewire?
« Reply #1 on: 2012/06/19, 16:05:10 »
well maybe you need an external driver:
http://www.sane-project.org/lists/sane-backends-external.html

Your scanner is listed to be fully supported.

Above the epson table is a link too:
http://avasys.jp/eng/linux_driver/

For the installation of the driver you have to search by your own.
I did not have a firewire scanner, but maybe it helps.

greetz hendrikL

Offline dieres

  • User
  • Posts: 787
(solved)how to get work a scanner with firewire?
« Reply #2 on: 2012/06/19, 20:07:52 »
modprobe sg was the solution of this problem.

I've put the line "sg" in /etc/modules and everything is alright now.

But I think normally the module sg should load automatically.
Is this a bug? I don't know.