seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/12/01, 04:24:45


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: [Solved] Forum language settings  (Read 4287 times)

0 Members and 1 Guest are viewing this topic.

Offline timc

  • User
  • Posts: 203
[Solved] Forum language settings
« on: 2012/05/29, 22:51:41 »
I am not sure which subforum to post this in, so I am putting it in Free Speech.

When I visit the Siduction Forum from Ubuntu with Firefox, everything is in English. However, when I visit it from Siduction with Midori, I can see the content of the posts in English, but all the command bittons, settings choices, headings, page titles, etc., are in German. E.g., The screen I am on now is titled "Nues Thema schreiben".

When I click on "Sprache auswahlen - Englisch", it just takes me back to the main page and still does not change things to English.

Is there some option I can set to have these things displayed in English from Siduction with Midori? Thank you.

Tim
Gigabyte Z68A-D3-B3, Intel i5-2500K, 8 GB DDR3, 2-Seagate SATA III RAID-0 btrfs, ATI HD6770, Samsung BX2440

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.059
    • Land of the Buckeye
RE: Forum language settings
« Reply #1 on: 2012/05/30, 00:02:45 »
On the gray menu on the left side of the web page, near the bottom is an item named "Choose a Language", and the choice is English and German.  So you click one .....

;-)
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline timc

  • User
  • Posts: 203
RE: Forum language settings
« Reply #2 on: 2012/05/30, 01:10:03 »
Yes, I have clicked that many times, as I said in the OP. It takes me back to the Siduction home page, but does not change the settings. But, I will click it again, now, and let you know whether anything different occurs.

Tim
Gigabyte Z68A-D3-B3, Intel i5-2500K, 8 GB DDR3, 2-Seagate SATA III RAID-0 btrfs, ATI HD6770, Samsung BX2440

Offline timc

  • User
  • Posts: 203
RE: Forum language settings
« Reply #3 on: 2012/05/30, 01:12:33 »
Same result as before. It sent me to the home page, and when I clicked the Forum link, all the language is still German, except the post contents.
Gigabyte Z68A-D3-B3, Intel i5-2500K, 8 GB DDR3, 2-Seagate SATA III RAID-0 btrfs, ATI HD6770, Samsung BX2440

Offline dibl

  • siduction community member
  • Global Moderator
  • User
  • *****
  • Posts: 2.059
    • Land of the Buckeye
Re: Forum language settings
« Reply #4 on: 2012/05/30, 02:44:58 »
Quote from: "timc"

When I visit the Siduction Forum from Ubuntu with Firefox ...


I don't know whether it makes a difference, but ...

I visit the siduction forum from siduction, with chromium-browser, and the English side is clear and in English.
Asus ROG STRIX X299-E, Core i7-7740X, Nvidia GTX-1060, dual monitors, SSD 860 EVO, 2@WD1003FZEX in BTRFS

Offline ayla

  • User
  • Posts: 1.706
[Solved] Forum language settings
« Reply #5 on: 2012/05/30, 09:29:08 »
Hello,

I can confirm this behaviuor with iceweasel and kde. Iceweasel evrytime leads to the german page.
When I tried with the standard browser in razor-qt evrything works as it should.

greets
ayla
Kernel: 4.18.11-towo.1-siduction-amd64 x86_64
Desktop: KDE Plasma 5.13.5
(mostly) kept current siduction "18.3.0 Patience"
HP EliteBook 8570p; MoBo: HP model: 17A7 v: KBC Version 42.35
Dual core  i5-3320M (-MT-MCP-)
Intel 3. Gen Graphics (Ivybridge) Driver:i915/ intel
 Wifi Intel Centrino N6205

Offline der_bud

  • User
  • Posts: 958
  • member
[Solved] Forum language settings
« Reply #6 on: 2012/05/30, 12:45:04 »
Some browsers use "preferred languages" and "default languages", and some try to recognize the lang of a page by themselves. It can happen (if preferred language is not set or the liveuser profile has some values) that a wrong (for you) language is always shown, not regarding your choice from the menu left from the forum.

- Booting Razor-QT Testrelease, lang set to en:
  qupzilla has language en_US and shows this forum/menu/buttons completely english

- Booting Razor-QT Testrelease, lang set to de:
  qupzilla has language de_De and shows this forum/menu/buttons completely german

- Booting Desperado LXDE lang set to en:
  midori has language en_US BUT(!) shows this forum/menu/buttons completely german (!)

- Booting Desperado LXDE lang set to de:
  midori has language de_DE and shows this forum/menu/buttons completely german

- Iceweasel here behaves like qupzilla, showing right forum language according to browser-settings.

Seems to be an issue with combination of midori+zikula+languagedetection. Try to play around with the settings of your browser or test another one.
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline timc

  • User
  • Posts: 203
[Solved] Forum language settings
« Reply #7 on: 2012/05/30, 14:13:58 »
Thank you, ayla and der_bud. I had already decided that the problem is the Midori browser. I will try some others.

Tim
Gigabyte Z68A-D3-B3, Intel i5-2500K, 8 GB DDR3, 2-Seagate SATA III RAID-0 btrfs, ATI HD6770, Samsung BX2440

Offline der_bud

  • User
  • Posts: 958
  • member
set midori to en
« Reply #8 on: 2012/05/30, 14:19:20 »
Just tried:
Midori Preferences, Tab Behaviour, Field Preferred languages was originally "en_US.UTF8,en_US,en".
Changed sequence to "en,en_US,en_US.UTF8" (note single en first) and restart browser shows forum in english.
Du lachst? Wieso lachst du? Das ist doch oft so, Leute lachen erst und dann sind sie tot.

Offline timc

  • User
  • Posts: 203
RE: set midori to en
« Reply #9 on: 2012/05/30, 18:58:23 »
Ah, good work, der_bud. Thank you.

I installed iceweasel and it shows everything in English, too.

Tim

PS - I tried your way in Midori and that works, too. Although, for the life of me I cannot know how you figured it out. Thank you, again.
Gigabyte Z68A-D3-B3, Intel i5-2500K, 8 GB DDR3, 2-Seagate SATA III RAID-0 btrfs, ATI HD6770, Samsung BX2440