seduction
 Language:
Welcome, Guest. Please login or register.
Did you miss your activation email?
2020/11/30, 11:54:10


Help

Author [EN] [PL] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Probleme mit mysql-server  (Read 11110 times)

0 Members and 1 Guest are viewing this topic.

Offline harley-peter

  • User
  • Posts: 848
Probleme mit mysql-server
« on: 2012/05/30, 11:24:54 »
Hallo,

das heutige du ergibt auf meinem Laptop ein Problem mit dem Paket mysql-server-core-5.5:
Code: [Select]
Die folgenden Pakete werden aktualisiert (Upgrade):
  mysql-server-5.5
1 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
2 nicht vollständig installiert oder entfernt.
Es müssen noch 0 B von 8.988 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 903 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren [J/n]? j
dpkg-preconfigure: kann Stdin nicht wieder öffnen: Datei oder Verzeichnis nicht gefunden
(Lese Datenbank ... 253043 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Ersetzen von mysql-server-5.5 5.5.23-2 (durch .../mysql-server-5.5_5.5.23+dfsg-2_amd64.deb) ...
/lib/lsb/init-functions: Zeile 428: FANCYTTY ist nicht gesetzt.
invoke-rc.d: initscript mysql, action "stop" failed.
dpkg: Warnung: Unterprozess altes pre-removal-Skript gab den Fehlerwert 1 zurück
dpkg - stattdessen wird Skript aus dem neuen Paket probiert ...
/lib/lsb/init-functions: Zeile 428: FANCYTTY ist nicht gesetzt.
invoke-rc.d: initscript mysql, action "stop" failed.
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/mysql-server-5.5_5.5.23+dfsg-2_amd64.deb (--unpack):
 Unterprozess neues pre-removal-Skript gab den Fehlerwert 1 zurück
/lib/lsb/init-functions: Zeile 428: FANCYTTY ist nicht gesetzt.
invoke-rc.d: initscript mysql, action "stop" failed.
/lib/lsb/init-functions: Zeile 428: FANCYTTY ist nicht gesetzt.
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: Fehler beim Aufräumen:
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/mysql-server-5.5_5.5.23+dfsg-2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ein dpkg --configure ergab:
Code: [Select]
root@laptop:/home/peter# dpkg --configure -a
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von mysql-server-5.5:
 mysql-server-5.5 hängt ab von mysql-server-core-5.5 (= 5.5.23-2); aber:
  Version von mysql-server-core-5.5 auf dem System ist 5.5.23+dfsg-2.
dpkg: Fehler beim Bearbeiten von mysql-server-5.5 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von mysql-server:
 mysql-server hängt ab von mysql-server-5.5; aber:
  Paket mysql-server-5.5 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von mysql-server (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 mysql-server-5.5
 mysql-server

Meine Konfiguration:
Code: [Select]
root@laptop:/home/peter# inxi -v3
System:    Host: laptop Kernel: 3.4-0.towo.4-siduction-amd64 x86_64 (64 bit, gcc: 4.7.0)
           Desktop: Xfce 4.8.3 (Gtk 2.24.9) Distro: sidux 2009-02 Αιθήρ - xfce - (200907141521)
Machine:   System: TOSHIBA product: Satellite A210 version: PSAFGE-06500RGR serial: 18045297Q
           Mobo: ATI model: SB600 version: Rev 1 Bios: Phoenix version: 1.70 date: 02/22/2008
CPU:       Dual core AMD Athlon 64 X2 TK-57 (-MCP-) cache: 512 KB flags: (lm nx sse sse2 sse3 svm) bmips: 6384.66
           Clock Speeds: 1: 1600.00 MHz 2: 1600.00 MHz
Graphics:  Card: Advanced Micro Devices [AMD] nee ATI RS690M [Radeon X1200 Series] bus-ID: 01:05.0
           X.org: 1.12.1.902 driver: radeon tty size: 125x36 Advanced Data: N/A for root
Network:   Card-1: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller
           driver: r8169 ver: 2.3LK-NAPI port: a000 bus-ID: 08:00.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: 00:a0:d1:96:7a:05
           Card-2: Realtek RTL8187B Wireless Adapter driver: rtl8187 usb-ID: 0bda:8197
           IF: wlan0 state: up mac: 00:16:44:8f:44:1d
Drives:    HDD Total Size: 160.0GB (44.1% used) 1: model: TOSHIBA_MK1646GS
Info:      Processes: 144 Uptime: 3 min Memory: 553.4/1881.3MB Runlevel: 5 Gcc sys: 4.7.0 Client: Shell inxi: 1.8.4

Kann mir da jemand einen Tip geben?

Gruß
Peter

PS: ja ich weiß ... meine Distro lautet immer noch auf sidux ... und ich hatte immer noch keine Lust zu suchen wo das geändert werden kann ... :-)

Online towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.417
RE: Probleme mit mysql-server
« Reply #1 on: 2012/05/30, 12:18:36 »
echo 'FANCYTTY=1' >> /etc/default/rcS && apt-get -f install
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline harley-peter

  • User
  • Posts: 848
Probleme mit mysql-server
« Reply #2 on: 2012/05/30, 12:44:13 »
Hallo towo,

danke für die Info und den immer wieder super Support! Hat funktioniert.

Gruß
Peter

Thank's towo for the support.

Offline spacepenguin

  • User
  • Posts: 863
    • spacepenguin.de
Probleme mit mysql-server
« Reply #3 on: 2012/05/31, 04:12:32 »
Auch von mir dickes Danke!
Susan | Hardware: SysProfile
Music-Profile: http://www.last.fm/de/user/spacepengu

Offline susa2

  • User
  • Posts: 45
    • http://keine
Probleme mit mysql-server
« Reply #4 on: 2012/06/01, 15:27:43 »
ne, funzt immer noch nicht bei mir
Code: [Select]
   
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt-get -f install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 mysql-server-5.5 : Hängt ab von: mysql-server-core-5.5 (= 5.5.23-2) aber 5.5.23+dfsg-2 ist installiert
 supertuxkart : Hängt ab von: supertuxkart-data (= 0.7.3-1) ist aber nicht installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie, -f zu benutzen.
root@siduxbox:/home/mgtd# apt-get -f install
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.      
Statusinformationen werden eingelesen.... Fertig
Abhängigkeiten werden korrigiert ... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
  mysql-server mysql-server-5.5 supertuxkart-data
Die folgenden NEUEN Pakete werden installiert:

Online devil

  • Administrator
  • User
  • *****
  • Posts: 4.452
Probleme mit mysql-server
« Reply #5 on: 2012/06/01, 15:52:30 »
Weil Du ein anderes Problem hast?

greetz
devil

Offline susa2

  • User
  • Posts: 45
    • http://keine
Probleme mit mysql-server
« Reply #6 on: 2012/06/01, 19:24:32 »
jou, bestimmt devil, nur fragt sich blos welches...

Online devil

  • Administrator
  • User
  • *****
  • Posts: 4.452
Probleme mit mysql-server
« Reply #7 on: 2012/06/01, 22:43:44 »
apt-cache policy mysql-server-5.5
apt-cache policy mysql-server-core-5.5
bitte herzeigen

greetz
devil

Offline susa2

  • User
  • Posts: 45
    • http://keine
Probleme mit mysql-server
« Reply #8 on: 2012/06/04, 16:24:37 »
Code: [Select]
apt-cache policy mysql-server-5.5
mysql-server-5.5:
  Installiert:           5.5.23-2
  Installationskandidat: 5.5.23+dfsg-2
  Versionstabelle:
     5.5.23+dfsg-2 0
        500 http://ftp.us.debian.org/debian/ unstable/main i386 Packages
 *** 5.5.23-2 0
        100 /var/lib/dpkg/status
root@siduxbox:/home/mgtd# apt-cache policy mysql-server-core-5.5
mysql-server-core-5.5:
  Installiert:           5.5.23+dfsg-2
  Installationskandidat: 5.5.23+dfsg-2
  Versionstabelle:
 *** 5.5.23+dfsg-2 0
        500 http://ftp.us.debian.org/debian/ unstable/main i386 Packages
        100 /var/lib/dpkg/status

Hmm, ich brauch das glaub ich eh nicht, weiss nicht was man damit macht, wollte schon purgen, aber mit apt-cache depends bin ich niocht weiter gekommen...

Online devil

  • Administrator
  • User
  • *****
  • Posts: 4.452
Probleme mit mysql-server
« Reply #9 on: 2012/06/04, 16:55:02 »
mysql ist eine Datenbank, die z.B. von amarok oder KDE für Nepomuk und/oder akonadi verwendet wird. Einfach löschen ist nicht so clever, wenn man irgendwas von den obigen verwendet oder einen Homeserver betreibt.

Quote

aber mit apt-cache depends bin ich niocht weiter gekommen...

Was Du damit sagen willst, ist mir schleierhaft.

greetz
devil

Offline susa2

  • User
  • Posts: 45
    • http://keine
Probleme mit mysql-server
« Reply #10 on: 2012/06/04, 18:27:33 »
Quote from: "devil"

Was Du damit sagen willst, ist mir schleierhaft.

greetz
devil


genau deswegen, was da alles von abhängt, da die beiden nicht mal so eben zu purgen sind

Offline susa2

  • User
  • Posts: 45
    • http://keine
Probleme mit mysql-server
« Reply #11 on: 2012/06/04, 18:41:47 »
Meine Idee war nämlich, das zu purgen um endlich wieder eindistupgrade durchrauschen zu lassen und dann wieder die Pakete zu installieren.

Online towo

  • Global Moderator
  • User
  • *****
  • Posts: 2.417
Probleme mit mysql-server
« Reply #12 on: 2012/06/04, 19:35:13 »
Irgendwie fehlt mir in dem Post da oben die Ausgabe von apt-get -f install.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.

Offline Geier0815

  • User
  • Posts: 496
Probleme mit mysql-server
« Reply #13 on: 2012/06/04, 19:37:30 »
mysql-server-core ist schon auf der dfsg-version, muß nur noch der mysql-server auf diese Version. Ich kann leider nicht sehen woher die "nicht-dfsg" kommt. Ich persönlich würde ein "apt-get install --reinstall mysql-server -t unstable" versuchen. Danach sollten beide Versionen auf dfsg stehen und zusammen passen. Ob der Befehl so klappt, kann ich dir mangels Versuchsmöglichkeit nicht sagen. Danach läuft auch du wieder. Ansonsten poste die Ausgabe des Befehls.
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Offline susa2

  • User
  • Posts: 45
    • http://keine
Probleme mit mysql-server
« Reply #14 on: 2012/06/04, 19:56:52 »
Für towo

Code: [Select]
apt-get -f install
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.      
Statusinformationen werden eingelesen.... Fertig
Abhängigkeiten werden korrigiert ... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
  mysql-server mysql-server-5.5 supertuxkart supertuxkart-data
Die folgenden NEUEN Pakete werden installiert:
  supertuxkart-data
Die folgenden Pakete werden aktualisiert (Upgrade):
  mysql-server mysql-server-5.5 supertuxkart
3 aktualisiert, 1 neu installiert, 0 zu entfernen und 729 nicht aktualisiert.
5 nicht vollständig installiert oder entfernt.
Es müssen noch 109 MB von 118 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 156 MB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren [J/n]? j
Holen: 1 http://ftp.us.debian.org/debian/ unstable/main supertuxkart i386 0.7.3-2 [1.501 kB]
Holen: 2 http://ftp.us.debian.org/debian/ unstable/main supertuxkart-data all 0.7.3-2 [107 MB]
Es wurden 109 MB in 2 min 42 s geholt (669 kB/s).                                                              
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von mysql-server-5.5:
 mysql-server-5.5 hängt ab von mysql-server-core-5.5 (= 5.5.23-2); aber:
  Version von mysql-server-core-5.5 auf dem System ist 5.5.23+dfsg-2.
dpkg: Fehler beim Bearbeiten von mysql-server-5.5 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von mysql-server:
 mysql-server hängt ab von mysql-server-5.5; aber:
  Paket mysql-server-5.5 ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von mysql-server (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 mysql-server-5.5
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)



und für Geier0815

Code: [Select]
apt-get install --reinstall mysql-server -t unstable
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.      
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt-get -f install«, um dies zu korrigieren:
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 mysql-server-5.5 : Hängt ab von: mysql-server-core-5.5 (= 5.5.23-2) aber 5.5.23+dfsg-2 soll installiert werden
 supertuxkart : Hängt ab von: supertuxkart-data (= 0.7.3-1) soll aber nicht installiert werden
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt-get -f install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).


hmm, denk, ich glaub ich sollte doch mein sidux-aptosid-siduction-dingens runterschmeissen und gleich dad frische schöne neue siduction installieren. aber ich weiss nicht, ich weiss nicht....