Welcome, Guest. Please login or register.
Did you miss your activation email?

Author Topic: [DE] [gelöst] neuer Kernel - neues Prob mit Intel 852/855 GMA  (Read 4142 times)

Offline jp

  • User
  • Posts: 19
[DE] [gelöst] neuer Kernel - neues Prob mit Intel 852/855 GMA
« on: 2010/10/25, 11:49:22 »
Hi,

mit dem neuen Kernel 2.6.36 bootet mein grauhaariger Laptop mit Intel 82852/82855 GMA Chipsatz nicht mehr in KDE. Die früher funktionierenden cheatcodes "i915.modeset=0" und / oder "xmodule=vesa" bringen jetzt auch keine Besserung mehr. Ich vermute, dass es mit der KMS-Geschichte zu tun hat. Weiß irgendwer Abhilfe?

Danke

jp

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.846
neuer Kernel - neues Prob mit Intel 852/855 GMA
« Reply #1 on: 2010/10/25, 13:30:40 »
zeig mal bitte: /var/log/Xorg.0.log

greetz
devil

Offline jp

  • User
  • Posts: 19
[gelöst] neuer Kernel - neues Prob mit Intel 852/855 GMA
« Reply #2 on: 2010/10/25, 17:57:15 »
@ devil

Die schaut so aus.

edit: Den cheatcode "i915.modeset=0" musste ichsetzen, damit er überhaupt in die Konsole bootet, ohne jeden cheatcode gibt's nur einen blackscreen.

Quote
X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32.23-dsa-ia32 i686 Debian
Current Operating System: Linux laptop 2.6.36-0.slh.1-aptosid-686 #1 SMP PREEMPT Wed Oct 20 23:04:46 UTC 2010 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.36-0.slh.1-aptosid-686 root=UUID=86a12d2f-950b-4a18-94e6-09db5f031f84 ro vga=791 i915.modeset=0 quiet
Build Date: 10 October 2010  11:57:07AM
xorg-server 2:1.7.7-8 (Cyril Brulebois <kibi@debian.org>)
Current version of pixman: 0.16.4
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Oct 25 17:44:30 2010
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(==) No Layout section.  Using the first Screen section.
(==) No screen section available. Using defaults.
(**) |-->Screen "Default Screen Section" (0)
(**) |   |-->Monitor "<default monitor>"
(==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
   Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/Type1" does not exist.
   Entry deleted from font path.
(WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
   Entry deleted from font path.
(==) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/100dpi/:unscaled,
   /usr/share/fonts/X11/75dpi/:unscaled,
   /usr/share/fonts/X11/100dpi,
   /usr/share/fonts/X11/75dpi,
   built-ins
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
(II) Loader magic: 0x81ecca0
(II) Module ABI versions:
   X.Org ANSI C Emulation: 0.4
   X.Org Video Driver: 6.0
   X.Org XInput driver : 7.0
   X.Org Server Extension : 2.0
(++) using VT number 7

(--) PCI:*(0:0:2:0) 8086:3582:17c0:205b Intel Corporation 82852/855GM Integrated Graphics Device rev 2, Mem @ 0xe8000000/134217728, 0xe0000000/524288, I/O @ 0x00001800/8
(--) PCI: (0:0:2:1) 8086:3582:17c0:205b Intel Corporation 82852/855GM Integrated Graphics Device rev 2, Mem @ 0xf0000000/134217728, 0xe0080000/524288
(II) Open ACPI successful (/var/run/acpid.socket)
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension SELinux
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   ABI class: X.Org Server Extension, version 2.0
(==) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.13.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.1.0
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(==) Matched intel as autoconfigured driver 0
(==) Matched vesa as autoconfigured driver 1
(==) Matched fbdev as autoconfigured driver 2
(==) Assigned the driver to the xf86ConfigLayout
(II) LoadModule: "intel"
(II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
(II) Module intel: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 2.12.0
   Module class: X.Org Video Driver
   ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "vesa"
(II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
(II) Module vesa: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 2.3.0
   Module class: X.Org Video Driver
   ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "fbdev"
(II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
(II) Module fbdev: vendor="X.Org Foundation"
   compiled for 1.7.6.901, module version = 0.4.2
   ABI class: X.Org Video Driver, version 6.0
(II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
   i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
   E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
   965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
   4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
   Sandybridge, Sandybridge, Sandybridge, Sandybridge, Sandybridge,
   Sandybridge, Sandybridge
(II) VESA: driver for VESA chipsets: vesa
(II) FBDEV: driver for framebuffer: fbdev
(II) Primary Device is: PCI 00@00:02:0
(WW) Falling back to old probe method for vesa
(WW) Falling back to old probe method for fbdev
(II) Loading sub module "fbdevhw"
(II) LoadModule: "fbdevhw"
(II) Loading /usr/lib/xorg/modules/linux/libfbdevhw.so
(II) Module fbdevhw: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 0.0.2
   ABI class: X.Org Video Driver, version 6.0
(EE) intel(0): No kernel modesetting driver detected.
(II) UnloadModule: "intel"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.


Er scheint keinen ihm angenehmen Bildschirm zu finden.
Hilft das weiter?

mfg

jp

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.846
[gelöst] neuer Kernel - neues Prob mit Intel 852/855 GMA
« Reply #3 on: 2010/10/25, 19:53:24 »
Quote

(EE) intel(0): No kernel modesetting driver detected.
(II) UnloadModule: "intel"
(EE) Screen(s) found, but none have a usable configuration.

es wird kein modesetting treiber gefunden, deshalb entladen des intel treibers. dann is natürlich duster.
demnach müsste xmodule=vesa eigentlich gehen (mit oder ohne modesetting wäre zu testen) wenn mit kms, dann aber ohne vga=791

greetz
devil

Offline jp

  • User
  • Posts: 19
[gelöst] neuer Kernel - neues Prob mit Intel 852/855 GMA
« Reply #4 on: 2010/10/25, 20:17:33 »
@ devil

Genial!

Ohne "vga=791" funktioniert's. Ich dachte, der cheatcode verbessert nur die Darstellung der ersten paar Bootzeilen.

Danke!

jp

Offline devil

  • Administrator
  • User
  • *****
  • Posts: 4.846
[gelöst] neuer Kernel - neues Prob mit Intel 852/855 GMA
« Reply #5 on: 2010/10/25, 22:32:12 »
vga=foo beisst sich mit KMS.
wenn also KMs enabled ist, sollte vga=foo weg.

greetz
devil

Offline towo

  • Administrator
  • User
  • *****
  • Posts: 2.942
[gelöst] neuer Kernel - neues Prob mit Intel 852/855 GMA
« Reply #6 on: 2010/10/25, 22:33:15 »
Nicht sollte, muß weg.
Ich gehe nicht zum Karneval, ich verleihe nur manchmal mein Gesicht.